Odin won't flash my ace S5830iSupport


  1. Vinay Saxena

    Vinay Saxena New Member

    Hi all,

    I bought my Galaxy Ace S5830i last month. I hadn't installed Samsung Kies until yesterday, when I launched it it prompted a firmware upgrade. First I tried to use kies to upgrade but whenever the upgrade process started (Kies started downloading the firmware files) my device automatically got disconnected..I tried reinstalling kies, restarting my phone but nothing worked.
    I then decided to use odin(v1.87) to flash the firmware on my device but it kept failing at first step itself. Here's what it said :-

    <ID:0/010> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> S5830iXXLF3_S5830iODDLF1_RST_S5830iDDLF1_HOME.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/010> Odin v.3 engine (ID:10)..
    <ID:0/010> File analysis..
    <ID:0/010> SetupConnection..
    <ID:0/010> Initialzation..
    <ID:0/010> Set PIT file..
    <ID:0/010> DO NOT TURN OFF TARGET!!
    <ID:0/010> Get PIT for mapping..
    <ID:0/010> Firmware update start..
    <ID:0/010> sbl.bin
    <ID:0/010> NAND Write Start!!
    <ID:0/010> BcmCP.img
    <ID:0/010>
    <ID:0/010> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)


    I am at my wits end now so can anyone please help me sort out this problem?

    Thanx in advance :)

    Advertisement
  2. ayush29k

    ayush29k Well-Known Member

    Were you able to turn on your phone after the phone disconnected from Kies?
    Describe what you saw on the phone screen pls...
  3. Vinay Saxena

    Vinay Saxena New Member

    The phone has been working as fine as ever. Kies never got to the step of INSTALLING the new firmware as whenever it started downloading the firmware files my phone got disconnected so no damage there.

    With ODIN I entered download mode but here too it fails at the beginning, so I just switch off my phone and restart it and it works as if nothing ever happened (I've made several attempts)
  4. ayush29k

    ayush29k Well-Known Member

    Well all i can say is you were lucky, if that disconnection had been in the middle of installation, you could have bricked your phone.

    Check if your phone has a stable connection with the pc first. Connect it with the pc, transfer a few things on and off(keep the connection busy) and wait and watch for atleast half an hour, if it keeps connected, you can rule out connectivity issue and focus at the flash procedure.

    Also check that you are using the correct versions of Odin, ops and firmware files. And that your phone drivers are up to date and properly installed.
  5. socrates0

    socrates0 Well-Known Member

    You have not mentioned which version you are on. you can check if there is a
    OTA (over the air) option available for your phone. For that you have to go to Menu->Settings->About Phone->Software Update. Of course for this a wifi connection is useful.
    Vinay Saxena likes this.
  6. Vinay Saxena

    Vinay Saxena New Member

    Its GB 2.3.6, baseband version: S5830iDDLA2

    I tried using OTA as you had suggested. It prompted that an update is available and downloaded 3.5 MB data and did a reboot. At the point where it mentions the model name it started installing (showed a progress bar) reached 7% and then suddenly the screen went black, came back again and the phone started as usual with the notification- installation of files has failed. I've tried thrice with the exact same occurance :confused:
  7. ayush29k

    ayush29k Well-Known Member

    Take it to the Samsung Service centre and ask them to update your device.
    Also tell them of your problem, they might be able to suggest a solution, maybe there's something wrong in your phone, don't tell them anything about odin or rooting and unroot your phone if its rooted.
    socrates0 and Vinay Saxena like this.
  8. Vinay Saxena

    Vinay Saxena New Member

    yeah I guess I will have to go to the service centre.

    Thanks anyways for your help guys :)
  9. socrates0

    socrates0 Well-Known Member

  10. gordona

    gordona New Member

    I got the BcmCP.img fail message when using Odin 3.09 but I managed to flash the S5830i using Odin 3.07 (run the Odin program as an administrator)
Loading...

Share This Page