Odin won't write PDA, etc... stalls


Last Updated:

  1. FriedBunny

    FriedBunny Member This Topic's Starter

    Joined:
    Oct 29, 2010
    Messages:
    11
    Likes Received:
    0
    In attempting to flash from stock 1.6 to a modified ROM (bearsfan's, microhaxo's), somehow I managed to wipe out the OS partitions (but none of the boot) and yet Odin refuses to finish a flash - it just stalls at the point where it should write the system partition(s).

    None of the stock packages I found on this forum will flash, either (T939UVJA3 1.5 or T939UVJE2 1.6). Trying to flash phone and pda together AND separately both fail, as does the use of any One Package.

    Occasionally it appears to be working and the progress bar will move, but download mode never spits out any "OKAY" acknowledgement onto the phone's screen. BH_MAN's modified recovery partition loads, but ultimately only comes up with a "5%" screen and stops.

    I've tried to flash on three different computers, Windows 7 and XP (all 32bit); also tried direct usb and with a powered hub. I've tried Odin 3.88 and 4.03. Odin 3.88 seems to work the best, but the two progress bars move until the bottom red one finishes and then it stalls - phone doesn't acknowledge a PDA flash or reboot.

    Powering on will show the cartoon phone connecting to the computer icon. Stock recovery mode fails and tries to load into download mode, but shows white bars at the top and bottom. Download mode loads and connects.

    So at this point I'm simply befuddled. Did I somehow corrupt the nand so that now it won't accept system flashes? Should I have rooted and fiddled around with adb first before trying to Odin? Arrrrrg!
     

    Advertisement
  2. FriedBunny

    FriedBunny Member This Topic's Starter

    Joined:
    Oct 29, 2010
    Messages:
    11
    Likes Received:
    0
    Tried most of the suggestions in this thread.

    Here's a more exact idea of what the phone does when I try to flash it: Gets past the kernel flash (1/5) and the screen displays...

    Code (Text):
    1. zImage write to nand
    2. writing 6291456 bytes to KERNEL (Id:4)
    3. - OKAY
    ... then it stalls, while Odin reports that it's trying to start the system download.

    Attached is Odin 3.88 failing after flashing the kernel but not system.

    If I were to modify/find a rom that only had a #5 System partition, I wonder if that would flash by itself?
     

    Attached Files:

  3. FriedBunny

    FriedBunny Member This Topic's Starter

    Joined:
    Oct 29, 2010
    Messages:
    11
    Likes Received:
    0
    Some small amount of progress... if you consider isolating the problem to be progress. Managed to flash all of the different partitions in the OPS file except for #5 System. Did this by extracting the individual partitions from 1.5/1.6 update tar.md5's/onepackages, repackaging them using the instructions here, and then using Odin to flash them.

    Behold2.ops:
    Code (Text):
    1. 0,partition
    2. 1,arm9boot
    3. 2,arm11boot
    4. 3,amss
    5. 4,kernel
    6. 5,system
    7. 6,userdata
    8. 7,recovery
    9. 8,cache
    10. 9,
    11. 10,
    Of those partitions, I was able to successfully flash each - except for system and #0 partition (which the phone said hadn't changed and didn't need updating). Even the bootloaders took just fine.

    So I'm just about at the end of my rope. I can't get ADB to see the phone in the (failed) recovery mode or download mode. Flashing all of the other partitions doesn't seem to matter if I can't get system to write, it's stuck without a platform to load/recover.

    Anybody have any ideas? :(
     
  4. Jr_223

    Jr_223 Member

    Joined:
    Jul 7, 2010
    Messages:
    15
    Likes Received:
    0
    maybe try odin v4.03 and reflash? Idk!
     
  5. FriedBunny

    FriedBunny Member This Topic's Starter

    Joined:
    Oct 29, 2010
    Messages:
    11
    Likes Received:
    0
    Mmm, thanks - I've tried pretty much every version of Odin I can find, though. Odin 3.88 works for flashing and does the progress bar thing, 4.03 flashes but doesn't show a progress bar for System flashing, and 4.16 shows a progress bar but gets stuck when it appears the flash should be done and doesn't reboot the phone (or show any diagnostic messages on the phone itself). Obviously none of them have succeeded in flashing a #5 System partition yet, unfortunately. :\

    I have thought about alternatives, like the Galaxy S flasher Heimdall, but newer Odins or that open-source version don't have proper support for our piece of crap BH2.

    Newer Odins, by the way, appear to have a "repartition" option that I'm intrigued by. I can't help but wonder if there's some way to force a repartition that might clear up whatever is blocking the writing of the system partition...
     

Share This Page

Loading...