Official 2.1 Eclair and Contacts now showing; known issue?General


Last Updated:

  1. hakujin

    hakujin Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    454
    Likes Received:
    36
    updated to official 2.1 update on Moment. Whenever I attempt to add contacts, they don't show unless I search. If I sync gmail, those contacts show, but then not even the ones I added manually show up, even by search. Maybe they were overwritten in the sync...o.k. So I add them again, they JUST DON'T SHOW UP. WTF is this crap. I like google and all but are we actually expected to only use gmail/google services to manage our contacts?

    Please HELP before my wife rips my throat out for updating her phone! Time is running out!:eek:
     

    Advertisement
  2. p2theg77

    p2theg77 Member

    Joined:
    Feb 28, 2010
    Messages:
    17
    Likes Received:
    3
    have you done a reboot and just let the phone seat for a bit? My girlfriend I both have the Moment. My flash went quick and easy and the contacts loaded up fairly fast...but I did my flash at like 2am. Her phone flash had a couple of hiccups and the sync took a little while to finish and even a reboot to get all the contacts back and running correctly. Her flash and sync happend around 1pm. The Gmail servers could be getting slammed with everyone trying to sync their newly updated phone.

    Sorry if this doesn't help but trying a reboot let it sit for awhile and come back to it.
     
  3. hakujin

    hakujin Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    454
    Likes Received:
    36
    yes, reboot. the thing is, it should be instant. I'm talking about local contacts. I eventually got it working, but ran into another issue whereby I removed contact groups from sync, and decided to add them again, and kept getting 'vcore error' force closes. this problem was incidental but required a soft reset in order to get sorted.

    before i soft reset, i was finally able to view local contacts by choosing a BLANK contact group (accessible from display views) that randomly popped up ; but after soft reset, there was no blank group to choose so back to square . Eventually I deduced taht I have to choose google 'my contacts' to see contacts that I've added to the phone manually; not the more likely show other contacts, but 'my contacts, in order to see local contacts. Hell, I say more likely but honestly, it's counter intuitive (and slightly stupid) to even have to choose to display local contacts (as they aren't by default), let alone from a sub menu item below 'johndoe@gmail.com'. It shouldn't even BE BELOW GMAIL, as it is a LOCAL PHONE CONTACT.

    I think the new contacts manager is flaky at best.
     
  4. hakujin

    hakujin Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    454
    Likes Received:
    36
    correction to title: NOT SHOWING LOCAL contacts. It was a typo. I apologize.
     
  5. SirCheese

    SirCheese Well-Known Member

    Joined:
    Jan 23, 2010
    Messages:
    148
    Likes Received:
    2
    NM! It seems so!
     
  6. SirCheese

    SirCheese Well-Known Member

    Joined:
    Jan 23, 2010
    Messages:
    148
    Likes Received:
    2
    Backup progs and contacts? Most are on Google, but just be safe :)
     
  7. hakujin

    hakujin Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    454
    Likes Received:
    36
    this is a bug... have found more w/ same problem on google groups. it's frustrating to say the least. Results are mixed now w/ soft reset but essentially local contacts don't display properly w/o displaying google's 'my contacts'. And I still don't understand what 'all other contacts' are, just that if I sync w/ google contacts, every tom, dick, and harry gets added whenever somebody emails me, and if I use groups such as family, co workers etc, and un check 'my contacts', none of the locally added contacts show w/ search. that's nonsensical. dis-playability of local contacts shouldn't even be under 'jonndoe@gmail.com' in the display options, it's counter intuitive. Ergo, vanilla eclair contacts manager on the moment sucks. The only acceptable solution i find is not syncing w/ google contacts anymore. Luckily my wife doesn't like to constantly sync her contacts in gmail w/ that in her phonebook, LUCKILY...

    Now I'm hesistant to upgrade my Hero. Though I think Sense will resolve this issue, I'm going to wait for cooked rom update, root, nandroid, then update.
     
  8. 9Nails

    9Nails Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    85
    Likes Received:
    2
    In my case, contacts were being blended between local contacts and Gmail contacts. My particular situation, my son and I had our contact imformation merged. When my son called my wife, her phome ID showed up as me calling her. But I was driving the car with my wife in the passenger seat!

    I tried everything to get our contact info seperated, including deleting all contacts, deleting my contact, deleting my sons merged contact info, creating new contacts on the phone or at Gmail... eventually, the combination to solve her issue was to give my son a different first name. Like if his name was John, I had to enter his first name as Johnny. Thenput his name into a nickname field so that we could find him in a search.
     
  9. sboggus

    sboggus Well-Known Member

    Joined:
    Nov 4, 2009
    Messages:
    53
    Likes Received:
    5
    I don't know if this is new to 2.1 or if I just didn't notice it before. A chunck of my contacts have miraculously been sent to the category 'all other contacts'. They weren't displaying in my contact list, but showed up when I searched the name. When you look on line at gmail, this is obviously the difference in All contacts and My contacts. I think this is similar to what you are describing. In contacts on the phone, if you press menu, display options, then select the email account, you can check all of the groups or selectively check the groups to display. It was the 'all other contacts' that was not being displayed.

    My question is where did the 'all other contacts' group come from, because it is not defined in gmail. I would like to start from scratch with no categories, but I haven't found the rhyme or reason to how and why this is created and how the contacts got there. I do see alot of the newer contacts are there, but older ones as well.

    I know this will be a big shock to all of you, but Sprint says to do a hard reset and 'see what happens'. Wow. Did you know you can solve world peace if you reset your phone? Well, I assume so, since Sprint suggests a reset will fix anything they have NO CLUE ABOUT. I get tired of educating them about their own phones. Sorry, rant is over now.

    Anyone have a clue about this category?
     
  10. Bedrock_66

    Bedrock_66 New Member

    Joined:
    Jul 4, 2010
    Messages:
    1
    Likes Received:
    0
    Hi - I'm new to android but this may be a workaround for this problem. Create the contact as normal, then start to share with google mail. Then back out of the e-mail - the contact then appears in your contact folder. Hope this helps. The contact must have a telephone number for this to work (i.e. if you test this with no number it does not show up in contacts)
     

Share This Page

Loading...