[OFFICIAL SOLUTION] 3G issues on the 3D?Support


  1. Vinter

    Vinter Well-Known Member

    we did the phone step by step thing from the xda fix, we're going to the repair store now
    EarlyMon likes this.
  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    To clear any confusion - on the phone, we did ##data#, enter MSL, restore - fail! - ##768#, enter MSL, reset - phone goes into activation again - fail! - ##data#, MSL, restore - fail! (where fail = get right 3G results)

    And my philosophy is simple - never let the minor inconvenience of having to re-do your apps and config prevent you from doing a hard reset. Resets clear out bad/stuck bits in memory, and quite often - it's the only solution. Better to just get it over with - if you go in for service, eventually they'll do that anyway.

    So - never prolong the agony. And what do you lose resetting a phone you're positioning to have to return? Nada. Zip. Nothing.

    To answer your question - the test cost me nothing. However - now that I've switched to RS insurance, they warned me that the next one will run me $35 - with Sprint insurance, it's free.
    marctronixx and Jackietreehorn like this.
  3. Vinter

    Vinter Well-Known Member

    Sprint service tech wouldn't look at the phone, we had to go back to the store where we got our phone, another extremely rude group of employees, we got new phones, no dice... it took 15 min to download speedtest.net

    just gonna sit on the phone for a little while, see if there is an update or some sort of magic that fixes the speed .. otherwise I'll be moving on from this awesome phone :\

    the thing that pisses me off is i sat on my couch with my sisters 4g, dl speedtest, tested it and got a 1.2 mb d/l and decided that it would be an ok move....

    two etfs is what is really getting me angry
  4. EarlyMon

    EarlyMon The PearlyMon Moderator

    Well - they definitely have a bad batch happening out there.

    I'm back (really bad signal at the store location) home and -- this one is no better.

    Given that the Sprint tech was clear: my previous unit had a hardware defect -- and this one is behaving the same -- I'm likely going to return this to the store I got it from for refund, then try my luck with the batch at the Sprint corporate store.

    If you're sitting on one of the bad ones, no software fix is going to help. Food for thought.

    Well - through adversity to the stars! :)
  5. Vinter

    Vinter Well-Known Member

    Ya, idk.. gonna call Sprint tomorrow... I will never walk in the door of that store again after being disrespected, as well as my wife.

    So not sure what other option there are, but one thing I do know is on my Vibrant some modems hardly worked for me getting signal, others gave me great speed/coverage which is why I assumed there may be a ota fix that could help.
  6. EarlyMon

    EarlyMon The PearlyMon Moderator

    FOREHEAD SLAP.

    It's official - I'm an idiot.

    To use speedtest.net -- if you get a bad reading, you change servers to ensure it's not just a bad server. Not the phone's fault if a server is bad.

    On my broken unit yesterday, I did that by force of habit - bad results everywhere.

    So, tonight it hit me I'd not done that with my replacement.

    Ta da - 3g speeds on the order of 1 Mbps down, 500k up, +/- depending on the server. Try Spokane, WA - it's one of many responding decently (that can change hourly, btw).

    I'll have to monitor this a little bit to see if all other issues I had are cleared up (GPS, web loading) - but this is looking pretty good so far, including the few web sites I've tried in wifi vs. 3G to compare.
    marctronixx likes this.
  7. Vinter

    Vinter Well-Known Member

    marctronixx and EarlyMon like this.
  8. EarlyMon

    EarlyMon The PearlyMon Moderator

    toad6386 likes this.
  9. Vinter

    Vinter Well-Known Member

    i seem to be according to open signal hitting up 3 "towers" less than a mile or two away and the 4th being below me about a mile or so away roaming

    and they seem to pop off of each other often, and the strength or w.e on the map listing shows either 10 or 11 received strength

    right now, i'm getting 4 ... at a place i could be at in about 35 seconds in a car
    EarlyMon likes this.
  10. toad6386

    toad6386 Well-Known Member

    EarlyMon likes this.
  11. EarlyMon

    EarlyMon The PearlyMon Moderator

    Yeah - with my bad unit, I was drifting between 4 towers near me, mostly 3.

    Now with a working unit - I'm locked to the tower east of me that my Evo has always just locked to (it's my desk - aka reference location).

    And my signal is now only fluctuating between -75/-73 dBm for a tower at 1834 meters - a working unit seems to be rock-solid.
  12. atg284

    atg284 Well-Known Member

    Well, It appears I have the 3G issue as well. I drove out to a known good 4G and 3G spot updeted the profile and PRL to no avail:(

    Im geting a large ping and upload/downloads in the 100's

    Looks like I will have to go to a sprint store tomorrow. I bought the phone over Telesales do you guys and gals think they will be able to replace my 3VO there or will I have to ship it back for a new one?

    Looks like it WiFi for me until I get this fixed. I really wanted to customize it tonight too :(
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    I believe if you're going to a corporate store, they won't care that it was bought online.

    Best luck!
    marctronixx likes this.
  14. atg284

    atg284 Well-Known Member

    By corporate store you mean one that they own and not one like in a mall?

    Also I can't seem to able to set up an appointment online. Does anyone know how to get to chat support on Sprint.com? I did it once and now I cannot find if for the life of me.
  15. EarlyMon

    EarlyMon The PearlyMon Moderator

    On Sprint.com, goto Support, device, choose phone - on the right panel is an option to start a conversation. If I missed a step, look for the contact us link at the bottom of the page.

    I think they have a store locator too.
    marctronixx and atg284 like this.
  16. atg284

    atg284 Well-Known Member

    I dont see the online support link. I'm going to try to do a power cycle and then call it a day. I just hope they can take care of me at the store tomorrow :(

    Thank you so much for your help EarlyMon
    EarlyMon likes this.
  17. MikeCzipri

    MikeCzipri Active Member

    I am really regretting my decision to get rid of my EVO 4G and get this phone. MY 3G download speeds are typically as follows....

    Ping 1800-200 ms

    10-25 Kbps down
    200-300 Kbps up

    Terrible. Absolutely inexcusable. Tried all the tricks, none of them work. Really hating this phone right now.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    Notice my posts above - I got a lemon, you may have, too. Have Sprint perform an RF test on your phone, likely they'll find it's defective. My replacement is equal to my Evo in great performance.

    Presuming you've tried multiple servers in your speed tests.
    BenChase7 likes this.
  19. MikeCzipri

    MikeCzipri Active Member

    Well. Foot in mouth. Did a hard reset, re-activated phone, re-installed updates...and here are the results over 3G

    ping 340 ms

    1.15 Mbps down
    .67 up

    Not bad at all. I spoke to soon.
  20. atg284

    atg284 Well-Known Member


    Well the verdict is in!

    Turns out a hard reset is what it needed. I asked the service rep at my local store about the RF test and he said they couldn't do it at that location but another one. I figured that though. I was information gathering to start the day off.

    He asked me if I would mind if he hard reset it and I remembered what you said earlier in this post EarlyMon. Something along the lines of "Life is short so move on and get it over with" type of sentiment.

    I said do it and it started getting better speeds than his :D

    One downside is that the location of where I live has bad 3G but at least it's not the same when I go out now. I was getting horrible speeds everywhere.

    I will be watching and checking it over the next couple weeks and will report back here if it goes south.

    Thank you for all your input!!!:)
    EarlyMon likes this.
  21. MikeCzipri

    MikeCzipri Active Member

    Hard reset did it for me. Had to spend another 2 hours re-downloading all my apps, setting them up, etc, but am now seeing speeds up to 1.6 Mbps down and 1.2 up on 3G. That's way better than my evo 4g....best speeds I ever saw on that were around 1.2 down and 1.0 up.

    4g reception seems to be better too....more bars in more places. Speeds are still about the same, best I have seen is around 8 mbps down, up always seems to stay the same at around 1.2 mbps.

    Before I did the hard reset I contacted cust service...even went so far as to reset the data profile and re-activate the phone from scratch...didnt work.

    If you are seeing poor 3G speeds I seriously recommend doing the reset. Customer service will give you the code that you need to do it.
    BenChase7 and EarlyMon like this.
  22. EarlyMon

    EarlyMon The PearlyMon Moderator

    Glad to help. :)

    It's the Evo all over again.

    Initial software is quirky, updates rolling quickly, and PRL update, resets, hard resets, reprovisioning and return of bad units are fixing radio issues.

    Can't wait for the equivalent of the Evo 1.47 update.

    Time to restructure this as an official thread.
    atg284 likes this.
  23. MikeCzipri

    MikeCzipri Active Member

    What was the 1.47 update on the original Evo?

    Only updates I ever got were from eclair to froyo...then the update that forced me to have the stupid blockbuster app and gave me swype (so half good, half bad) and then from froyo to gingerbread...I'm not too saavy with the numerics of it all.
  24. NSXLA

    NSXLA Well-Known Member

    haha i just posted that on the app (speedtest) review lol same nick as here lol

    lets not forget our phones are flashed enabled so we can also run speedeasy web tests. ;)
    EarlyMon likes this.
  25. EarlyMon

    EarlyMon The PearlyMon Moderator

    1.47 was a big stability update.

Share This Page