"ok google" not workingSupport


  1. androidguy011

    androidguy011 New Member

    For some reasons, the "ok google" voice activation is not working on my s4. Anyone else have this problem. It was working fine until a few days ago. I try restart and reboot my phone, active the hotword and everything, and the google voice activation still not working. After I ask "ok google" once, the mic becomes hallow and I can't voice activate it again. Any help is appreciate it!

    Advertisement
    :
  2. electricpete

    electricpete Well-Known Member

    Can you explain what hallow means?
    Does it always work the first time or that sometimes doesn't work either?
  3. electricpete

    electricpete Well-Known Member

    One thing that seems to come up regularly (but may not exactly fit here).
    Make sure you are talking to the mic port on the bottom of the phone and that it is not filled up with lint or covered with your case.

    I looked at my case and saw the hole for the mic was TINY and partially covering the tiny mic, so I enlarged the hole in the case (with a drill) and Google understands me better now.
  4. electricpete

    electricpete Well-Known Member

    Another thing to double check (although I don't know why it would change).
    Settings / my device / language and input / voice search /
    make sure there is a checkmark next to "hotword detection" for ok google
  5. AeolianReflex

    AeolianReflex Well-Known Member

    I had the same problem. The prompt in the search bar "Say Ok Google" was missing. I went into settings > applications and cleared the cache for Google Search and haven't had the problems since.
  6. fezzik

    fezzik New Member

    This has been driving me nuts for weeks. Finally spent a bit of time on it and found the conflict (which in hindsight makes sense). I have MacroDroid installed and set to read my texts to me when I have headphones connected.
    After trying all the other things people have recommended, I turned off my macros in MacroDroid. Still no "OK Google" option and the microphone was an outline. I uninstalled MacroDroid and "OK Google" worked and the microphone symbol in the Google Search box is filled in (i.e. All grey)! (note - it does not say "OK Google" in the search box, as I guess I passed the number of training searches before this goes away, but saying "OK Google" works.)
    I then reinstalled MacroDroid and turned on my macros and it still works. So, check if you have any apps that have voice notifications and try uninstalled them, checking if "OK Google" works and then reinstalling them.
    Hope this helps someone else.
  7. Mcgiveral

    Mcgiveral New Member

    My "ok google" was working great when I first got the Galaxy S5. I installed several apps into it that I had on my S3 and missed them. Next thing I know my "ok google" wasn't working! I played around with shutting down or removing many apps but it still didn't work. Then it dawned on me, I also put back the missing app that the Galaxy S3 used to have called " Active Weather Wallpaper ". I changed the wallpaper to one of the stock ones in the phone and everything was working again. This app when running was blocking the "ok google" from listening.

Loading...

Share This Page