1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice


Last Updated:

  1. Chiryder

    Chiryder Well-Known Member

    I don't know what happened. But when I set the stock clock alarm, every once in awhile, if I get a text or email or something before or during the time my alarm will go off, the pop-up (snooze/dismiss) won't come up. So it'll keep on going and going and going and going until I have to turn the power off to get it to go off.

    Any suggestions? Is there a better app?

  2. viper941

    viper941 New Member

    I have had the same thing happen. It will also happen if you tilt the phone causing it to rotate screen (sometimes). Just a glitch you learn to live with until they fix it in an update.
  3. jamirgrs

    jamirgrs Member

    I too have had this happen to me with the ascend 1 and 2. Although its annoying, I just have done the same thing and had to power down my phone. :(
  4. xedis

    xedis Member

    Ah yes much fun trying to hold power button while still passed out. I've found tearing the protective case off and ripping it apart during its relentless barrage of wonderful alarm noises to be waaaaaayyyyy easier....I have several alarms set a few minutes apart so its even worse.....*cringes at the memory*

    Sent from my M865 using Tapatalk
  5. tanporakuda

    tanporakuda New Member

    This just happened to me for the first time. Horrible glitch.
    One "solution" I found: set up another alarm for the next minute and when it rings stopping it will stop both. Faster than turning the phone off.
    papituro likes this.
  6. 787323

    787323 Well-Known Member

    Lol this happened this morning with some girl that was sleeping in my bead had this phone. We ended up just shutting if off and then turning it back on, after 10 minutes of frustration
  7. actualsize

    actualsize Member

    Thats hilarious. You could always try changing the selected sound, I bet that stops it. But maybe not. Hey, at least you could pick a better song.
  8. MWT_seadog

    MWT_seadog New Member

    The solution is amazingly simple. Go to settings > personalisation > manage notifications > all, then scroll to the clock and put a tick in the empty box. Your slides and side buttons will now work again.

Share This Page