One-Click Root for DX2 2.3.3


  1. bryan240g

    bryan240g New Member

    HELP!!! I am a newbie MORON, rooted phone and in trouble.
    So last night I rooted my phone. All went ok until I thought it might be a good idea and try and remove some bloatware. I think I deleted something important because when I go into my contacts list i can scroll thru the list BUT when I make a selection it takes me right back to the home page even after rebooting.

    This morning I panicked and decided that it would be a good idea to do a factory reset. I think that was a bad choice because it formatted my sd card and I cannot undelete the files.

    Is there any way I can get my phone back to normal and unrooted? I just want it back to stock.
  2. Scur

    Scur Well-Known Member

    Sync your contacts with your Google account so you'll always have them no matter what.
    Look through this xda thread and grab the Gingerbread 2.3.4 SBF file and RSD Lite (I've always used the 5.3.1 with 100% success) and follow the instructions to flash your phone back to stock.
    Add your Google account again and make sure you sync your contacts again, and you'll have them back.
    Hit the market on your computer and look at your library. It should list all your apps (the first 10 pages anyway, the market is screwy like that) so you can easily reinstall them all.
    That should get you back.
  3. kgreendenver

    kgreendenver Well-Known Member

    I've owned many phones and i have to say this is by far the most simple phone to root!
  4. Perry.Saints

    Perry.Saints Active Member

    Ok, I'm not a newbie . Ive rooted many phones and even modified build props. This phones root proces is giving me a headache. I have Gingerbread version 2.3.4 , I aquired it from my brother, it was never rooted but it was updated and factory reset. Using the link above posted by poete I CANNOT root the phone. I already have file explorer intstalled so when I do have rot I can check (my prefered method, also modify data etc;) I have tried many diffrent usb settings can someone tell me what I'm doing wrong? I have big plans for this phone with QPST ave I just need to aquire root. I have neber had this issue before. Its not my cables or ports either because ibe tested them all with other androids and they work.
  5. coolpoete

    coolpoete Well-Known Member

    When you say it was updated and factory reset are you still on 2.3.4 or are you now on 2.3.5? Did you take the OTA update?
    Perry.Saints likes this.
  6. :( Ok so I've been trying for about a week to root my DX2 and still cant get it...

    I've tried every root i can find and nothing... everytime i try to download the Moto End User Drivers when i get to the installation part i get an error message saying:

    " This installation package is not supported by this processor type. Contact Your Product Vendor".

    Is there anything else i can download/use to root my phone?
  7. coolpoete

    coolpoete Well-Known Member

    If you have the 2.3.5 update you cannot follow any of the rooting methods described. Right now there is no direct rooting method available so you have to do a work around. Here is a breakdown of what you have to do:

    - Restore your phone back to 2.3.4 by performing a SBF
    - Download and install Voodoo OTA Root Keeper from the Google Play store, run it to protect your SuperUser access from not changing when the update is performed.
    - Accept the 2.3.5 OTA update. You should still be rooted.

    Read through the thread here to find out more specifically and what others are doing.
    Official 2.3.5 Root Method for Droid X2 1.3.418 OTA update - xda-developers

    Personally I will not be accepting the 2.3.5 update so I am not familiar with this process specifically but if you follow it to the tee you should be able to regain root. Hopefully soon someone will be able to crack the 2.3.5 security and make a new root method program.
    Chris_droid619 and Perry.Saints like this.
  8. Perry.Saints

    Perry.Saints Active Member

    This phone DID receive the latest update before being factory reset-but I rooted it using an old method.
    read on !


    I spoke with my brother after reading your post, Poete. He informed me he had done the update for some reason I cant ever have luck with mediafire , every time I try to track down the SBF files the links are dead. So using the link above from droid.life(petes roott tools) I decided to experiment in the name of science , plus I have several phones and thus one was free . So I grabbed a shiner , sat on my couch and have it a go. I set the phone into charge only mode and then clicked ADB temp root. Success everything worked, I had root ! But I know how temp works . I figured why not ruin the program again this time choose regular root. Success! Super user stocks and everything. I have the chinese boostrap with a working nandroid backup, I cleaned the boat off and mow im going to try to flash a pre update rom , then a post update rom to see how this phone handles it. Thank you for your help. I appreciate it.
    coolpoete likes this.
  9. coolpoete

    coolpoete Well-Known Member

    Cool. If you are good with ADB push commands you can do more with the phone. Glad you got it working that way.
  10. Coolpoete thank you for the information it certainly clears some things up .. when I get the chance ill try your instructions and ill let you know how it goes
  11. :mad: So now I switched back to 2.3.4 but it wiped out my service ( I flashed my DX2 to Cricket) nd i STILL cant get my damn phone rooted...

    Now I have no root and Im gonna have to spend another $50 to flash my phone again FML
  12. Veeshnoof

    Veeshnoof Member

    I am trying to unroot my Droid X2, but I can not download the system/app files from the links in the application. I've tried Google, but can't find a copy. Any leads?
  13. droidmanx1

    droidmanx1 Active Member

    Hi everyone,

    I have a unique question. I live in a rural area but have 3G coverage. A friend of mine is ditching their X2 and I can get it for nearly free. The contract expires next year, and I DO NOT want to renew it.

    My interest in the phone is not as a cell phone but rather as a handheld computer for use at public WiFi hotspots.

    With a rooted phone it seems it would be useful this way to some degree, even without a 3G link. Is this correct? Can apps be downloaded through a connection to the internet via a public hotspot? I know this is possible with earlier iPhones.

    If this is a real possibility, what might I need to obtain or do while I still have 3G (until next year)?

    Thanks! I know this is not a typical use of the phone, but I like the little thing :) Just don't have the $ for recurring monthly expenses. :(
  14. coolpoete

    coolpoete Well-Known Member

    If you only want to use the phone as a browser and to download apps you can do that without having to be activated on the Verizon network. Once the phone is not activated you won't be able to connect to the data network however the phone will continue to work on Wi-Fi just fine.

    There's another use for a phone not activated on the network, I read this just yesterday:
    How to turn your old cellphone or phone with a bad ESN into a home phone. - xda-developers
    droidmanx1 likes this.
  15. droidmanx1

    droidmanx1 Active Member

    Thanks coolpoete for that info.

    Just so I'm clear, I can obtain anything I might need to root the phone without it being activated (by using a PC on the Internet & a USB cable to the X2) ?

    Doesn't sound like there's any concern for getting any updates or apps or whatever while still activated.

    One thing I'm not clear on is versions. Under settings, About phone the Android version on my phone is 2.3.4. I don't see the firmware version, unless it is "System version" which is 4.5.621.MB810.Verizon.en.US.

    When I check for updates there are none, yet I see people referring to 2.3.5 here on the forum. Also, v2.3.2 is Froyo, and 2.3.3 is gingerbread, right? Is "GB" short for Gingerbread / 2.3.3? So what is 2.3.4? I never see a name for that version. I also presume 2.3.5 is the Ice Cream Sandwich, is that correct?

    Sorry for the 3rd degree, just trying to come up to speed. I see from your posts here you're a major contributor so I thought I'd ask.

    Thanks for all your help :)
  16. coolpoete

    coolpoete Well-Known Member

    Yes. Just follow the rooting methods posted in other forums/stickies.

    I wouldn't. 2.3.5 is a waste of time unless you are going to want to flash the Eclipse ROM. It's not necessary if again all you are going to do is use the phone as a wi-fi browser. Plus, I think that if you go to 2.3.5 and then try to go back to 2.3.4 you have to perform an SBF, and the first screen would ask for an activation. I think it will work on Wi-Fi anyway, but I'm not sure if you can get past that screen. Someone else please confirm that for me. Either way, unless you are curious and want to get some practice in with flashing and restoring then I would not worry about it.

    Not quite. Gingerbread or "GB" refers to version of Android that references 2.3.x. Ice Cream Sandwich starts at version 4.0.x In between there is Honeycomb which was mainly for tablets at 3.x.x See article here for more in-depth info
    Android version history - Wikipedia, the free encyclopedia
    If you can't get an update it could be that the phone is already rooted. I know that Motorola had already pushed out the 2.3.5 over-the-air updates. Rooting the phone or changing some of the system files prevents the OTA download from happening. Do you by chance see a "SuperUser" icon in your list of program files?

    Not a problem, your questions are welcome. This is how we all learn. ;)
  17. droidmanx1

    droidmanx1 Active Member

    I seriously doubt the phone is rooted. I just hooked it up with a USB cable and browsed around and saw nothing like that, but that's probably on the SD card.

    I have looked at the system files. But this was a brand new phone with 1 owner until myself, and she hardly used the thing except as an internet modem for her computer. She never downloads apps or anything.

    With my luck I'll get the 2.3.5 update pushed to the phone when I don't want it (unless you can tell me a good way to prevent that). It would be nice to capture the state of the device as it is now, including pictures, contacts etc. that I could restore it to later, a complete snapshot so to speak.

    I've got alot of reading to do yet, so perhaps that is yet for me to discover. Thanks again for all your help ;)
  18. coolpoete

    coolpoete Well-Known Member

    The SuperUser access icon appears after you root the phone. It is in your list of apps in your app drawer. It would look like this
    [​IMG] or [​IMG]

    Yes, all of that can be done by Rooting the phone and creating what's called a Nandroid backup of the phone.
  19. droidmanx1

    droidmanx1 Active Member

    After reading up and playing around awhile I decided to try to root my friends Droid X2.

    I was successful in accessing the phone from a Windows XP VM running under Parallels, and also directly on the Mac (OSX 10.6.8 Snow Leopard).

    I don't recall seeing the connection choices everyone says occurs when the phone is plugged in to the PC, and this confuses me.

    First, I hadn't yet installed the Moto drivers for the Mac when I connected under the Windows XP VM. But even then I don't recall seeing that option.

    One thing for certain is I don't see that option now that the OSX drivers are installed. The phone is recognized OK, and I can browse folders on the phone in the Finder. But I never see any connection options when I connect the phone's USB cable.

    The Moto driver has a little menu containing an option "When device connects...", and I set this to "Do nothing". However, whenever I plug the phone in iPhoto is launched. I can't seem to get it to stop doing that.

    At this point I'm about to try uninstalling the Moto driver from the Mac and go for root under a Windows 7 VM, which I haven't yet installed the moto drivers for. I use alot of VMs, but this is an old Macbook Pro with only 3GB, so I have to suspend one VM to use another in many cases. (Windows 7 need at least 1GB to run well).

    I was going to run the "run_to_root_your_droid3.sh" script in a terminal window on OSX, but was uneasy because I have no idea what if the "charge only" mode is set or not, since I wasn't prompted fo it when the USB was plugged in.

    If anyone has a Mac and could comment on this I'd appreciate it. I'm using the Motorola Device Manager drivers right off the Moto website (MDM_Installer_2.0.22.dmg).

    PS - on one early thread (sept 2011) I read something like if you're running on a unix host "you don't need no stinking drivers". That makes sense to me, so I will first try to uninstall the MDM from OSX and see what happens when I plug the phone in. Now if I could just get them damned drivers uninstalled!

    Thanks for any comments you might have.
  20. droidmanx1

    droidmanx1 Active Member

    I uninstalled the MDM and drivers from OSX and started my Windows 7 VM. I installed the moto 5.2 32 bit drivers under the Windows 7 VM and plugged the phone in. Under the Parallels host software pops up a window to ask which machine or VM you want the USB to be connected with. I choose the Windows 7 VM of course.

    No matter what I try I never get anything popping up on the phone to choose a connection option. I do see notifications on the phone: 1) "USB Connection", 2) "Connection detected", then iPhoto pops up (if Parallels is NOT running). When the USB is unplugged in I get the notification: "Preparing SD Card".

    I wasn't planning on attempting to root the Droid quite yet, i only wanted to see if PetesMotorolaRootTools_v1.07 would recognize the phone. Unfortunately it didn't pause to ask, but proceeded to root the phone. I didn't interrupt it, and it completed all 3 steps and concluded with a "Success". But I'm pretty sure it didn't succeed in rooting the phone, as I don't see the superuser logo / app as I read above.

    The whole question mark stems from this "Charge mode" question. I bet that is the key, as having the thing NOT in charge mode prohibits a connection to the Droid's SD card, and I suspect the root tools don't work when the SD card is mapped.

    The only other option I have right now is to use another Windows 7 box and try to root using that PC. I will install the same moto drivers (v5.2 downloaded from mediafire link (Motorola_End_User_Driver_Installation_5.2.0_32bit.msi) in the rootzWiki page.

    Might another option be to power off the phone and remove the external SD card?

    I won't swear to it but I suspect that there's something different going on here than everyone else. I suspect that if I plug the USB cable into the Windows 7 box that has never seen the droid it will install default device drivers and the droid's external SD card will appear as a removable drive and that will happen without any prompting on the phone as to connection type. Perhaps that won't happen on the Windows box if the debugging option is turned on first. It depends on if the Windows 7 default USB driver for unknown devices maps the droid's SD card as a drive.

    It seems the only difference (still on the Mac) of the "USB debugging" option is whether a CD image is mounted. With that option off I still get the SD card folder as well as a CD mount with a few items (autorun.inf, config.ini, MotoHelper_2.0.45_Driver5.exe, setup.exe). If the debug option is on I don't get the CD mounting.
  21. droidmanx1

    droidmanx1 Active Member

    OK, so I tried a few things on a Windows 7 box that never saw a droid in it's life.

    1st thing I did was to see what would happen when I plugged in the Droid to the box's USB port. Just as I surmised the default Windows 7 USB driver provided access to the Droid's SD card, and the X2 provided no connection options at all, just the usual "USB connection" followed by "Connection detected".

    I saw no difference after installing the moto drivers, v5.2 64 bit. I tried to run the zergRush "runme.bat" script which was able to determine it was indeed a gingerbread 2.3.4 target, but ran into permission problems trying to copy things into place on the X2, which I suspect is all due to the external SD card being mapped to the Windows box as a USB drive. I also tried to just eject the drive and run the script but no difference.

    I tried to google "charge mode" with a multitude of variations for droid, x2 options charge options, usb options but couldn't find anything useful. The prompting behavior is always presumed.

    So I conclude by asking has anyone seen this behavior (no prompting for connection type upon inserting USB cable)? I looked all over in the phone to find a way to set such an option but didn't find anything.

    Oh, and I didn't mention that I'm using the original Verizon USB cable that came with the Droid. I'm 99% certain this is Moto cable, as it is labeled "ECOMOTO" with a SKN5004A 10320-0403532 part number. It says to connect the cable to the PC to transfer photos, video and music right on the Vcast tag. There is a little hologram sticker on the micro SD connector too.
  22. coolpoete

    coolpoete Well-Known Member

    I don't know abut rooting on a Mac but I suspect you will have some issues seeing as though you are running a virtual machine. Sorry, can't help you there. As far as rooting on a Windows Machine it's pretty straight forward as stated in the instructions. If you don't follow the steps such as install the drivers, put the phone in debug mode it won't work. I recently restored my phone and re-flashed and used the ZegRush method described, it was painless and easy. I'm running Windows 7 64. (make sure to install the correct drivers for 32 bit or 64 bit windows as well.)

    http://forum.xda-developers.com/showthread.php?t=1315711

    Under step 11 I upgraded the SuperUser but it is not neccessary to install Busybox.
  23. droidmanx1

    droidmanx1 Active Member

    You missed the main point...

    Sorry, I know I can be rather verbose. What I was trying to say was that the charge mode popup is difficult or non existent on my droid. Forget about the Mac. I was not finding any diff on the win 7 box either.

    Can you comment on this charge mode business? That's what I'm having difficulty with. All the instructions say that when you insert the usb plug that you will get a prompt and you select the charge mode, only I'm not seeing that prompt. Thats the problem. If the lack of a prompt is because I plugged the droid into they usb be 4 I install the drivers, that needs to be stated in the instructions. I've seen plenty of other devices were they're very explicit about the order that you plug things into the usb, or the drivers must be nstalled first etc. It seems that if that were the issue you would see many other posts raising this "no charge mode" prompt issue.

    Note that on the Win 7 box no VMs are involved. Also, this is being sent from my droid as my friend cut off the hotspot option on the account. Is that something a ROM can get around (tethering), or is that Verizon limitation?
  24. droidmanx1

    droidmanx1 Active Member

    My humble apologies if I seem to be a rather adament about getting this resolved; I guess I do that alot. Perhaps you didn't address several of the points i raised b/c it was just too verbose to wade through. No worries, I understand if thats it. I do appreciate your help coolpoete.:)
  25. coolpoete

    coolpoete Well-Known Member

    Yes, I missed that point, thanks for clarifying. Yes, you need to install the motorola drivers before you plug the phone in. Once you do you, make sure debug mode is turned on. Then plug the phone in and you will see the USB icon on the top left. You should be able to do a menu pull down from the top of the screen and select a USB connection mode:

    [​IMG]

    As far as tethering is concerned once rooted you can install a tethering application that mostly involves root access but that does not mean it will be free or that you would not later incur charges. Some have reported that it showed on their bill others have said that it hasn't but seeing as though Verizon monitors data usage it's bound to show somewhere.
Similar Threads
Forum Title Date
Samsung Galaxy S 4G One-Click Rooting (4.3) Nov 28, 2013
(AT&T) Galaxy S4 - All Things Root One-Click Root (works for MF3) Oct 14, 2013
Torque - All Things Root Framaroot, a one-click apk to root some devices Sep 21, 2013
(Verizon) Galaxy Note 2 - All Things Root un-root and one-click root added to Verizon Note 2 Root Guide Apr 30, 2013
Connect 4G - All Things Root [ROOT] [CWMTOUCH] [WINDOWS/LINUX/MAC] One-click root (and unroot) for LG Connect 4G Dec 19, 2012

Share This Page