One Click Root for Magic / Dream / Pretty Much Everything


  1. XBrav

    XBrav Well-Known Member


    Advertisement
    :
  2. Akkuzo

    Akkuzo Well-Known Member

    So I could only find vague references to Rogers phones in the XDA thread. Does anyone know if this has been tried successfully on Rogers dream or magic post or pre 911?
  3. XBrav

    XBrav Well-Known Member

    Let me give a bit of insight:

    If you have read lately about the e911 Dream rooting method, it uses the same exploit found in this application.

    Simply put, the app automates that process. It gives you root access, without flashing the SPL, Radio, or a new ROM.

    Reading in the thread, they have had success with the HTC Magic (which is the Canadian naming), and the HTC Dream.

    The root method offers no means of bricking, because it simply uses the exploit to inject the SuperUser.apk into the phone, and give root access. It's one of those "If it works, you have root. If it doesn't, it'll say like 'denied'".

    Which device do you have?
    Akkuzo likes this.
  4. Akkuzo

    Akkuzo Well-Known Member

    I have a pre 911 dream and a post 911 magic. I wasn't sure if the thread was referring to the European magic or the Canadian one. Thanks!
  5. Crash27

    Crash27 Well-Known Member

    Worked great for my X10, failed the first time but second was a charm
  6. Akkuzo

    Akkuzo Well-Known Member

    So that all worked except that I needed to install superuser permissions manually after the app rooted the phone. So now if I want to installa custom rom I neede to start from step C in this guide?
  7. XBrav

    XBrav Well-Known Member

    If you've pushed the recovery image to /data/local, then do this:

    1) On your PC, run ADB shell.
    2) If you don't get a # prompt, type "su" without quotes, and SuperUser should give you clearance.
    3) When you get your root shell, type "flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img" without quotes.

    Then, you should be able to start at Step D.
    Akkuzo likes this.
  8. Akkuzo

    Akkuzo Well-Known Member

    So it all worked great on my dream. I'm running 5.08 with no problems. I know you kind of already went over this but just so I'm clear... this doesn't touch the radio - if i use this same method on my e911 magic I will end up with a custom rom and no data cut off?
  9. XBrav

    XBrav Well-Known Member

    No custom ROM even.

    Let me clarify:

    This "utility" just gives you root access. It does not flash any ROMs or Radios or SPLs or recovery images. It just injects the app that will allow you to flash a new recovery, at your leisure.

    Simply put, root access just means the ability to access functions locked out to a normal user access. This includes write abilities of all folders, flashing new partitions, etc etc.

    For the sake of now, root access will only be good for you if you are going to flash a new recovery image, so that you can flash a new SPL / RADIO / ROM.
  10. Akkuzo

    Akkuzo Well-Known Member

    Sorry, I wasn't clear. The old rooting method (as I understand it) flashed different radio version than the e911 radio. This one doesn't. So if I use this method to root, and then go on to flash a custom recovery and then a rom, am I correct that I will still end up with the current rogers radio and as such, will not have data cut off?
  11. XBrav

    XBrav Well-Known Member

    Here's the order that you HAVE to do things:

    1) Flash recovery
    2) Flash SPL from recovery (not sure which one it is for the Magic, it MUST be compatible with your radio version)
    3) Flash ROM

    If your phone has an incompatible SPL / RADIO combination, your phone is a brick.

    The key here is knowing which SPLs are universally compatible.

    Now, I would ask GreatBigDog01, as he knows the Magic much better than I do.
    Akkuzo likes this.
  12. Recc113

    Recc113 Member

    --edit-- This worked amazingly well on my post 911 dream --

    Alright I've reached an in-pass, I had originally followed THIS tutorial on my post 911 dream. Although in step D.1 my phone won't boot in recovery. It just stays at the rogers screen if I hold home, home + pwr, or any other combination I could think of. It does however boot normally so I tried following this 1-click process, although I'm pretty sure that from what I had done and what this 1-click app does is the same point, and I've reached the same point. I'm sure I did something wrong but I was wondering if someone knew where I went wrong and how I could get it working. Any help would be greatly appreciated, and thank you for your time.
  13. XBrav

    XBrav Well-Known Member

    Sounds like you flashed a bad recovery. For the Rogers Dream, you need that AmonRa v1.7.0R. If you use the regular AmonRa v1.7.0, it won't boot into recovery.

    Here's the recovery file you want:

    RapidShare: 1-CLICK Web hosting - Easy Filehosting

    Assuming you have ADB from the SDK running:

    (Anything in quotes, type, minus the quotes)

    1) Put recovery-RA-dream-v1.7.0R-cyan.img in the same folder as adb.exe

    In Command Window:

    2) Type "adb push recovery-RA-dream-v1.7.0R-cyan.img /data/local"

    3) Type "adb shell"

    4) Type "flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img"

    5) Type "exit"

    Now, you should have a new recovery for when you boot with HOME + POWER.
  14. Recc113

    Recc113 Member

    I have tried that, I downloaded the img from THIS tutorial along with the one from the previous one that I had linked, and both of them gave me the same problem. Does it matter if I run the recovery from su or not? Cause both times I've run it with those permissions.

    -edit- also when I try to run the recovery this is what happens.

    [​IMG]
  15. Crash27

    Crash27 Well-Known Member

    It said it rooted my X10 but It will not let me install Titanium Backup, it says not root access, Not sure if this is because it is not rooted fully or just partially, If anyone has any suggestions on a fix please let me know.
    Thanks
  16. XBrav

    XBrav Well-Known Member

    So the recovery is flashing fine, as you're not getting any errors. If you hold down the HOME key + Power, what happens exactly?
    Recc113 likes this.
  17. Recc113

    Recc113 Member

    rogers screen shows up and then nothing, if I let go after a bit the rogers screen disappears and I get a black screen and the lights stay on although nothing else ever shows up.
  18. XBrav

    XBrav Well-Known Member

    That is different... Go into HBOOT mode (Power+Camera), give me all the numbers in there :)
  19. Recc113

    Recc113 Member

    And I quote ;

    DREAM PVT 32B SHIP S-ON d
    HBOOT-1.33.0010 (DREA21000)
    CPLD-4
    RADIO-3.22.26.17
    Jun 2 2009,21:33:16
  20. XBrav

    XBrav Well-Known Member

    Ok, so that is the same details as mine was. I'm looking into it. For the time being, try this:

    1) "adb shell"

    2) (if not already #) "su"

    3) "erase_image recovery"

    4) "flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img"

    Let me know if erase_image works.
  21. Recc113

    Recc113 Member

    =/

    [​IMG]
  22. XBrav

    XBrav Well-Known Member

    Ok, no worries, they said that it only exists on rare systems.

    I am kind of baffled why it isn't booting. Basically, it sounds like the recovery partition needs to be wiped first on your phone. Problem is, I only know of one way to do it right now, but I don't know how risky it really is. Basically, here's my thought:

    "adb shell reboot-bootloader"
    "fastboot oem rebootRUU"
    "fastboot erase recovery"
    "fastboot oem reboot"
    "adb shell flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img"

    I am concerned that it may not boot properly without a recovery image. I'd consult Amon Ra @ XDA honestly. Sorry :(
    Recc113 likes this.
  23. Recc113

    Recc113 Member

    Well good news is that this is by backup phone, thus I don't really care if it bricks, I'd prefer if it doesn't, but which ever. Also if you want I can PM you my skype or msn and we could chat in a more personal matter if it'd suit you.

    -edit- although I've just received this error =[

    [​IMG]
  24. XBrav

    XBrav Well-Known Member

    sorry, should be "adb shell reboot bootloader", I was thinking of fastboot's bootloader reboot.
  25. Recc113

    Recc113 Member

    Before anything I've gotta thank you for your continuous help, I would of given up a long time ago had it not been for you. On that note, this is as far as I've gotten.

    Also msn or skype might allow us to have a quicker troubleshooting process, and we could post the solution here afterwards.

    [​IMG]
Loading...

Share This Page