[One Click][Updated]LG Spectrum All in One Pkg for Root, CWM Touch Recovery, and Unroot

Last Updated:

  1. hollywoods14

    hollywoods14 Well-Known Member

    if you are rooted already, just use the option for cwm only. Make sure all the correct drivers are installed. also make sure your phone is in internet/ethernet connection, and make sure debugging is enabled.

  2. Neph81

    Neph81 Well-Known Member

    Ok, by your posts, you say you have root, which gives me hope. Now for the fun part. Open the all in one package with the phone connected to the computer and choose option 7 (reboot into recovery). One of three things will happen.

    If your phone reboots and you see a box with an curved arrow coming out of it with the android robot standing next to it and no text, then wait for the phone to reboot and install CWM recovery with the all in one tool.

    If your phone reboots into CWM recovery, then you are good to go.

    If the program just hangs and your phone doesn't reboot, then either you forgot to turn debugging on in your phone, or you are set on the wrong connection mode. Make the appropriate corrections and try option 7 again.
  3. trigz1

    trigz1 Member

    ok i hit number 7 and its saying the system can not find the path specified
  4. trigz1

    trigz1 Member

    i think it worked. i did option 7. i saw the box with curved arrow and little robot next to it. then i did option 2. its installing now. now i can go into rom toolbox and install the rom?
  5. Neph81

    Neph81 Well-Known Member

  6. jimmyalbrecht

    jimmyalbrecht Member

    I just joined this forum, and there is a lot of great info. I appreciate all the people who came up with this process for rooting. I ran through the process as stated. I put my phone into usb connection through ethernet and had usb debugging enabled. I ran the .bat file and it successfully flashed CWM Recovery, but it froze after it said "Pushing exploit" and then "waiting to reboot again" Now it will charge when plugged into usb mode, but no options for connection type came up, and I can't run the .bat file again because it won't recognize through usb. Any ideas?
  7. jimmyalbrecht

    jimmyalbrecht Member

    Please don't ridicule me haha, the problem was with my computer. Somehow the USB malfunctioned and it just happened to be during the process of rooting my phone. I rebooted my computer, and now I am running the .bat file again.
  8. alanmac1982

    alanmac1982 New Member

    Is there a Linux package available to root? I see that one was going to be uploaded the first week of April, just haven't seen it around yet. Thanks!!
  9. Neph81

    Neph81 Well-Known Member

  10. becksalottery

    becksalottery Well-Known Member

    stupid question, but-- if I root the Spectrum, will I need to unroot in order to receive the official ICS ota update [in the advent that it FINALLY frakking arrives]? If I can update with root active, are there any preinstalled apps I need to make sure I haven't removed from the phone? (that sports crap, bitbop, nfl mobile and tunewiki etc)
  11. MrB206

    MrB206 Well-Known Member

    No, you won't. Just make sure you freeze bloatware rather than delete it. Deleting those apps will prevent you from taking the ota.
  12. becksalottery

    becksalottery Well-Known Member

    Really, you mean even the preinstalled games?? Bummer, I loath to keep crappy apps just sitting around all frozen on my phone :( There is something distinctly satisfying about putting the total banhammer on bloatware.

    If I remove them, and then reinstall them when ICS comes out, I should then be able to receive OTA updates, yeah?
  13. finndo77

    finndo77 Well-Known Member

    Best bet would be to do a complete backup in clockwork before freezing or deleting anything. Then COPY that backup to your PC. For safe keeping.
  14. MrB206

    MrB206 Well-Known Member

    You can try, but if they're installed as a system app, you'll need to reinstall them as system apps. That's why it's best to freeze... Unfreezing restores the apps as they were.
  15. becksalottery

    becksalottery Well-Known Member

    Thanks, y'all. :D I swear Android users by default are generally awesomesauce. *wrinkles nose* Unlike inferiority complex driven iPhone users. :p

    I switched to the Spec from my prepaid Lg Optimus V, which was built like a friggin TANK and thanks to buying it before a certain VM push to kill free mobile hotspot, I was even able to tether on the old bastard without rooting.

    But alas, the shiny called, and here I am. I was tempted by the iPhone, I really was, because the whole choir of singing angels thing at how sleek it looks, but really. I could not justify the spec fail compared to this bad boy.


    Err.. anybody have any tips re: battery life and/or general snappiness? I have it rooted, but still on the stock rom, and i have setcpu installed and set to conservative. Except last night, I somehow ****ed up and it got switched to OnDemand, which by the way NOT BAD, I went to bed with it on 85% unplugged and aside from a quickie 10 minute crap charge in the car, it made it until 10pm tonight before it hit 12% with occassional use.
  16. MrB206

    MrB206 Well-Known Member

    I've had that happen before. Are you running rom toolbox? If so, it sometimes overrides setcpu, so you'll want to set the governor in rtb.
    Make sure 'set on boot' is selected... The system will revert it otherwise.
  17. becksalottery

    becksalottery Well-Known Member

    I think the latter is what happened; that day I woke up with ondemand running, set on boot wasn't checked. I fixed it after that and I had it unplugged @ 100% at 11:30 this morning and didn't touch it until 3:30, to my surprise, the battery was still at 100% :eek: :D
  18. TypicalHorror

    TypicalHorror New Member

    Got my Spectrum a week ago and knew nothing about installing custom ROMS and/or rooting. Thanks to everyone one on here for making this so very easy to do. BrokenOut Rom is amazing.
  19. YoungGun

    YoungGun Well-Known Member

    so i flashed the CMW and after it says "remount succeeded" it says this:

    rm failed for /system/etc/install-recovery.sh, no such file
    rm failed for /system/recovery-from-boot .p no such file

    did it still fully install ok?

    Edit: picking option 7 makes my phone reboot into a black screen..
  20. finndo77

    finndo77 Well-Known Member

    Those two failed messages are ok, it is just there for removing the files IF they exist
    YoungGun likes this.
  21. ofHATEandENVY

    ofHATEandENVY Well-Known Member

    will this work with the V6 Firmware?
  22. mtmichaelson

    mtmichaelson Well-Known Member

  23. phillip_viado

    phillip_viado Well-Known Member

  24. IMUcarmen

    IMUcarmen Well-Known Member

    I'm confused. So they renamed v5 to v6? this looks the same as the promised v5 update. They need to igonre this junk and just get on with ICS already.

    I just hope they don't botch the ICS upgrade like they have the 2.3.6 ginger update
  25. MrB206

    MrB206 Well-Known Member

    Kinda seems like v6 is a fixed version of v5.

Share This Page