One X Plus - No USB mass storageSupport


Last Updated: 2013-05-03 09:44:39
  1. Shallowthing

    Shallowthing Member

    I am extremely disappointed to find that the HTC One X+ doesn't support USB mass storage, forcing me instead to "rely" (hah!) on the significantly inferior MTP instead.

    Does anyone know of a workaround, fix, hack, or blackly arcane ritual to get it back?

    This is a near deal-breaker as far as the device is concerned. I am seriously considering returning it and sticking with my two-year-old DHD.

    Advertisement
  2. StanFx

    StanFx New Member

    USB Mass Storage is supported - Comparing HTC One X Plus vs. HTC Eternity - 15 Reasons for the HTC One X Plus - VERSUS IO

    I'm not sure why your HOX+ doesn't have USB Mass Storage... mine does!
    Maybe you need to update your drivers?
    I can transfer files from my phone to pc and vice versa no problem... no need for MTP.

    I too used to have the DHD :) It has the option to select charge only, disk drive... etc! The HOX+ doesn't have the same option, which is a little annoying, so plugging the HOX+ into my PS3 there is no option to use as a disk drive, which means I can't view pics, movies, music etc. The way round this is to buy the HTC HD Media Link, which costs around
  3. Shallowthing

    Shallowthing Member

    I emailed HTC support directly regarding this issue. Here is the answer I received:

    "I
  4. Mitchturbo

    Mitchturbo Well-Known Member

    I've just got my hox+ today and it took a while for the laptop to recognize it as a one x+ in the USB port but it did eventually and I was able to upload a lot of songs and pictures on it. Is that the same thing your trying to do?
  5. Shallowthing

    Shallowthing Member

    Not quite. I can still (just about) do those things, but the transfer protocol the device uses to do them is different. With my previous phone (a trusty HTC Desire HD I have had for over two years now), plugging it into my PC causes the device to present me with a choice of "Charge Only" or "Disk Drive", and selecting the latter allowed me to mount the DHD as a USB mass storage device - just like my two external HDDs and my Cowon .mp3 player. I can open these devices in Windows Explorer and interact with them as easily as if the were my PC's own C: drive. This is what I consider normal and desirable behaviour.

    With the HTC One X+, when I plug it into my PC, I am not offered the choice above and although I can (just about) get into the files and folders stored on it (eeeevvveeennntttuuuaaalllyyy), it takes ages, is much less flexible, and fails frequently - it is running MTP rather than USB protocols. My aforementioned Cowon .mp3 player was made in 2008, and even that offers me the option to toggle between the two!

    Here is the easiest way to check whether your device is mounting as USB mass storage or as an MTP device: Fire up Windows Explorer, open up the HOX+, and then go Internal Storage > DCIM > DCIM 1541 (or whichever folder you have all your images stored in). Then, in Explorer, go View > Thumbnails. If the device is mounted as USB mass storage, you will see a proper thumbnail image - a smaller version of the photo itself. If it's using MTP, you will only see a generic thumbnail icon.

    This is the crux of my problem: Being unable to easily check which image file is which before selecting which ones to transfer over to my PC is a serious usability issue with the device which is my principle camera! Moving them all over to the computer and then doing it there is ssslllooowww and an inefficient use of my time. Finally, MTP transfers fail much more regularly than USB ones do (this very issue on my Cowon .mp3 player back in 2008 was how I learned the difference the hard way), and even simply plugging the HOX+ in has caused my PC to crash and hard reboot on two separate occasions!

    MTP didn't work properly over four years ago and it doesn't work properly now. The fact that expensive flagship devices like the HTC One X+ and the Samsung Galaxy SIII (which has exactly the same problem - I had one of those for a week before I got rid of it and switched to the HOX+) are crippled with technology half a decade out-of-date is shocking and embarrassing. Whoever at Google decided to drop USB mass storage support from Android 4.1.1 must have have been mad, and whoever at HTC decided not to re-enable it on the HOX+ is just as daft.
    PoweredByTofu likes this.
  6. Mitchturbo

    Mitchturbo Well-Known Member

    Ah got you. Understand now :)
    Yeah that sucks. Ice cream seems to have crippled Android in many ways, but at least hox+ still has flash enabled websites lmao! XD

    Hopefully HTC may release an update to the lack of USB Mass Storage in the future *shrugs* or not.
  7. Driftfog

    Driftfog Well-Known Member

    Mine connects via the Computer folder and pops up as HTC ONE X+ then click on that and you get the disc drive usage, click on that and your into the folders stored on the phone.

    HTC Sync manger tries to load as this is going on but if not needed I just close it.

    This is on Windows 7
  8. Shallowthing

    Shallowthing Member

    Mitchturbo: I hope so too. I'm still just astounded that it's not an option. It's like paying top dollar for a brand new sports car, only to find that if you actually want to sit in it you have to walk up the bonnet and climb in through the sun roof.

    Driftfog: As I tried to explain above, I can to that with mine too - it's just mounting as an MTP device rather than the more sensible USB mass storage. I refer you to the email from HTC I quoted above: Android 4.1.1 does not support USB mass storage, and HTC have seen fit not to restore it either. I've tried it with both my desktop PC (Windows XP) and my DJing laptop (Windows 7) and it's just the same with both.

    As to why you can't get it to mount as an MTP device with your Apple products (I saw your other thread on this subject just now), I'm afraid I'm as much in the dark as you are - I'm not an Apple user myself. As a stopgap measure, have you tried downloading the WiFi File Explorer app from the Play Store and doing it that way instead? Not as simple as a good old USB cable, of course, but at least you'd be able to get at your files from that machine.
  9. 1500cc

    1500cc Well-Known Member

    Got doing some research, and I doubt we'll get USB mass storage for our HOX+ unless it's in a custom ROM or emulated some how.

    Some of the reasons I read: MTP is file system independent, whereas USB mass storage required the SD card to be partitioned at FAT32. We don't have SD cards in our HOX+, so this would have required partitioning the internal memory. Currently all 64GB is in one EXT4 partition, with the emulated 'SD card' just being a folder. Thus if you want to fill up all 64GB with apps, no problem, or all 64GB with movies, no problem, it's all on one partition. And since all 64GB is in an EXT4 partition, Windows wouldn't be able to read it anyhow, and would likely want you to format it once mounted (yikes). Another advantage is that the 'SD card' doesn't have to be unmounted from the phone when connected to the PC, so both the phone and PC can use it at the same time.
  10. smackysquirrel

    smackysquirrel New Member

    double post my bad
  11. smackysquirrel

    smackysquirrel New Member

    I had an HTC ONE X and when I connected it to my PC I had the option of "Charge Only" or "Disk Drive".

    I have an HTC ONE X+ now with 4.1 Jelly Bean and when I connected it to my PC it does nothing but charge. If you open "Computer" on Windows 7 you will see a CD drive (to install HTC Sync Manager) and you will see a Portal Media Player with presumably nothing in it. If you go into your Android settings, developer options, and turn on USB Debugging mode, then when you go into the Portal Media Player you will see a 64GB "Internal Storage" device. You can access your pictures, ring tones, movies, etc.

    "Show touches" and "Pointer location" developer options are pretty neat as well.
  12. PoweredByTofu

    PoweredByTofu New Member

    Completely agree with Shallowthing, that is a very well-worded outline of the issues with the 4.1.1 upgrade.

    I can't even express how frustrating it is that the mass storage device option has been removed, I too use in on a daily basis for both work and uni and find the current option unsatisfactory for what I need...particularly not being able to preview images without opening them or copying them over to a PC first!

    I vote we bombard android and htc with complaints until they fix it!
  13. Joelzinho

    Joelzinho Well-Known Member

    I was gutted as well. I love the HTC One X+ but it just confuses me why they didn't implement USB mass storage. I too am coming from a DHD and I miss plugging my phone into my TV and playing music or videos.
  14. champagner

    champagner New Member

    Hello,

    it is 2 weeks ago that I upgraded mit Hox (w/o+).
    Since then I have more than one problem similar to Shallowthing.
    1. When I connected this phone with the PC on my work (winXP), than I'm not able to transfer data from the pc to the hox or back. So I installed the HTC Sync tool.....

    2. When my own pc (win7) or the pc from my work recongnized my hox it will needs a lot of time to open the Sync tool. Additionally the transfer rate will be no more than 1,4 Mbyte/s - that is nothing. An USB mass storage device is specified with 60Mbyte/s. (Would the half achieved I will be happy)

    3. After this update to 4.1.1 I can't data with more than 2GB transferred. My win7-Explorer will crash.

    4. I had a contact with the HTC support - here I got the answer that with the last update the storage format will be changed, from NTFS to FAT32 for Linux.

    I'm deep disappointed and I hope I will find an official or non official flash to get back the USB mass Storage device. The next HTC could you call Apple device.
    I don't know how works a S3, it has an own micro SD slot. SD cards can I formated in every common format.

    sad greetings from germany
    Peter
  15. ashh_vini

    ashh_vini New Member

    Hey i bought a HOX+ 2 weeks back & came across the same problem. The device connects FINE on Windows 8 and LINUX-UBUNTU 11 but NOT ON WINDOWS XP. Its quiet a disappointment really.. but the work-around would be you use windows8 or linux machine since i feel dropbox & airDroid is a bit painfull to keep uploading & downloading the files each time.
  16. DevilsAdidas

    DevilsAdidas New Member

    I too am having issues with transfering files to my phone on XP.... but htis is only at work.... at home i am proud to say that i use an OS that was not released a mear months before th very first Ipod..... or 3 years before the motorola Razr..... i cannot complain that HTC has ditched something created so long ago.... pls embrace technology and move forward.... your complaining can only hold things back...
  17. Lolhare

    Lolhare Member

    I do exactly the same,never bother with the HTC sync now,its a pain
  18. thowe21

    thowe21 Active Member

    I had same issue here with a Windows 7 machine at work. Took my HOX+ home on my Windows 7 laptop and it recognized it just fine and was able to access the internal files. So it's definitely a drivers issue. I also use my work machine to access iPhones as well and am having trouble recognizing the internal storage on iPhones so it's definitely a computer issue.
  19. beeflin

    beeflin Member

    I've discovered that the Mac OS X media sync app, HTC Sync Manager, whilst of no real use itself, mounts both the internal and removable SD cards of my One SV after a minute or so. Thank goodness. But very odd.
  20. smurph1

    smurph1 Well-Known Member

    I have just been given a replacement HOX, and i WANT to add files b myself, how do i do this (without root)?
    The synch manager only allows for music and pics anyway, Files is greyed out.
    How come my faulty HOX worked doing Mass storage.

Share This Page