One X+ WiFi IssuesSupport


Last Updated:

  1. sarhindi

    sarhindi New Member

    I got my one x+ yesterday i.e. November 4, 2012, and already have this issue of wifi initially recognizing my home network and then refusing to connect while i am standing next to the router. Now wifi fixer is showing that it goes to scanner and then immediately after a second goes to inactive. Is there a solution available, i am thoroughly disappointed by this issue otherwise its a superb phone.

    I have narrowed down the issue to my SIM card. After one factory reset, I didn't insert my SIM card module, and went ahead with the settings. The phone till the end showed the all the available networks around me. The moment I inserted my SIM card module, the wifi networks just disappear and wont come back.

    Please help any one

    Advertisement
  2. uapuat

    uapuat Member

    This is the same issue as mine, I think. That makes two of us (at least) with the same issue. I'll see what happens if I take the SIM card out.
  3. sarhindi

    sarhindi New Member

    Just wanted to know where u procured the set and which country you are operating it. I am currently operating it Pakistan, and the set was bought from UK, i.e. meant for European market.
  4. uapuat

    uapuat Member

    Got mine in the UK, and am running it in the UK.
  5. sarhindi

    sarhindi New Member

    Any luck with the wifi issues you were facing. I am trying to send back the set to the retailer.
  6. uapuat

    uapuat Member

    I had an online chat with the HTC support desk, and they showed my how to do a Wipe Cache Partition. After that I just rebooted by wireless router and modem and everything seems to be OK now.

    The Wipe Cach Partition is a bit of a drastic step and I suggest you have someone on hand to help you do it. Doing an online chat with the guys on the HTC support site would help. I managed to contact them via the 'chat online' at Contact us.
  7. Mrphazon

    Mrphazon New Member

    Hey guys,

    I just have te phone aswell, and guess what! same issue. It sees the network but doesn't connect.
    I even replaced the router with a new one and weirdly enough I had wifi for like 1 day. Then it dissapeared again.. Every other device like the Ipad, Galaxy note and and LG windows phone seem fine. This is really bad from HTC, after what the issues with the previous ONE X.. No idea what now...
  8. uapuat

    uapuat Member

    After what I said before, I restarted my phone yesterday, and the same issue is back.
    Please, all you other One X + owners out there, tell us if you see this too, or if our phones are defective and need to be repaired.
  9. AndrizzleHD

    AndrizzleHD Well-Known Member

    Can anyone confirm if this is happening in the international handset only?
  10. fsn1977

    fsn1977 Member

    Hello, I just got my Htc One x plus friday, I dosent seem to have the wifi issue.
  11. Supersnake

    Supersnake Member

    Deleted
  12. greatsnoring

    greatsnoring Well-Known Member

    I've had a UK set in UK on Vodafone for a couple of weeks. 2 problems, listed elsewhere, one with sync manager and another with storage. However wifi was working well up until tonight. Now keeps searching for wifi and says good signal but can't lock on and carries on searching. Have tried rebooting phone and router but won't stay locked to wifi. Any help appreciated.
  13. Mitchturbo

    Mitchturbo Well-Known Member

    I'm looking to get a HTC one x+ in three days time... I hope this issue isnt as bad as everyone makes out. I kinda need good WiFi lol. Hope someone can re-asure me that it will get fixed or something. Thanks :)

    Edit: I got it today and it connected fine to my WiFi today. I'll monitor its behavior in the next few days.
    Managed to get 750MB of data with it though if wifi does play up as a backup.
    Luckily I have 15GB of data on my Flyer thanks to 3 so I won't have much issues if I need the internet for emergencies lmao!
  14. greatsnoring

    greatsnoring Well-Known Member

    Have sorted this problem 100% - many thanks to El presidente on One X forum. you need to switch to a static IP address. If not sure how go into settings > wifi then click on the wifi point you want, click show advanced options then switch ip settings to static. If this isn't shown, disconnect from your wifi point, put in an incorrect password, then go in again with correct password and at this point you should be able to see the advanced options and set the static ip.

    This has revolutionised my wifi usage, hope it does the same for you!
  15. greatsnoring

    greatsnoring Well-Known Member

    Further to my last post, wifi worked perfectly for 24 hours, now phone shows good wifi signal, wifi analyzer app agrees but unable to connect to internet via wifi. If I switch off wifi I can connect via 3g, no problem, but with wifi turned on no connection. tried rebooting phone and router but no improvement. Any ideas gratefully received
  16. StelArian

    StelArian New Member

    Same problem here.

    Two days ago got mine 1X+ 64 black. I unpack, connect to my WiFi. First thing I did was check for firmware update. I had firmware 1.14.401.16 and updated to 1.17.401.1 then reboot. Wi-Fi problem appear. Keep Wi-Fi on during sleep set on Always, nevertheless Wi-Fi sleeps any time the screen goes off (manual or inactivity timeout). When back, Wi-Fi re-connect to AP, but no Internet. Try with more than 10 APs. Same issue.

    I guess the problem was firmware update to 1.17.401.1 and I return the device. They see the problem and give me an other new one.

    Back at home, same story. But this time I didn't update firmware. I stay with 1.14.401.16. During Play Store pre-installed apps update internet stop working but Wi-Fi keep connected.

    The problem is REAL and HTC ignores it. I get my devices from Bulgaria, Sofia (VIVACOM).

    So? What's next?
  17. StelArian

    StelArian New Member

    Oh My God!

    I think I found the problem! Looks like it's related to my Google account!!!!!

    I factory reset the device and skip all steps on first boot. Didn't register ANY Google account.

    WiFi works like charm!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    WTF?!?!?!?!?

    Looks like the problem is related to Android 4.1.1. I have an ASUS TF700T using the same account. 4.1.1 too. Some Wi-Fi properties pass to 1X+ (along with wallpaper!) and make Wi-Fi unstable.

    PLS GOOGLE! DON'T BE THAT WOW! I'M 100% SURE NOW THE PROBLEM WILL NOT BE FIXED ANYTIME SOON AND I CAN NOT USE MY GOOGLE ACCOUNT TO MY BRAND NEW AWESOME DEVICE!!!!
  18. SteveISU

    SteveISU Well-Known Member

    I only have an issue at my office, never my home. Security protocol is the same. The phone can't last all day on LTE and I can't be tethered to a wall.
  19. Mitchturbo

    Mitchturbo Well-Known Member

    I've only encountered the issue once since owning the Hox+ and that was it getting confused between certain WiFi hubs. Other than that, it's been absolutely fine for me.
    I get better WiFi signal on this device than my others I've owned, my friends devices too.
    Happy as pie.
  20. greatsnoring

    greatsnoring Well-Known Member

    Further to my posts above I seem to have sorted the problem out (at least for now...)
    My Wifi works best with a fixed IP address. This stopped the phone constantly searching,finding, then dropping the wifi connection. However, under advanced settings the phone had defaulted to the wrong Gateway setting. It was on 192.168.1.1, whereas for the BTHomehub2.0 it should read 192.168.1.254. Once I changed to this (with IP address 192.168.1.128) it seems to work really well. I tried disconnecting and reconnecting and it defaulted back to the wrong default Gateway address. I am not sure how to make it default to the correct one but at least I can manually reset it now I know where the problem lies

    Having spent all morning on the HTC helpline to no avail apart from the advice to hard reset, I rang BT helpline and a charming lady in India sorted the problem out in about 2 minutes.
  21. Joelzinho

    Joelzinho Well-Known Member

    Don't have this problem with the Canada Telus version.
  22. System Steve

    System Steve New Member

    My provider in the UK (O2) made me text Wi-Fi to 2121 to reset the wifi. In about an hour I switched the phone on and off and it was cured
  23. freeperjim

    freeperjim Active Member

    I've had my One-X+ ~ 1 month and was noticing some random WiFi drops.

    Then I discovered if I placed the phone on a hard surface, a strong WiFi connection returned.

    But when I picked up the phone and cradled it in my palm, the WiFi drops returned.
  24. authentic8

    authentic8 New Member

    After changing the ip settings to static, the option to connect was grayed out. is there something i have to change in the static settings before i can connect???

Share This Page