Oops...lost all my market links to free apps. ROM related?

Last Updated:

  1. Redflea

    Redflea Well-Known Member This Topic's Starter

    Oct 6, 2009
    Likes Received:
    Just wanted to share this in case others experience it...I've never seen this happen before on other ROMs (currently on BB Froyo v.2). No idea if it's the fault of the ROM, or some other quirk...this happened a full day after I had installed BB v.2 over my previous install of BB v.1.

    I went into the Market/Downloads view a little while ago and found that none of my free installed apps were listed, just the paid ones. All the apps were still installed on my system, but all the market links apparently had been lost.

    I hadn't done anything today to change my setup or configuration, but for some reason my installed free apps had disappeared.

    I entered and exited the market a few times, nothing changed.

    Went to Titanium and did a quick backup, just to make sure that I had all my apps. Then I tried to use Titanium's market fix feature, but it said there were no market links to fix.

    Remembering some advice in Titanium Backup that says when restored market links aren't showing up after a restore (which I hadn't done), if you simply download and install one app from the Market it will refresh the links...I did so, and all my free installed apps showed up again in the Market/Download screen.

    Hope this helps someone else...if the market seems to have lost your app list, try installing a new free app, and see if things get refreshed...

    jpdediego likes this.
  2. jevfr

    jevfr Active Member

    Nov 21, 2009
    Likes Received:
    Mine's done this on a few occasions also. Sometimes it has happened when I wiped data/cache and didn't restore using Titanium but restored each one individually. When it's happened, I went to the market to download my apps after a wipe, then exited the market before re-installing free apps and they would disappear. The other time, I used mybackup and the free apps didn't show. I have no clue as to why this happens.

Share This Page