Optimus Elite root with an apk


Last Updated:

  1. jmfolcik

    jmfolcik Well-Known Member

    Joined:
    Oct 19, 2011
    Messages:
    102
    Likes Received:
    19
    +1 worked here too, now using WiFi Tether for Root and it works great! (too afraid to try the built-in one even though i'm on the updated ROM)
     

    Advertisement
  2. l0uisl0uis

    l0uisl0uis New Member

    Joined:
    Jul 23, 2012
    Messages:
    3
    Likes Received:
    0
    Worked on my phone :D thanks!
     
  3. HackADevice

    HackADevice Well-Known Member

    Joined:
    Jul 21, 2012
    Messages:
    217
    Likes Received:
    5
     
  4. taco1425

    taco1425 Active Member

    Joined:
    Sep 2, 2012
    Messages:
    41
    Likes Received:
    0
    wifi tether works for me i get no errors at all
     
  5. atraum

    atraum Well-Known Member

    Joined:
    Feb 10, 2011
    Messages:
    76
    Likes Received:
    10
    Wow, that was incredibly easy! Thank you very much!!!
     
  6. BliND123

    BliND123 Well-Known Member

    Joined:
    May 30, 2012
    Messages:
    90
    Likes Received:
    10
    I'm rooted on ZV4, tired of seeing the update message. If I update to ZV5 will your APK be able to get me root again or do I have to re-flash it? (I deleted all the stuff I used to flash in the first place, LOL since I was seeing so many more easier ways now).
     
  7. kwknott

    kwknott Well-Known Member Developer

    Joined:
    Mar 19, 2012
    Messages:
    1,520
    Likes Received:
    727
    Yes this works for zv5
     
  8. Ginxeng

    Ginxeng Member

    Joined:
    Apr 30, 2012
    Messages:
    24
    Likes Received:
    1
    It worked for me on my zv5, but what I did first was do a factory reset and then rooted it. The only thing I didn't get to do was download rootcheck because I hit back on the phone after installing superuser but then poot was just a blank black screen. So I searched for rootcheck in the store but which one is the one you used for this one?
     
  9. ktb83

    ktb83 Well-Known Member

    Joined:
    Jun 10, 2012
    Messages:
    653
    Likes Received:
    212
    I'm not sure which app giantpune linked to in his rooting app, but there are at least a few apps that should work. Just try one, it doesn't really matter. I've used both apps named Root Checker in the past.
     
  10. Ginxeng

    Ginxeng Member

    Joined:
    Apr 30, 2012
    Messages:
    24
    Likes Received:
    1
    Once were done rooting, is it safe to remove poot and ministro?
     
  11. giantpune

    giantpune Well-Known Member This Topic's Starter

    Joined:
    Jun 13, 2012
    Messages:
    452
    Likes Received:
    475
    Yeah, the Qt stuff for Android is still in the alpha stages. One of the bugs is that if you let the app spend too much time in the background, it will not respond when you try to wake it up (hence the black screen). There's not much I can do to fix it except rewriting the apk to not use the Qt at all, which I'm too lazy to do.


    The rootchecker app it links you to is here. https://play.google.com/store/apps/...GwsMSwxLDEsImNvbS5qb2V5a3JpbS5yb290Y2hlY2siXQ



    Yes, you can remove Poot when you're done. Unless you have another app that uses Qt, you can remove Ministro.
     
  12. kiowaboi

    kiowaboi New Member

    Joined:
    Sep 9, 2012
    Messages:
    1
    Likes Received:
    0
    I've been waiting for a simple root like this for my Virgin Mobile Optimis Elite. It took only five minutes to root my Elite following your simple instructions.
     
  13. mutantchipmunk

    mutantchipmunk Member

    Joined:
    Jul 24, 2012
    Messages:
    17
    Likes Received:
    10
    It worked without any problems. It took longer to install the app than it did to root. I tested it with adblock and got su rights. Thanks abunch dude.
     
  14. BliND123

    BliND123 Well-Known Member

    Joined:
    May 30, 2012
    Messages:
    90
    Likes Received:
    10
    10 seconds to root! :D This is great! Took longer to update to ZV5. How do I uninstall Ministro though? I don't see it anywhere.
     
  15. Curtis1973

    Curtis1973 Well-Known Member Developer

    Joined:
    Jul 1, 2012
    Messages:
    2,166
    Likes Received:
    1,625
    settings,applications,manage applications,pick ministro,uninstall.
     
    BliND123 likes this.
  16. Bellrounds4u

    Bellrounds4u New Member

    Joined:
    Sep 9, 2012
    Messages:
    4
    Likes Received:
    0
    When I try to download your attachments I get a download unsuccessful notification.
     
  17. Curtis1973

    Curtis1973 Well-Known Member Developer

    Joined:
    Jul 1, 2012
    Messages:
    2,166
    Likes Received:
    1,625
    happens using some browsers like stock. try opera mobile or dolphin.
     
  18. tommymel

    tommymel Member

    Joined:
    Sep 7, 2012
    Messages:
    10
    Likes Received:
    1
    update: after enabling usb debugging this worked 100 percent. you guys are truely amazing thank you so much finally cleared all the bloatware off my phone!
     
  19. Curtis1973

    Curtis1973 Well-Known Member Developer

    Joined:
    Jul 1, 2012
    Messages:
    2,166
    Likes Received:
    1,625
  20. Curtis1973

    Curtis1973 Well-Known Member Developer

    Joined:
    Jul 1, 2012
    Messages:
    2,166
    Likes Received:
    1,625
    nice work on the vm venture giant.:smokingsomb:


    root via poot!! lol
     
  21. Ginxeng

    Ginxeng Member

    Joined:
    Apr 30, 2012
    Messages:
    24
    Likes Received:
    1
    Just reporting this, after rooting the phone with this and installing my normal aps and stuff back, the phone worked great for about 2 days. I use my LED keys as indicator when ever I have a message or something (built in optional phone feature). While charging it I saw the LED keys on so I though I had a message, when I looked at the phone I had no message or text but the light was on, thought nothing of it and locked the phone, the lights remained on again so I unlocked the phone and the screen went blank and started doing a boot loop. I took out the battery and put it back in and phone booted up normal again.


    *Update* This morning I was woken up by the stupid boot noise because my phone was stuck in a boot loop again, except this time it would boot all the way where the phone was ready to be used but a few seconds after it would reboot again over and over. I was able to turn it off without pulling the battery during one of its start ups before it rebooted again. After turning off the phone completly and turning it back on it seems to boot normally but it seems for someone reason at randon times it starts to boot loop on its own. This is my first root attempt on this phone which seemed to work, I never tried to root this phone with any other method.
     
  22. cmaker29

    cmaker29 New Member

    Joined:
    Sep 8, 2012
    Messages:
    3
    Likes Received:
    0
    I love you so much i cant say it enough!!!!!!!:d:d:d:d:d:d:d!!!!!!!!
     
  23. squidmo

    squidmo New Member

    Joined:
    May 24, 2011
    Messages:
    1
    Likes Received:
    0
    Of all the roots I've done, this was by far the easiest!


    Thank you, thank you, thank you!!!!!
     
  24. thomasbremer

    thomasbremer Member

    Joined:
    Sep 12, 2012
    Messages:
    8
    Likes Received:
    0
    Hell yeah lol got it! Woot!
     
  25. imamystery

    imamystery New Member

    Joined:
    Sep 3, 2012
    Messages:
    4
    Likes Received:
    0
    I done this root sunday evening, the root went good and the phone was running fine. Turned the phone off and when I tried to turn it back on it went straight to download mode.. I took the phone bk to Best Buy and got a trade in. Before I turned the phone off I moved some internal apps to the sd card, could that be why the phone bricked?

    And if I root my new phone can I get rid of unwanted apps and then unroot?
     

Share This Page

Loading...