1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

Optimus Logic?


  1. kingmt

    kingmt Well-Known Member

    How did you soft brick your phone? I take it that ROM Manager CWM restore works on this phone. I've flushed it & did a backup but not tired a restore yet.

    How is CM 9 working?
  2. Lexam

    Lexam Member

    At one point it would only show the boot screen for CM9. I had to create a folder in my sd card "/clockworkmod/backup/" and put my backed up rom in there. But I was lucky I had clockworkmod to begin with, it took me forever to figure out how to boot into it. I looked around for the recovery boot mode and nothing worked.

    CM9 does not give me cell service or wifi service, can't find any carries, says there was an error. So I switched back. But if there comes a stable version that works on it, then I'll switch over.
  3. kingmt

    kingmt Well-Known Member

    Did you try manually setting up the APN?

    Wi-Fi probably needed the permissions set.
    *Try this. Go to etc/dhcpcd/ dhcpcd-hooks go to properties & change permissions. Mark all the boxes. rwx *

    Any other problems? any other experiments. If I could get the phone out of my wife's hands I'd like to try myself.

    Are you on Straight Talk Or Net10?

    *edited*
  4. kingmt

    kingmt Well-Known Member

    1351266024528.jpg 1351266044232.jpg

    APN settings for Straight Talk.
  5. DislexicDan

    DislexicDan Member

    please help. i have done this step by step and my phone is yet to have root access. i see the # during the process can someone walk me through it quickly?

    will be up most of tonight and will be on tomorrow.
  6. Lexam

    Lexam Member

    I'm on straight talk. But no I didn't mess with the APN or wifi permissions. I'll give that a try and report back on it.

    "please help. i have done this step by step and my phone is yet to have root access. i see the # during the process can someone walk me through it quickly?

    will be up most of tonight and will be on tomorrow."

    Dan give me a little bit of time and I'll post a tutorial for it.
  7. kingmt

    kingmt Well-Known Member

    For APN settings I would suggest Tweaker but since Wi-Fi isn't working you have to do it manually. Go to Wireless & Networking/Mobile Networks/Access Point Names.

    Edit:CM 9 will probably be a different path if it is ICS. Sorry I didn't think about that before. I've never even seen ICS or CM so it is hard to guess.

    If I get a chance I'll try to get it on my wife's phone so I can look at it. I downloaded it last night but the MD5 sum didn't match what was on the site so I trashed it & downloaded again. They match this time but I don't have the phone in my hands to try it.
  8. Lexam

    Lexam Member

    1. Download the drivers for the phone http://s3.amazonaws.com/lgforum.com...leDriver_S4981MAN37AP22_ML_WHQL_Ver_3.7.2.exe HERE and install them. This will make sure your phone is visible to abd.
    2. Download the Android SDK and install it in your root drive (this will make it easier to navigate to. http://dl.google.com/android/android-sdk_r16-windows.zipWindows, http://dl.google.com/android/android-sdk_r16-macosx.zipMac OS X, http://dl.google.com/android/android-sdk_r16-linux.tgzLinux.
    3. On the phone go to your
  9. Lexam

    Lexam Member

    The APN was giving me problems doing it manually. Couldn't get it do anything with Wifi, but I'm still researching.
  10. kingmt

    kingmt Well-Known Member

    They have made it past that. Said something about making a directory he shouldn't have but out was a directory that should have already been there. I'm waiting on him to reply to find out what is going on instead of guessing.
  11. DislexicDan

    DislexicDan Member

    hey guys. in a nutshell i followed the directions and could not gain root. i accidentally made the /data/local.prop a directory
  12. DislexicDan

    DislexicDan Member

    still no luck but was able to fix the dir error, not it says /system/xbin/su is a dir. need a fix for this

    rm command wont work, not even in root. there has to be something i am missing here guys
  13. kingmt

    kingmt Well-Known Member

    I gave it a try myself. Like to never to get past the boot screen. I can get it to save the APN settings after I put them in. There is no file explorer to adjust permissions ether. I already switched back to the stock ROM before I thought about bluetoothing a apk to it. I don't know how to make it save the APN tho. It may be a permission thing also.
  14. DislexicDan

    DislexicDan Member

    how did everyone get past the boot screen?
  15. baktrak

    baktrak New Member

    CM9 seems to run pretty well for the limited amount of time I played with it. If it were able to get WIFI and cell service I could keep it as a daily rom.

    If anybody finds the solution the help would be greatly appreciated. The apn setting wont save.
  16. kingmt

    kingmt Well-Known Member

    I found out why the APNs won't save. It erases your IMEI when you flash it. I don't know whitch files need copied copied yet or where they need to go back after they are flashed. It is kinda hard to play with since it is my wife's & she wants to play with it herself.

    No clue on the WiFi yet. I haven't even begun to look at it. I do know it isn't the permissions for dhcp. May be scrip for the wrong modem. If anyone else is working on this I'd like to share information.

    Found a few other bugs but they may be linked to these two so first things first.

    *Edit*
    *If anyone is going to work on WiFi I'd suggest looking at the modem settings. Make sure they are the right ones.*
  17. Lexam

    Lexam Member

    Is Jcase over on Xda working on a rom for it. or is that my wishful thinking?
  18. kingmt

    kingmt Well-Known Member

    After we talked the other day getting root was the only thing of interest.
  19. kingmt

    kingmt Well-Known Member

    Does anyone know how to port this ROM?
  20. Lexam

    Lexam Member

    Alas maybe someone with more knowledge than us will make the rom. I definetly do not like the system memory on this though. It's just over 100 but you can't get near that installing apps. I can install about 4 apps max with this. Going to partition my sd card and install on there.
  21. kingmt

    kingmt Well-Known Member

    Just delete what you don't want from the phone. Move want can be moved.

    It won't work with a card formatted to ext3 or it didn't what I tried. I am going to try & port this thing when I get a machine set up.
  22. KendrickC76

    KendrickC76 New Member

    Does any1 out there know where I can purchase a cell phone cover for my Net 10 Optimus Logic LG L35G?
  23. kingmt

    kingmt Well-Known Member

    I haven't looked but it will probably be a few months before you find one made for it but you may find something close. Try a search for the e 400.
  24. faxanidu

    faxanidu Member

    working on working non broken cm9 now.
    also can a mod make a sub forum for the "LG Optimus Logic" please????
  25. kingmt

    kingmt Well-Known Member

    Sweet. I'm still waiting on my PC. Glad someone else decided to take this on. I still have to teach myself how so it may have taken a while.

    I asked for a LGL35G forum but haven't received a answer. Maybe more PMs would show them how many people are interested.

    Edited: Because my spelling sucked.

Share This Page