Optimus M connection issue


  1. JustChevere

    JustChevere New Member

    Hi, I have the LG Optimus M with the 2.2.1. I am currently trying to root but cannot get my PC to connect completely with my phone. I have Win7 64bit, I've tried installing/re-installing drivers, no luck. My comp shows me in devices window that the Optimus is connected but there's a warning triangle and it won't let me troubleshoot, in fact it says there's a problem preventing troubleshooting from starting? When I plug the phone into the back ports I get 'device driver was not successfully installed - please consult with your device manufacturer... etc.' even though the LG driver installed successfully. I've rebooted in b/t installs and still get 'LGE Android Platform Composite USB X Failed Device' messages. Trying to update driver from device properties on comp shows that 'driver is up to date'. Any ideas where the issue may be?

    Any help would be much appreciated. Thanks.


    Driver File Details: C:\\Windows\system32\DRIVERS\lgandbus64.sys

    Advertisement
    :
  2. Darnell0216

    Darnell0216 Well-Known Member

    Judging from past rooting attempts your issue is Win7. If you can, get to a WinXP computer, that'd be a boost. More than a few people had problems with the drivers and rooting tools working properly in Vista and Win7.
  3. blaxican25

    blaxican25 Well-Known Member

    i got windows 7 and it works fine
  4. JustChevere

    JustChevere New Member

    Yeah, I do think its Win7- I just know from other threads that Win7 does work and was wondering if anyone ran into the same issue and knew exactly what was going on.
  5. blaxican25

    blaxican25 Well-Known Member

    ianmichele likes this.
  6. ianmichele

    ianmichele New Member


    Thanks blaxican25, this worked for me :)
  7. Nando2469

    Nando2469 New Member

    Does this issue also occur on V2.2 ???

    I have never been able to hook my phone up to my computer and get a positive response. It will charge the phone but doesn't get recognized by the computer. It says that my device has malfunctioned.

    I also get a an error message.
    LGE Android Platform Composite USB Device
    This Device cannot start. Code 10

    Please help.
  8. odatkid

    odatkid Well-Known Member

    I believe you need "LGWindowsMobile_USBDriver_WHQL_ML_Ver_1.0"...do a Google search. If it that one doesn't work try: "LGUnitedMobileDriver_S497CA20_WHQL_ML_Ver_1.0"...but I'm pretty sure it's that first one you want.
  9. sammyz

    sammyz LG Whiz Kid Guide

    First one is for a windows mobile phone....read the name of the driver :p
    The second one is ours.
  10. odatkid

    odatkid Well-Known Member

    Sammy...You're right. I Should have looked to see which one I actually had installed.:eek:
    It is the "LGUnitedMobileDriver"

    Tom
Loading...

Share This Page