Optimus M recovery


  1. lexbot

    lexbot Active Member

    Hello everyone.

    I followed the instructions here to temporarily root and remove the MetroPCS apps from my phone, but I got too greedy and removed some LG apps too.

    Now my phone gets stuck booting on the Android screen.

    The "LG Support Tool" scans my phone in the recovery process and then reports "UPDATE NOT REQUIRED"

    Since their support tool thinks the phone is up to date, is there any way for me to recover the phone?

    Thanks in advance for any help offered.

    Advertisement
    :
  2. therooferking

    therooferking Member

    the answer is in ur lg booklet explains how to factory restore your phone
  3. lexbot

    lexbot Active Member

    My booklet has 2 solutions:

    The first involves going into settings menu so this won't work for me.

    The second solution is to press and hold home+lock+volume and release when the LG logo is shown.

    When I do this, a droid pops up for a second near a box with an arrow coming out of it and a progress bar. Then the LG logo comes back and the phone boots.

    Sort of. I have the menu bar at the top, but that is literally all. The screen is black, and none of the buttons on the phone do anything. No icons on the screen anywhere.

    Any help from here??

    Thanks again!!
  4. therooferking

    therooferking Member

    sorry i figured that would work
  5. therooferking

    therooferking Member

    that is supposed to put your phone back to a full factory reset
    xx1danny3xx likes this.
  6. therooferking

    therooferking Member

    try taking the battery out after you factory reset then boot again
  7. lexbot

    lexbot Active Member

    It sticks on the Android logo still on a normal boot, even after taking the battery out.

    The really odd thing is that while booted in recovery mode, I received an MMS message. So I tried calling the phone and I was able to answer the call. After that though, I couldn't return to the (empty) home screen.

    Looks like there is no way for me to get to the settings menu.
    NiNi likes this.
  8. lexbot

    lexbot Active Member

    I also get this error message when I boot in recovery:

    "The application setup wizard (process com.android.setupwizard) has stopped unexpectedly. Please try again"

    I recall deleting some app with a name like setup wizard. So anybody trying to clean out MetroPCS crap watch out for that one haha.
  9. therooferking

    therooferking Member

    sorry im new to android dont really know much
  10. lexbot

    lexbot Active Member

  11. lexbot

    lexbot Active Member

    More output from the Diagnostic tab from the modem device in device manager. I feel like there is probably an AT command to reset this thing, I just need to know what it is:


    ATQ0V1E0 - OK
    AT+GMM - LG-MS690
    AT+FCLASS=? - 0,2.0
    AT#CLS=? - COMMAND NOT SUPPORTED
    AT+GCI? - COMMAND NOT SUPPORTED
    AT+GCI=? - COMMAND NOT SUPPORTED
    ATI1 - Manufacturer: LG Electronics
    Model: LG-MS690
    Revision: MS690ZV3 1 [Oct 23 2010 22:27:57]
    ESN: 0x80DBDA3F
    +GCAP: +CIS707-A, CIS-856, CIS-856-A, +MS, +ES, +DS, +FCLASS
  12. lexbot

    lexbot Active Member

    Made a slight typo above, I used a "%" not an "&" with the AT command as indicated by those instructions. Still no dice.

    Anyway, hopefully my local dealer will swap me out a new one today!
  13. lexbot

    lexbot Active Member

    Ok first, the app I removed was LG Home, don't do that =)

    Next, the factory reset *was* working, it just wasn't fixing my problem. All the reset does it seems is wipe the data folder, nothing more.

    Restoring the home app fixed the phone. Case closed.
  14. xboxhacker

    xboxhacker Member

    DAMN!! i wish i had seen this a few days ago, i know how to fix your phone.

    But for anyone else...

    1. Take out the battery!! And leave it out!!
    2. Open the LG Update Tool software.
    3. Click "Customer Support" >> "Recovery Phone"
    4. Select the model number LGMS690, look under the battery and type in the serial number.
    5. It Will open a new window, and search for the phone.
    6. Replace battery and turn it on.
    7. Connect the USB (with it on) and click "Retry" to search for the phone.

    This should reinstall a FRESH flash for the phone and return it to OEM.

    This will not work if you can not get USB connection to the phone at all.
    dizkiller likes this.
  15. lexbot

    lexbot Active Member

    oh man that really works? Good to know.

    I tried the LG tool without step #6-#7. It found the phone just fine, but reported that it was "up to date" and wouldn't do anything else.
  16. danyvw

    danyvw Well-Known Member

    Just for curiosity I did all the steps and the software still saying: Cell Up to Date and do nothing. :confused:
  17. Slug

    Slug Check six! Moderator

    Any more childish arguing and bad language will earn infractions. The whole ethos of Android Forums is to help people, so please keep discussions polite and constructive.
    NiNi, jas0995 and deardevon like this.
  18. NiNi

    NiNi G1/Cliq Guide

    can you boot up in recovery mode?
  19. mblackwood

    mblackwood New Member

    do you have a source link for this information?
    (as in... Where does one get the "LG Update Tool Software"?)

    I ask because I'm trying to collect information in an effort to compile all the good stuff for the Optimus M line, so that it can be revamped on this site...

    many thanks!
  20. wilberfan1

    wilberfan1 Well-Known Member

    My SDCARD got borked this afternoon, and by an hour ago my phone was a complete brick! I just used the tool found here: LG Software Updater Application Download to get things back to where they were in late December when I bought the phone! :eek: Guess I should be grateful it's working again...

    THANK YOU FOR THIS THREAD!!! :)

    [Edit] Rats. The recovery tool installed 2.2.1 ...
  21. Darnell0216

    Darnell0216 Well-Known Member

    If your phone shipped with 2.2, you can use the downgrade method with LGNPST. Any time you use the LG Updater, you're going to get 2.2.1 because that's what the server delivers now.
  22. new optimus

    new optimus Well-Known Member

    I am very new here but if your phone is not working and the software says your phone is up to date you could use the downgrade method, then use the software updater.
    when I was rooting my phone I tried downgrading it to 2.2 first, I however just got the blank screen, so I used the update tool to get back to 2.2.1.
  23. chepo2309

    chepo2309 New Member

    OMFG!!! Thanks so Much XBOXHACKER i followed your instruction and ma phone works thanks so much saved me some money dere
  24. alexxseven

    alexxseven Well-Known Member

  25. WQuine

    WQuine Member

    This does not work. Just says phone cannot be updated. I also RTFM and could not find out how to do this under settings. My phone drops every call after trying to perform the z4 update on v2.2.1 (i didn't check before so my fault that I did not realise it only works for 2.2).

    Please advise: TIA
Loading...

Share This Page