Optimus S having GPS issues with Google NavigationSupport


Last Updated:

  1. Kelemvor

    Kelemvor Well-Known Member

    So my wife has the S and the 2.3 update on it. If I open Google Maps and tap the GPS icon, it locks right on and finds where we are. The icon stays solid in the status bar.

    From there, if I hit the dropdown and choose navigation, it then goes to Searching for GPS and the icon in the status bar starts flashing. It just sits like this and never is able to lock onto the GPS signal.

    I've tried toggling GPS on and off, tried rebooting the phone, etc but nothing helps. I don't understand why Maps can lock onto the GPS but Nav can't.

    Anyone else have this issue and have any idea how to resolve it?

    Advertisement
  2. Dark Penguin

    Dark Penguin Active Member

    I'm having the problem as well, and the most commonly described fix (wipe and delete Maps and Street View, then download a Maps .apk and install that, then finally SV), did nothing to fix it.

    I initially believed it was due to my having flashed the CyanogenMod 7 ROM, because that is Gingerbread based. As it turns out, a lot of people on GB, using lots of different makes and models of handsets, are having GPS and navigation issues, without necessarily having rooted or customized their OS in any way.

    Finally I decided to revert my handset to stock and re-root. I'm back on Froyo now, rooted, but navigation still does not work. In my case, GPS seems to work fine to the extent that I can tap the location tool and it will zero in on location accurately. Similarly with generating lists of directions. But real time turn by turn voice navigation will not come on. If I try to use it, it just stays stuck on "Searching for GPS".
  3. Ed Vim

    Ed Vim Active Member

  4. Dark Penguin

    Dark Penguin Active Member

    I'd been having the same problem for a long time. I asked about it, discussed it, complained about it, and even ranted at Google because none of the fixes I'd tried, either singly or together, seemed to work. The fixes in question were mainly variations of wiping and reinstalling Maps from an apk download, or enabling security credentials. In my case, these fixes might have done the trick, but I never knew it because my GPS Privacy Setting value was "E911 only"--only first responders could find the location of my phone. Of course, I didn't think of that, because when looking at Google Maps without trying to navigate, I could get my own location on the map just fine--the phone knew, so to speak, where it was. That being the case I thought navigating should work too.

    It's so obvious, that must be the reason why so few people have mentioned this. I can't be the only one who's gone through this, though, and its easy to forget about a setting you haven't touched in months.

    Long story short--you need to have GPS Privacy Setting* set to "Location On". The wording of the attribute and its values aren't entirely intuitive in my opinion, but there you go. Once you know what to change, you can change it.

    *Under Location And Security Settings on these phones. For those using other devices it might be different but the principle's the same.
  5. droididol

    droididol Active Member

    Dark Penguin, I'll try that and see if it works. I had the same issue, and it's not a proper workaround, but I installed the GPS app Waze and it works very well. It's not quite as smooth as the native GPS app, but it's not half bad, and has some extra features (community driven trip time estimates- always a lot more accurate for me than Google's)

Share This Page