Optimus S touch-screen sometimes refuses to turn onSupport


Last Updated:

  1. gorcq

    gorcq New Member

    Every so often, the screen on my phone refuses to turn back on from standby mode. I'll push the power button and the four buttons below the screen light up, but the screen does nothing. I have tried waiting for a long time and pushing all of the buttons, but the only way I have found to make it work again is to pull out the battery, put it back, and let the phone boot up again.

    At first, I thought that the phone had completely crashed when this occurred, but I'm seeing more and more evidence that it is still running, only with no display. Once, I noticed this just as a call was coming in. The phone continued to play my ringtone, but the screen did not display anything. I tried touching the screen where I thought the answer button should be, but that didn't do anything.

    I have read stuff online suggesting that an app called Juice Defender can cause a quite similar problem, but I don't use Juice Defender and never have. Any other suggestions would be welcome, as this is highly annoying. Thank you.

    Advertisement
  2. jefboyardee

    jefboyardee Well-Known Member

    Noticed nobody has replied, so I’ll try to help...

    I presume your OS is 2.33 Gingerbread? That was problematic for me and I downgraded to the original Froyo using a Sprint file called, ironically, update.zip. I have no idea if that would help in your case, but I hear I’m not the only one that thinks Gingerbread stinks.

    Caveat: when I reverted to Froyo, I goofed something up and it wouldn’t start until I took it to the local Sprint store for a blessing, but it has been wunnerful for many months since.
  3. gorcq

    gorcq New Member

    Thanks for responding. You are correct, I do have 2.3.3. I don't recall whether the problem I described occurred before I upgraded to it, but I think the phone has been running slower since, so I will attempt the downgrade.
  4. jefboyardee

    jefboyardee Well-Known Member

    If you go Froyo, a couple other tricks:

    To keep it from constantly nagging you to go ‘up’ to Gingerbread:
    1. Choose ‘more info’ in the nag window, then immediately
    2. Yank the battery and wait about half a minute, then
    3. Put it back and start up... you may have to do one more off/on.
    4. Now it will think you responded the nag and leave you alone.

    If for some reason you do want to go back to Ginger, go to Settings > About phone > System update. But don’t go there just to peek, like I just did, or you’ll have to do the yank again, like I just did.
  5. gorcq

    gorcq New Member

    Thanks for that. I was just starting to frantically search the internet for information on getting rid of that upgrade message when I discovered you'd already posted it here, and it works.

    The downgrade went well. Obviously I don't know yet if it's solved the blank-screen issue (that's the problem with randomly-occurring errors), but the phone is working correctly and I am attempting to get all the apps I use re-installed.
  6. jefboyardee

    jefboyardee Well-Known Member

    Hopefully, that actually solves the original problem.

    One last little nag: us often-posters collect ‘thanks,’ shown in our profiles. To add to that total, just click the Thanks! button at the lower-right corner of the post you’re thanking.
    gorcq likes this.

Share This Page