1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

OTA Update


  1. icedice34

    icedice34 Well-Known Member

    So if I am running an ICS rom on the old firmware patch. When the OTA finally gets around to releasing (some people are saying they are getting it today). Can I run a stock rom Nandroid, run the OTA, then flash a nandroid of an ICS rom over the top of it? Or do I need to wipe and install the ROM again and reinstall everything?

    Thanks!

    Advertisement
    :
  2. scotty85

    scotty85 Guides Guide

    you will need to reinstall your rom,unfortunately,as the nandroids will contain the old firmware patch. thus making them uncompatible with new firmware.
  3. icedice34

    icedice34 Well-Known Member

    What if I used Amon Ra to only flash the "data' portion after flashing ROM? or is it in the data portion that the old firmware patch is located?
  4. scotty85

    scotty85 Guides Guide

    the old firmware patch is modifying some files in /system.

    you could try restoring only the data partition,but i believe that it wont boot. im fairly certain that amon wipes all partitions automatically prior to a restore,so after restoring /data,you wont have a /system or a /boot to make the rom work :eek:

    i could be wrong,tho... trying it shouldnt cause any harm. if it doesnt boot,then youll just have to pull the battery,and relaunch recovery to fix it :)

    after some thot,here is what you should do:
    -reflash GB backup and take OTA
    -restore current backup(dont reboot after)
    -wipe cache and dalvik cache
    -reflash rom
    -reboot

    relflashing the rom without a data wipe should preserve your setup,and replace "/system with old firmware patch" with fresh /system install,ready to run on new firmware :)
    icedice34 likes this.
  5. icedice34

    icedice34 Well-Known Member


    Sounds like a plan. The OTA has released, but doesn't appear everyone can grab it yet, I will try this in a week or two and let you know what happens
  6. howardz2

    howardz2 Active Member

    gruss likes this.
  7. gruss

    gruss Well-Known Member

    Hooray for t torrent and unlimited data! Thanks for the link! :D
  8. ntrnlerror9

    ntrnlerror9 Active Member

    after downloading the ICS update, my phone restarts and i land on the recovery menu and am getting error

    verifying current system assert failed: apply_patch_check("/system/app/accountsyncmanager.apk", E:unknown command [b9a36302874fe20264b1147dc97e23989d6b8014",] E:unknown command [f5496")] E:error in cache/fumo/otapkg.zip
    status 7
    installation aborted

    what should i do? do i have to restore factory settings?
    revert back to stock or something? i have no clue and am so excited to finaly get the ICS update and now i cant get it working!! please help me
  9. jlb0305

    jlb0305 Well-Known Member

    are you getting the phone icon with red triangle and exclaimation point? I'm stuck there on rooted stock (tried 4 times)
  10. ntrnlerror9

    ntrnlerror9 Active Member

    no, its dumping me at Amon Ra recovery screen
  11. jlb0305

    jlb0305 Well-Known Member

    OTA will only work on stock recovery from what i've heard.
    NightAngel79 likes this.
  12. acejavelin

    acejavelin Well-Known Member

    I think I see the problem... I was under the understanding you had to be BONE STOCK for this to work, but I could be wrong. Amon Ra may be the issue, perhaps you could just flash the RUU?
  13. ntrnlerror9

    ntrnlerror9 Active Member

    how do you get to bone stock?
  14. acejavelin

    acejavelin Well-Known Member

    I honestly don't know... I have not rooted my Rezound or installed any ROM or recovery so I don't know how to restore it. My best bet would be look in the All things Root area or check the Rezound section of XDA.
  15. NightAngel79

    NightAngel79 Lv 60 Bounty Hunter Moderator

    you must be completely stock to get OTA to work the way I understand it

    moving this to root section
    scotty85 likes this.
  16. lawizard

    lawizard Active Member

    do I need a particular program to open the download and how do I install it.
  17. jlb0305

    jlb0305 Well-Known Member

    Any idea why its not working on mine w/ stock bootloader & rooted stock?
  18. NightAngel79

    NightAngel79 Lv 60 Bounty Hunter Moderator

    It is my understanding that if you are rooted at all then you just figure on either not getting the ota or it not being able to install.

    I'm certainly no expert on this but hope that some of our more advanced root users can better answer this. (Scotty comes to mind, :))
    scotty85 likes this.
  19. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    So this is the exact OTA ICS update that's going out right now? What about the small 7MB or so update that is pushed OTA before ICS is pushed? I'm trying to update my wifes (stock/unrooted) Rezound manually because we live in an extended network area where we roam on a regional carriers towers , so she wont receive the update OTA.

    TIA :)
  20. jlb0305

    jlb0305 Well-Known Member

    Doors the bootloader need to be relocked fit the ota to work?
  21. DaveHiro

    DaveHiro Member

    The fastest/easiest way to get the update if you are failing install from being rooted is by running the ruu executable for the latest Gingerbread version on a PC.

    (I failed the install of the 7MB file twice before I did this.)

    The file can be found here:

    Goo.im Downloads - Downloading RUU_Vigor_VERIZON_WWE_2.01.605.11_Radio_RS_0.95.00.1123r_3161E_9K_QMR_release_233635_signed.zip

    Via Scotty, in this thread -> http://androidforums.com/rezound-al...-off-guide-info-return-stock.html#post4394131

    HTH,
    Dave
    NightAngel79 and scotty85 like this.
  22. scotty85

    scotty85 Guides Guide

    how long are you giving it? it can sit on that screen for awhile sometimes.

    correct. will NOT work with amon or clockwork permantly installed. this is why i typically recomend the rotoed stock crowd to fastboot boot recovery when they need it,and not fastboot flash it.

    you can run the ruu. or you can wait patiently for a .12 ruu to be released,then run that. or you could be impatient and flsh the .10 leak,and then get stuck on it,untill the .12 one comes out :eek:

    run the RUU

    honestly... no. ive had OTAs work when rooted,and modified with frozen/deleted apps. i have read reports of OTAs not working when too many apps have been deleted,but i havent verified or disproved it.

    it also could possibly be a bad download to the phone(one reason im not real fond of OTAs)

    no


    **one last bit of info,once the phone as downloaded the OTA and tried to apply it,you are prolly SOL if it failed becasuse of a custom recovery. restoring the stock recovery at this point,usually does not apply the OTA.
    NightAngel79 likes this.
  23. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    I'm trying to update my wife's totally stock/unrooted Rezound with the instructions Scotty provided here, but when I go to flash the official update .zip file, I get this in the command prompt window:

    Not sure what could be causing this.. I'm guessing because I need that small 7 MB update before this update can be applied? Can't think of anything else, except maybe a corrupt download. But that "remote: not allowed" error makes me think it's some sort of permissions or software issue.
  24. scotty85

    scotty85 Guides Guide

    im not 100% sure what the 7mb update was that youre refering to,but if youre on 2.01.605.11 then the phone has had all available updates.

    assuming by stock,unrooted,you mean stock locked or relocked, then there is an issue with the download.

    im unfamiliar with torrents,so im not sure what howardz has posted a link to. it could be an unsigned by htc file,or it could be a corrupt download.

    unless howard has some advice on torrents,you might just download from the link in post #21 and see if that works. goo.im should be a pretty fast download.
    PhilosoRaptor likes this.
  25. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    I'm referring to the 7.1MB OTA update that they pushed out that your phone apparently needs before you can receive the actual ICS OTA update.

    I'm not sure what that version number you mention is referring to, but when I'm in Fastboot/bootloader, it says it's on "HBOOT-2.1.0000". Should that be on 2.01.605.11? EDIT: I found what you're talking about; in the software info on the phone, she's on "Software number 2.01.605.11". So yeah, she's on the latest GB update, so she should be ready for this ICS update.

    Yes, by stock/unrooted, I mean the phone is LOCKED as indicated in the bootloader at the top of the screen. I have never touched her phone as far as rooting/s-off/unlocking goes. I want her to have as stable of a phone as possible, so I don't mess with her phone for all that. I waste too much time ROMing my Gnex to mess with her Rezound anyways, heh.

    I was afraid of the file being unsigned judging by the filename of the .zip (rezound_AndroidPolice_3.14.605.12_PH98IMG.zip). I doubt HTC would put "Android Police" in the file name, heh. I tried re-downloading it again and am still getting the same error. There was no MD5 hash listed for it either for me to compare it to. I didn't even open or rename the .zip file. Would you happen to have a direct download link for the offical ICS update?

    Thanks!
Loading...
Similar Threads
  1. Ollyhw45
    Replies:
    0
    Views:
    2,598
  2. Cjohn8792
    Replies:
    16
    Views:
    1,521
  3. lewa
    Replies:
    6
    Views:
    654
  4. Ferox
    Replies:
    6
    Views:
    821
  5. curiousjorge
    Replies:
    4
    Views:
    446

Share This Page