OTA Update


  1. scotty85

    scotty85 Guides Guide

    thanks for the link,i hadnt read that bit about being 2 seperate updates. tomoro ill have to roll my phone back and see if i can get it to download them, so i can see what they are.

    the RUUs wont need to have the small update,they should include it. the ruu is all the images,while the OTA is patch files,and firmware. the small update is likely something needed to preserve the users data prior to changing the fimrware and software in the next update.(running an ruu will wipe all data,including the internal sd)

    i hadnt realized android police have released the .12 update,i thot you were trying to install .10 or one of the older leaks. there is no official from htc RUU(in the form of a .exe file) just yet,but the one from AP is a signed,legit file.

    wich leads us to prossibly being a bad download.

    here are a couple more links,if you havnet seen them:
    Verizon Confirms HTC Rezound ICS OTA In Official Update Document, Includes The Changelog For Good Measure
    and
    [Exclusive Download] HTC Rezound Ice Cream Sandwich RUU For Final OTA (3.14.605.12)

    that second one contains a few(likely sloooow) download links.

    last and lot least,ignore the bit about using the download link in past 21,its for the current build,not the ICS update. you would use it to get back to stock GB in order to OTA.

    the number i referenced is the software build number,that you can find in about phone. the hboot you have(2.11.0000) is consistent with that build.

    unless ive missed it above somewhere, im not seeing any reason your wifes phone wont recieve the OTA naturally,if you give it a few days :)
    PhilosoRaptor likes this.
  2. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    Thanks a lot for the info and links. I just realized if I install any of those RUU files, that it will wipe her data. I don't want to do that. Is there no way to manually update it without wiping data? The reason why I'm trying to manually install the update is because we live in an "Extended network" area where we roam on another regional carriers towers, so the phone won't receive any OTA updates in this area :(. Native Verizon coverage is 30 mins away and we rarely go out that way.

    Thanks again!
  3. scotty85

    scotty85 Guides Guide

    oooh,that sucks. are you sure that being outside of vzws native range will prevent the OTA? your not actually acumulating roaming cahrges are you?

    until you fid yourself near vzw towers it wouldnt hurt to keep checking the update status while in wifi. ive actually gotten my thunderbolt to download and apply updates over wifi,when it was not even an active phone :eek:

    unfortunately,there is no way to update the phone that i know of,that wont wipe all her data :(
    PhilosoRaptor likes this.
  4. gruss

    gruss Well-Known Member

    ^^^^^^
    I can second that, your phone should update on wifi the normal way without wiping. My wifes razr was acutallly on wifi when the ICS update hit her phone last month don't know why it would be different for Rezound. And I remember a while ago messing around trying to brick an old Eris, line wasn't active but update popped up.
    PhilosoRaptor likes this.
  5. jlb0305

    jlb0305 Well-Known Member

    I gave it about 15+mins (it sat there while I was driving home). So your saying it could stay on red triangle for a while then start back up?

    Any idea how I could clear it out and download a good copy?


    I had stock recovery w/ rooted stock. only booted to AmonRA didn't flash it. Any way to remove root w/o flashing the RUU, since I'm on stock?

    If it helps error my update is getting is 410 in status after it fails. looking at VZW forums they just suggested doing a data wipe (on non-rooted phones). May try that see if it helps.

    Did anyone else have rooted stock (unlocked hboot, didn't flash recovery, rooted factory stock) and have the OTA work fine?
  6. scotty85

    scotty85 Guides Guide

    it could... but prolly not after 15 minutes. i was thinking more like 5ish minutes. basically give it more than 30 seconds ;)


    wipe /cache. you can boot amon and wipe cache and dalvik,or i believe the stock recovery does have an option to wipe cache.

    doing this will not gaurantee an immeidiate redownload,however.



    you dont need to remove root. if you have deleted a bunch of vzw apps and bloat,this could be part of the prollem. when i first got my rezound,i got an OTA with apps frozen,rooted,and unlocked. it worked fine. i had rreflash superuser and refreeze all the apps,but there were no issues.

    i have had folks telling me that deleting certain apps or too many apps can cause prollems. i cant say for sure if thats true or not. your best bet honestly may be to just run the ruu,unless you have a pretty unmolested stock backup you can restore.

    im going to roll back to GB shortly,and see if i can get my phone to do it.
    jlb0305 likes this.
  7. jwbolfer

    jwbolfer Member

    How do you root the official ics? Restored ny rezound to stock and upgraded and installed amon ra and unlocked my bootloader. Installed Su and super user but no root apps work and root checker says I'm not rooted. Help me Scotty!!!!!
  8. scotty85

    scotty85 Guides Guide

    check out my posts in this thread: http://androidforums.com/rezound-all-things-root/594463-root-stock-ics-s-off.html

    scratch that. if youve unlocked allready,you dont need to read that whole thread,you just need ICS compatible superuser:
    http://forum.xda-developers.com/showthread.php?t=1538053
    NightAngel79 likes this.
  9. jwbolfer

    jwbolfer Member

    I don't have s-off tho. Kinda scared of touching parts with wire and shorting it out
  10. scotty85

    scotty85 Guides Guide

    you dont need s-off. just use the superuser i linked,flash it in recovery just like you did 3.0.7
  11. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    No, we've lived here for over a year now and I've never heard of Verizon penalizing you for not being on their network.

    Yeah, I'm pretty sure I can't receive the OTA while in their Extended Network. When I go to the "update" (I don't have the phone with me now, so I'm not sure if that's the exact verbage, but I think it was the second option from the bottom) options in the main settings menu, the "check for update" (again, not sure on the verbage) button is grayed out and it actually says "Roaming" under that button.

    See above. I actually received the 4.0.2 update on my Galaxy Nexus over WiFi when I first got it too (was the first OTA for it and was pushed on launch day), it wasn't even activated on the carrier or had a SIM card in it at the time. I figured since it was a Nexus phone, it pulled its updates directly from Google and not Verizon. So I'm not sure if different phones pull updates differently or what..? I'm thinking maybe your Razr wasn't roaming, so it actually found the update from the carrier, then was able to download it on WiFi once it knew where to pull the OTA from. No idea, just a guess. But the Rezound doesn't even let you check for updates while you're roaming, the button is greyed out and it says "Roaming" under it. :(
  12. jlb0305

    jlb0305 Well-Known Member

    I think the update PDF has instructions for what to do if your roaming. I think it says to do the wifi thing. Don't rememeber off hand.


    Gave up on fixing my issue and ran the RUU. Hoping i can get the OTA now. If not I guess I gotta find a good ICS ROM.

    Update: After Running the RUU I was able to get start installing the update (7 mb one). Note: to even get data service back after RUU i had to reboot a few times, then turn off and back on mobile data.
    once ICS is installed I'm gonna have to re-unlock and reroot to get all my data/apps back. This time I am def going to take a stock image with NANdroid prior to root in case this is an issue if/when JB is pushed.
    PhilosoRaptor likes this.
  13. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    It seems you're right. Odd that it didn't let me manually check for an update while on WiFi then. I guess I'll wait a few days to see when/if it comes over WiFi.

    Thanks!
  14. obscuro

    obscuro Well-Known Member

    Scotty, is there any significant advantage to going from running ICS on patched GB firmware to running ICS on the new firmware? Just wondering whether I should bother going back to stock to get the OTA. Don't really want to run the RUU right now because I'd have to back up my SD card first and it's about to be the weekend :)

    I have an old bare-bones GB backup and my current backup is newts with the old firmware patch applied. Would the instructions you gave (quoted above) work for my situation?
  15. jlb0305

    jlb0305 Well-Known Member

    Scotty/Anyone

    In locking, running the RUU, and then reunlocking i now have the "tampered" label. Is there a way to remove the "tampered" label (if I need to ever do a phone exchange, Not looking to do S-off.)
  16. scotty85

    scotty85 Guides Guide

    if you relock,run a stock ruu,the tampered should disapear,as long as you dont re-unlock. at least,i think thats how it went. its been awhile now since ive been s-on. :eek:

    it comes from,at some point,unlocking on ICS and installing a custom recovery.

    also,there is no way to get back to locked without s-off. best you can do is relocked,so unfortunately,ther is going to be telltale signs in hboot for those that know to look.
  17. scotty85

    scotty85 Guides Guide

    i like to think running the actual ICS firmware makes things a lil smoother and faster. but it could well be the placebo affect :eek: its something i personally would want to eventually do,but i cant really say i think there would be significant,noticAble difference.

    if you want to update,the above directions should work fine for you as well :)
    obscuro likes this.
  18. jlb0305

    jlb0305 Well-Known Member

    S-OFF doesn't look too hard. To update for OTAs with S-OFF is it as hard as what I had to do with just unlocked & rooted? (Relock, run ruu, and update to ics, then reunlock and re-root)
  19. scotty85

    scotty85 Guides Guide

    if youre on ICS now,there isnt really a reason to roll back,as juopunut bear will work on ICS,you just need to be unlocked and rooted. use a small spare sd card for the process,and make sure youve looked at the troiubleshooting page,so you know how to get your phone back if you decide youve had enuff in the middle of it: Troubleshooting | Unlimited.IO

    after the process,id prolly reccomend running the newest ruu again,and hit the "clear storage" option in hboot immediately after,with the stock recovery still in place.

    at that point you can install a recovery,and restore a backup of what youre running now,or flash a new rom.

    just do not unlock again after s-off. :)
  20. scotty85

    scotty85 Guides Guide

    ics,just an FYI, i tried this and it worked fine. i even used it in the manual update guide: http://androidforums.com/rezound-al...-manually-update-ics-without-losing-data.html

    so if you wanted,you could:
    -take OTA
    -reflash rom
    -restore data portion only

    maybe 6 of 1,half dozen of the other,but just thot id let you know either way works :)
  21. scotty85

    scotty85 Guides Guide

  22. obscuro

    obscuro Well-Known Member

    OK, scotty was right. If you restore a nandroid backup, even if you just select the data partition, amon ra wipes the others.

    So for example, to install ViperRez over stock ICS, I had to:

    1) Restore nandroid
    2) Flash viperrez rom in amon ra custom recovery
    (it gives you an option during the viperrez install to reboot to bootloader if you are S-ON, but I stupidly ignored this)
    3) If your ROM didn't flash a boot image for you, you need to do it through the PH98IMG.zip method. I extracted the viperrez rom zip, found the PH98IMG.zip, placed the PH98IMG.zip on the root of the sdcard, then rebooted into the stock bootloader. It asked me if I wanted to go ahead with the update, I pressed VOL UP for yes.

    EDIT: Still getting bootloops when it starts to load the home screen. What do I need to do? I have the boot.img from viperrez, but don't know where to flash that.

    EDIT2: Tried fastboot flash boot [ROM's boot.img filename here] ; fastboot reboot ; still bootlooping. Scotty? HELP! :)

    EDIT3: OK, after I was about ready to give up, I did 'Clear Storage' from bootloader and I finally booted up OK. What does Clear Storage do exactly? haha

    EDIT4: Well that got the phone to boot, but I don't have any of my apps data. Like, it grabbed my wallpaper but I don't have what I need to restore a titanium backup. So I still need help.
  23. scotty85

    scotty85 Guides Guide

    hopefully you made a backup of newts before starting to update?

    this is prolly not exactly what youll want to see,but the best thing,IMO:
    1)wipe and restore working newts backup. before rebooting,wipe cache and dalvik,and reflash the same version of newts rom,so that it will work with new firmware.
    2)once youre in your working backup,use titanium to backup apps and app data only.
    3)make a backup of working newts rom,in case you want to come back to it,you wont have to reflash the rom over your old backup to get it working on new fimrware.
    4)reinstall viperrez
    5)restore aps with titanium. wallpapers,ringtones,etc. should remain unmollested on the sd card.

    and for anyone else watching,make sure youre fastboot booting recovery each time(i know you know that ;))
    obscuro likes this.
  24. obscuro

    obscuro Well-Known Member

    I'm going to make a poster that says, "Fastboot boot is your friend." :p


    The only thing about flashing newts is the script is built to do a full wipe. So my old newts backup worked after doing a full wipe and restoring it, but then when I tried to reflash newts over it, I no longer had any apps.

    But I remember you said something about my old newts backup (taken from ICS on GB) would retain some of the GB firmware patch?

    So I'm at a loss of what I need to do before flashing viperrez again.

    EDIT: From my fresh newts-on-ics rom, I'm going to try restoring just the data from my old newts backup, since you said that may work. Then going to try doing a titanium backup and backing up new rom like you said. Do I need to do anything between doing an up-to-date backup of working newts and flashing viperrez?

    EDIT2: After doing a TiBu and a nandroid of my new newts setup, I then wiped cache/DC and flashed viperrez. Still getting bootloops. I'm sure I'm missing something simple here.

    EDIT3: Wiped /boot and /system, then flashing viperrez. See if that works.

    EDIT4: Then I tried wiping cache in stock recovery, then wiping dalvik-cache and rebooting. No go. So back to fresh viperrez with no apps, for now, need my phone for work. Still want to get to the apps in that TiBu to save me a lot of grief! :)
  25. scotty85

    scotty85 Guides Guide

    if you got a tibu backup of your apps,why cannot you now simply restore them? you will have to manuall set some phone settings,ringtones,etc. but all your apps will at least be there.

    just make sure you dont restore anything other than user apps+their associated app data. no not restore any system data or ANYTHING other than user apps or youll be back in the same boat you were with the no data wipe dirty flashes :eek:

    so,given newts wipes your data,you could try(if you still need a good tibu app backup)
    -restore newts. backup newt data(dont really even need to boot it,i wouldnt think)
    -full wipe,install newt. install backed up newt data
    -boot phone. if it works,rejoice :smokingsomb:
    -backup user apps with tibu
    -make good nandroid of newts in case you need it
    -fresh install viper
    -restore user apps with tibu

Share This Page