Other caller hears echo on Bluetooth - EVO 3DSupport


Last Updated: 2012-09-23 14:39:18
  1. tuz

    tuz Well-Known Member

    When I use my Motorola H390 bluetooth headset with my EVO 3D, the caller on the other end sometimes hears their own voice echoing back so much that I have to turn off the headset. Does anyone know a solution for this? I love the H390 I don't want to have to find a different headset!

    Advertisement
  2. Dman626

    Dman626 New Member

    I've seen this problem reported on every other forum, but everyone, including tech support, guesses that it's a network problem.

    I have logged the symptoms and variations of the problem with my Evo 4G and my Plantronics Voyager Pro HD.

    I will guarantee that the problem's genesis lays somewhere in the fact that the phone splits Phone Audio from Media Audio... and what the other caller is hearing as an "echo" is actually the Media Audio being transmitted through the Phone Audio a split second later.

    This is the reason why temporarily turning on speakphone during the call resolves the issue (it turns off Media Audio until the call is ended.)

    I have tried and tried to use my earpiece for Phone Audio only, but the latest patches don't allow that to happen.

    HTC says that it's either a network problem (thus pushing it off to the carriers), or a bluetooth problem (thus pushing it off to the headset manufacturer.) In actuality, it's a problem with how Android is rendering two different types of audio.

    The Dec 11 patch was supposed to fix this, but actually made it worse. My headset, that I've used for years through four different phones, is now useless.

Share This Page