[OUDHS] Soft Brick and CWM recovery support


  1. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Ok, some of you guys are really tearing it up and trying some stuff that can soft brick your Reverb. A soft brick is when the device will not boot into Android OS, but will boot into either recovery or Download mode. Download mode is the screen with the yellow triangle and the digging android. Another screen you might see is the one with the error message and the computer connected to a phone. That screen just tells us that whatever was just tried failed. For our purpose though, it is the same as the download mode screen. Usually you see it after a failed flash using Odin, which we will go over in a minute. Both screen open the device up to be flashed via USB with either Odin (if using Windows) or Heimdall (if using Linux). These are tools that allow the user to install software to the device by writing the data to the proper partition.

    You can usually get into Download mode by holding the volume rocker down while also holding the power button. This device requires that you hold vol up + dn then power. Hold that combo until you see the android digging and the yellow triangle. You can escape download mode by holding the power button down for a few seconds. I do not recommend removing the battery to escape Download mode. Try the power button for a while before you chose to remove the battery.

    So, now that you know what we're working with, here are some files you may want. The first files are the stock kernel and recovery. Most devices call them boot.img and recovery.img respectively, but to work with Odin they need to be contained in a .tar.

    Download them before the power goes out!

    REMOVED DEAD LINKS

    You also want to make sure you have the right drivers for your Samsung device. When you first plugged it in, Windows might have installed some generic drivers, but that's not good enough for us, so download these drivers and install them right now even if you don't plan on flashing anything or working on your device at all.

    Samsung drivers

    After you install the drivers, plug the phone into the computer with your USB cord and let the install finish completely. Once that's done, you are ready for BaconMaggedon!

    Next you will want to familiarize yourself with the Odin program. Get it now!

    Odin 3.04

    Extract the zip. Double click Odin.exe. You will see a series of "windows" in a row across the top. On the left, under the first one it says "ID:COM" The rectangle beneath the letters should turn blue when you plug in your phone. Try it now to make sure; there is no danger. This ensures the drivers are installed correctly and you are ready to fix or modify you device. Doing this now will avoid a headache later. If it does not turn blue, try using your USB in another port.

    Next is the scary part. As of this writing there are only a few files you can use with the Reverb. The stock kernel and recovery from above and the next one, which is a modified recovery, and a community favorite, ClockWorkMod. Download it now!!!

    Reverb Clockworkmod Recovery Test 8

    This recovery will allow you to make a full backup of the system, data, boot and maybe some other partitions as well as wipe partitions clean. As of this writing, DO NOT WIPE SYSTEM! We do not have a system dump to restore that partition yet.

    Now, to use Odin, fire it up if it's not still on. Plug the device into the computer using the USB cable. Check for the blue rectangle near ID:COM and make sure "Re-Partition" is NOT CHECKED OFF!!! I repeat NO CHECKMARK!!! Once you know the device and computer are connected properly, click the button labeled "PDA." You will now see a file explorer window. Navigate to the desired file and chose it. File explorer will disappear. If you are sure you want to proceed, click "Start" at the bottom of the program window.

    In the message box, lower left corner, you will see what Odin is doing with your device. If all goes well, there will be no error messages and the device will reboot into the Android OS. If not, and you get some kind of error, this is the thread to discuss fixing your device.

    Please give as much detailed information as possible about your situation in your first post. Avoid messages like "I was using Odin and messed up my phone. What do I do now?" I have no idea what happened, but want to provide the best support possible. Copy any error messages you see exactly and describe how you arrived in your situation. If you need intense help, join the IRC by clicking the link in my signature.

    Happy Flashing and good fortune to all!

    Advertisement
  2. sumner2q

    sumner2q Member

    I tried this I keep getting into a boot loop every time I try to boot into recovery can you please give step by step instruction on how to get this custom recovery to boot because I keep have having to flash the stock kernel and still isn't getting any progress
  3. cobretti

    cobretti Well-Known Member

    +1, reflash the tar, your phone will reboot. But I can't reboot w/out a loop period unless I use Odin. Don't kill me, I didn't install the drivers. Is that the problem? Interlope, you fixed up Martinez and got some thanx on that post, you confirm this works and the problem is on my end?
  4. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Sorry I wasn't available earlier. I also forgot I have to subscribe to threads I create on this forum.

    So, if I understand you both correctly, the .tar flashes, but the phone does not boot completely? Then, you flash the stock recovery and all is well? If thats the case, can someone check if adb works and if so try to get a logcat like this:

    adb logcat > logcat.txt
    The logcat will write to c:\ or wherever the ADB binary is I think. If you can get that try to get last_kmsg like this:

    adb shell
    cat /proc/last_kmsg > /sdcard/last_kmsg.txt
    adb pull /sdcard/last_kmsg.txt c:\

    I recently discovered if you hold shift while you right click in a folder you will see an option to open the cmd window there, so you can use Windows Explorer to get to ADB.exe, then shift+right-click and BAM, you can start typing.

    Now, if the flash fails, that's another story. Give me as much info as you can. Any error messages, etc...
  5. cobretti

    cobretti Well-Known Member

    Hey bro, no worries. The TAR flashes successfully, no errors.BUT, the device boots to system, NOT recovery. Fine sofar. Unplug phone and try to reboot phone goes into loop. Try to reboot into recovery w/ button sequence, phone boots to loop. Recovery from terminal, phone boots to loop. The ONLY way to get out of softbrick is to reflash the TAR through Odin. I got the logcat, for some reason the sight won't upload it. How else you want I should send it?
    xInterlopeRx likes this.
  6. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    I think i know what the problem is. I'll fix it tomorrow/today later on. Thanks for the info.
  7. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    ClockworkMod recovery has been updated. Let me know how it goes.

    Cobretti, there's an email address on my profile I think.
  8. cobretti

    cobretti Well-Known Member

    Still no good. Same results. Yellow triangle IS present, and phone is forced into Factory Mode. I have no idea what it does yet but I know it's a /system/app. Shuts down WI/FI and cripples other things.
  9. siyangqiu

    siyangqiu Well-Known Member

    Normally, I'm just a lurker, but today, I made this account to thank you, Interloper! Thanks!
    xInterlopeRx likes this.
  10. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Updates CWM link in OP. This is a fresh build, not just a repack with some different parameter. Let me know what happens.
    bkttk2 likes this.
  11. cobretti

    cobretti Well-Known Member

    We're almost there. CWM sticks, but doesn't work. I have to pull the battery to get out of recovery. Boot options are still missing. Here's the pink and purple abortion SO FAR.

    Attached Files:

  12. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Come on down all you hip cats and cool kitties! Serving up the hot links on a cool December night! Let it rip and hope for the best!

    (And, I updated the CWM link in the OP)
    martinez41613 and cobretti like this.
  13. cobretti

    cobretti Well-Known Member

    You're a dork.
  14. cobretti

    cobretti Well-Known Member

    How's that phrase go? If you build it, they will come. Still no boot options BUT, so far IT WORKS! The prettiest recovery I've ever seen. PROPS TO YA BRO! Still a few hiccups.
    No boot options.

    Device boots to "Factory Mode". I changed the /EFS/FACTORY APP/factorymode file to "off", we'll see what happens.

    Custom Binary counter is on. XDA has a thread to get rid of that.

    Can't partition the extSdCard.

    Check the pic, problems with partitions being unsafe? EFS?

    I made a backup, took forever, haven't gone any further.

    Attached Files:

  15. martinez41613

    martinez41613 Well-Known Member

    Wow. This custom recovery is starting to look good. Awesome Job! Btw does anybody else get a yellow triangle when you boot your phone up normally?
  16. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Ok, a few good things I think I see. One, it looks like the partitions are similar to the Victory, using extSdCard for instance, is the same. Two, I am handsome. Three, Backups take forever on the Victory also, which means I may be able to fix that using my device as a tester assuming its actually something broken. Four, very handsome indeed. When you say no boot options, do you mean they do not exist in the menu or they do not work?

    Also, by the time you finish reading this, there will be a new build linked.
  17. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Everyone does. That's how Samsung lets us know they appreciate our clever efforts but can't come right out and say "We're proud of you" for legal reasons. Some call it The Yellow Badge of Honor. For others it is The Victory Flag. You can esteem it however you decide, or you can get rid of it...
  18. cobretti

    cobretti Well-Known Member

    When you push the power button, the shutdown interface is MIA
  19. Jimmy422

    Jimmy422 Well-Known Member

    Awesome work guys! Hopefully next week I can start doing some testing with y'all. One step closer to custom ROMs! Glad I could help earlier :)
  20. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Is anyone else having the problem described as "the power menu is MIA"? In other words, when the device is running the Android OS, or system mode, does the power menu fail to appear when you hit the power button on the device? I asked Shabbypenguin if any of the Rush users had this problem and he said, well, he said some things that a mother should never hear her son say aloud. But to summarize, none of them had this Power Button MIA issue. Please let me know.

    Also, let me know if you have flashed the latest build, which is reverb-cwm-test-5.tar, and if there are no errors when mounting and unmounting partitions.
    cpk likes this.
  21. martinez41613

    martinez41613 Well-Known Member

    I'm not having that problem.everything works for me on the android os. as for the recovery whenever i choose to reboot it gives me a message about the recovery being replaced and choosing go back reboots the phone instead of going back to the main menu. the recovery doesn't actually get overwritten also it erases the data for some of my apps.
  22. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    And you are using test-5 right? if you can, install BusyBox from the play store and run this command:

    [HIGH]adb shell
    find -name '*recovery*' >> finding.txt
    exit
    adb pull finding.txt c:\Users\Yourname\Documents[/HIGH]

    My Email

    and email it to me.

    Does it erase data when you are trying to use a wipe feature or when it reboots? Have you tried backup and restore yet? I need to know which features work and which don't.
  23. Blackout720

    Blackout720 Well-Known Member

    How long untill we can get a stock rom to work on? If anything how is it done?
  24. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    If you have root, adb and an sdcard you can do this to pull the stock image:

    [HIGH]adb shell
    su
    dd if=/dev/block/mmcblk0p19 of=/mnt/extSdCard/system.img.ext4
    exit
    adb pull /mnt/extSdCard/system.img.ext4 c:\Users\yourname\Documents[/HIGH]

    Now, the hard part...In order to work with this image you need the entire SDK and to be able to mount and modify it. This is actually best done on a Linux system.

    Also, this is another topic entirely and should have been posted in another thread.
  25. cobretti

    cobretti Well-Known Member

    Hey John, thisswussup. Couple of bugs.
    What Martinez was saying. (option)Reboot to system now. Yes, push power button. Whoa, CWM comes back with another screen, nothin' scary, ROM may flash stock recovery on boot. Fix? THIS CAN NOT BE UNDONE. (option)no (option)yes-Disable recovery flash
    (option)+++++Go Back+++++. (No), and (Go Back) reboot to OS. I haven't tried option C. I'm speculating but the back door seems to work, choose that option and CWM is waiting for the package from ADB. I backed up my system, took forever, got about 2megs of .dat. Mnt/umnt all work except sdext. It doesn't like your fstab! It wipes the Dalvic but then tries to rm it, but can't because no file or directory exists? I tried to play around a little to get as much .txt as I could. Here's the log from CW. Kinda cool, you can read and send error reports IN recovery. Well actually he'll tell ya to have RM send the report but he'll throw one up on the screen for ya.

    Couple other things. On boot, this has happened like four times since running this, "Android is updating".

    The whole MIA power interface problem and "Factory Mode" might not have anything to do with this. Since we got root, I been tweakin' build props, system settings, trashin' files and bloat. But I got 9 enabled receivers when I boot. Just a taste.

    Factory Mode
    com.sec.android.app.serial_number_label_Indicator.MainLabelBroadcastReceiver
    started by android.provider.Telephony.Secret_Code
    com.sec.android.app.shutdown.ShutdownSettingBroadcastReceiver
    started by android.provider.Telephony.Secret_Code
    com.sec.android.app.version.Version_Receiver
    started by android.provider.Telephony.Secret_Code
    com.sec.android.app.entry.FactoryKeyStringBroadcastReceiver
    started by android.provider.Telephony.Secret_Code

    FACTORY TEST
    com.sec.android.app.camerafirmware.CameraFirmwareBroadCastReceiver
    started by android.provider.Telephony.Secret_Code
    (Factory Test).entry.Factory TestBroadcastReceiver
    started by android.provider.Telephony.Secret_Code
    com.sec.factory.entry.request_factory_reset
    (Factory Test).entry.SetupWizardSkipReceiver
    started by android.intent.action.Boot_Completed
    android.intent.action.Pre_Boot_Completed
    android.intent.action.Close_Setup_wizard
    android.intent.action.Enable_Setup_wizard
    android.intent.action.Sim_State_Changed

    One other thing, maybe this is what Martinez was talking about. All of the sudden I had like 20megs of junk in /Lost Dir. Suffix stripped. Had to run a cat just to peek.

    JMB

    Attached Files:

Share This Page