[OUTDATED] Root 2.2.1 and get Data WORKING!!!


Last Updated:

  1. joneidy

    joneidy Well-Known Member This Topic's Starter

    Joined:
    Jan 15, 2011
    Messages:
    307
    Likes Received:
    376
    If you want can make another thread just with the video so people can easily follow it :)
     

    Advertisement
    Strider0007 likes this.
  2. magdiel1975

    magdiel1975 Active Member

    Joined:
    Mar 4, 2011
    Messages:
    38
    Likes Received:
    0
    What ever is easier for you guys.. as long as in the end i am able to root my phone hassle free... :p
     
  3. mikekelso421

    mikekelso421 Well-Known Member

    Joined:
    Feb 1, 2011
    Messages:
    671
    Likes Received:
    366
    That's the plan.thank you fir making this possible!all credit goes to you guys! :)
     
    joneidy likes this.
  4. mikekelso421

    mikekelso421 Well-Known Member

    Joined:
    Feb 1, 2011
    Messages:
    671
    Likes Received:
    366
    the video is made..im uploading to youtube now..smoking one while i wait..i should have it up in a new thread within the hour!!!!!!! its a little sketchy but it should do the job!
     
    pmb116 likes this.
  5. pmb116

    pmb116 Well-Known Member

    Joined:
    Feb 24, 2011
    Messages:
    525
    Likes Received:
    93

    hopefully it will help me out as I've started from scratch numerous times and followed every step to the T and still keep getting the same error. And thank you for your time and effort
     
  6. Strider0007

    Strider0007 Well-Known Member

    Joined:
    Feb 4, 2011
    Messages:
    103
    Likes Received:
    12
    I just want to thank everyone involved on putting it all together for us to follow. It took me two tries and it worked. First was my mistake for trying to use custom ROM to go back to 2.2 from stock 2.2.1 but restarted the process and it worked like a charm. Thanks again..I'm so happy I can remove all the bloatware and free up resources, phone runs a lot better now.
     
  7. Ventrue05

    Ventrue05 Active Member

    Joined:
    Mar 6, 2011
    Messages:
    41
    Likes Received:
    0
    i have the same exact problem...


    ERROR: Unable to load [LGNPST_PortManager5.dll] Component Path = C:\LG Electronics\Components 5.0\LGNPST_PortManager5.dll Version = HR= 0x0


    Edit1: i tried again but did not run in admin mode... seems to be working so far. will keep everyone posted.
     
  8. Ventrue05

    Ventrue05 Active Member

    Joined:
    Mar 6, 2011
    Messages:
    41
    Likes Received:
    0
    after watching the video i figured out what i was doing wrong lol..

    i ended up doing a hard reset somehow n just started over and watched the vid step by step n bwala i have a working rooted 2.2.1 optimus m. woot. thanks.
     
  9. dantedom

    dantedom Member

    Joined:
    Feb 13, 2011
    Messages:
    17
    Likes Received:
    2
    yyyyyyyyyyyyyaaaaaaaaaaaaaayyyyyyyyyyyyyyyy i finally got the service to work. what i did different this time was install the custom recovery using 'adb shell' instead of the terminal emulator of jack. got to the blank screen after entering recovery , took the battery out then went back again into recovery using 'power + vol down + home' and then used adb shell while in recovery and execute " reboot recovery" after taking the battery out again there it is when i turn it on. SERVICE WORKING!!!!! ;^D i was so frustated. thanks everyone for you help. thanks joneidy for gathering the info
     
    joneidy likes this.
  10. fylpee

    fylpee Well-Known Member

    Joined:
    Jan 8, 2011
    Messages:
    55
    Likes Received:
    4
    can somebody tell me how to root my optimus w/o downgrading to 2.2
     
  11. eprano1969

    eprano1969 Member

    Joined:
    Feb 26, 2011
    Messages:
    7
    Likes Received:
    0
    I am not sure if I did this the right way, but is this the latest drivers/LGPST data, im not sure I am running the right builds of them all as I failed at this 5 times in a row and never got root...

    Erik
     
  12. Prime85

    Prime85 Well-Known Member

    Joined:
    Feb 7, 2011
    Messages:
    800
    Likes Received:
    201
    This is how you root without downgrading.

    The directions above are for rooting 2.2.1, all your supposed to get from the downgrade part is installing the LGPST
     
  13. absoludacris

    absoludacris New Member

    Joined:
    Mar 8, 2011
    Messages:
    1
    Likes Received:
    0
    This is fantastic. Thank you for the posts. Works like a dream!
     
  14. avalon173

    avalon173 New Member

    Joined:
    Mar 10, 2011
    Messages:
    1
    Likes Received:
    0
    Hi all.I thought I would put my 2 cents in.This method works 100% as I successfully completed the root upgrade on my 2.2.1 phone.There are some things that are not listed in the directions that caused me some problems with this that you should know before you try it.First off,do not do this unless you are connected to the net as the SDK pack needs to download files off the net.If you do like I did and try this offline you will get stuck at the SDK portion of the directions.The other thing I had a problem with was the recovery part to get back service.You MUST check your phone to make sure it is in debugging mode when you go to the final command prompt lines of the directions or you will receive errors.The phone will most likely reboot out of debugging mode.So,double check it.Other than my own stupidity this method is sound.
     
  15. magdiel1975

    magdiel1975 Active Member

    Joined:
    Mar 4, 2011
    Messages:
    38
    Likes Received:
    0
    I get this message when I try to open the LGNPST .."Fail to load the Skin.DLL"...
    I've tried uninstalling everything and reinstalling but still getting the same error.
     
  16. Cbelflower321

    Cbelflower321 Well-Known Member

    Joined:
    Feb 14, 2011
    Messages:
    75
    Likes Received:
    5
    When I try to drag MS690.dll onto reggie, i get this error message:

    HRESULT == 0x80020009

    Exception Occured

    Why isn't it working?
     
  17. magdiel1975

    magdiel1975 Active Member

    Joined:
    Mar 4, 2011
    Messages:
    38
    Likes Received:
    0
    Got it!!!... thanks mikekelso!!
     
  18. Mayimbe007

    Mayimbe007 Member

    Joined:
    Mar 10, 2011
    Messages:
    22
    Likes Received:
    2
    Right click over Reggie.exe and click on Properties. Then go to the Compatibility tab then check of the box that says "Run this program in compatibility for XP SP3". After clicking ok you should be able to drag the dll onto Reggie without any issues.
     
  19. Cbelflower321

    Cbelflower321 Well-Known Member

    Joined:
    Feb 14, 2011
    Messages:
    75
    Likes Received:
    5
    When I do this the only option is xp sp2. When I click that and try it, I still receive the same error message.
     
  20. magdiel1975

    magdiel1975 Active Member

    Joined:
    Mar 4, 2011
    Messages:
    38
    Likes Received:
    0
    Now that I have my phone rooted... which program do I use to be able to remove apps and make changes? There is a superuser icon but when I click on it the only options available are log and settings. the apps section is shaded and cant' click on it.
     
  21. joneidy

    joneidy Well-Known Member This Topic's Starter

    Joined:
    Jan 15, 2011
    Messages:
    307
    Likes Received:
    376
    To remove what apps? Do you mean the metro apps?
     
  22. magdiel1975

    magdiel1975 Active Member

    Joined:
    Mar 4, 2011
    Messages:
    38
    Likes Received:
    0
    no i mean the superuser icon that installs after you root the phone.. when I click on it.. on the top I see ..apps, log, settings... the "apps" icon is shaded and wont let me click on it.

    actually the only apps superuser lets me delete is the downloaded ones... those are the only ones that come up... I cant access the system apps through superuser. ..
     
  23. joneidy

    joneidy Well-Known Member This Topic's Starter

    Joined:
    Jan 15, 2011
    Messages:
    307
    Likes Received:
    376
    If you want to delete like the bloatware from your phone that are the apps that metro install you have to use root explorer and delete them.
     
  24. magdiel1975

    magdiel1975 Active Member

    Joined:
    Mar 4, 2011
    Messages:
    38
    Likes Received:
    0
    Ahh.. ok.. so what's the purpose of the superuser icon then?
     
  25. joneidy

    joneidy Well-Known Member This Topic's Starter

    Joined:
    Jan 15, 2011
    Messages:
    307
    Likes Received:
    376
    It`s just an app that provides root permission. The icon is usually used to see what apps have request root permissions. You must have this app so your phone stays rooted.
     

Share This Page

Loading...