overclock adjusting itself??


Last Updated:

  1. aaronmach1

    aaronmach1 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    394
    Likes Received:
    12
    Ive been noticing that ill set my droid overclocked to 1000mhz max and now and then ill notice that it sets itself back to 800mhz max. why does it keep doing this?
     

    Advertisement
  2. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    Do you have any profiles set within SetCPU? If you had a charging profile set for a lower frequency, your phone would move to that freq as soon as you plugged your phone in. This can also be set via battery power remaining, temperature, etc.
     
  3. aaronmach1

    aaronmach1 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    394
    Likes Received:
    12
    yes i have a profile for sleep/standby and one for charging, both set at 550mhz. thats not the issue though. im mean its setting its self and will hold it until i adjust it back to the 1000mhz that i want. not just adjusting itself in standby or charging.
     
  4. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    Okay, I understand your issue but I need a little more info. What is your current setup (Rom version, Kernel version, SetCPU version)? Has this just started out of the blue, are you using a new ROM, new kernel, new installation of SetCPU??? I'm just trying to get a feel for whether or not this is a new problem with an existing configuration or a problem where it has never worked propertly.

    Some things I would try without knowing those details (starting from the easiest to do):

    1) Uninstall/Reinstall SetCPU

    2) Re-flash your existing kernel

    3) Flash a new/different kernel

    4) Back up your apps and make a nandroid backup...then wipe your phone (data and cache) and then reinstall your current ROM. Then restore your applications.
     
  5. aaronmach1

    aaronmach1 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    394
    Likes Received:
    12
    Well i notice it has did it a couple times now.i would say once a week. Im rooted with smoked glass v5. im using set cpu by michael huang. kernal version:2.6.29 smoked_glass adamz@ubuntu #9.
     
  6. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    Hmm... Don't take this wrong, but SetCPU setting itself to 800MHz once a week doesn't seem like much of an issue to me. Granted, I'm saying that as I don't have a specific answer to your question. 800MHz seems like a strange number to have your OC revert to based on the fact that you don't have 800MHz listed as a profile (correct?). I would understand if it reverted to 550MHz cause I would conclude that your SetCPU application failed, or froze up.

    Try some of the fix actions I listed in my last post and see if that helps. I don't think I've kept one single configuration for a week since I rooted...maybe that's why I've never seen this kind of issue before.
     
  7. shizzy1427

    shizzy1427 Well-Known Member

    Joined:
    Nov 22, 2009
    Messages:
    463
    Likes Received:
    36
    I would just try out a different kernel, chevy's are great, my phone runs super cool on chevy's kernel and no random reboots or anything
     
  8. aaronmach1

    aaronmach1 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    394
    Likes Received:
    12
    ok i figured it out but i dont know why. It does it everytime i shut the phone off and when i turn it back on its at 800 instead of 1000mhz. your right its not a big deal but i just wondered if i could change somthing to remedy it.
     
  9. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    You could definitely try a new kernel. Just make sure it is compatible with your ROM.

    Better yet!...You're on Smoked Glass v5?...Check out Smoked glass 6.0.1. I hear they implemented the helix launcher (used in Koush's Cyanogen ROM). Very nice stuff IMO! :D

    You have one of those "quirky" problems that you probably will never see again once you change something...the ROM, kernel, etc...I'm guessing of course but I have never seen or heard about anything like what you are seeing.
     
  10. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    I was just looking at the change log for 6.0.1 and I think I misspoke about the Helix launcher. I'm sure I heard of other roms implementing it...may have been Bugless Beast instead. I highly recommend trying that laucher :)
     
    aaronmach1 likes this.
  11. vincentp

    vincentp Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,640
    Likes Received:
    59
    The SetCPU switching is almost definitely due to the kernel not playing nice. Try another kernel for a bit and see if that solves the problem.
     
  12. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    Joined:
    Jan 5, 2010
    Messages:
    1,307
    Likes Received:
    515
    This is probably a dumb question, but do you have "Set on Boot" checked in SetCPU?
     
  13. aaronmach1

    aaronmach1 Well-Known Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    394
    Likes Received:
    12
    figured that one out i must not have, but im trying a new rom now so ill see how it works out!
     
  14. slosh

    slosh Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    143
    Likes Received:
    7

    As stated above you need to have setcpu "set on boot" checked or it will revert back to what the kernal is set for stock which is 800 on boot up. check the set on boot and you will be fine.
     
  15. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    There are dumb questions but this isn't one of them :D

    I thought you might have something here so I did some testing to see if I could force the problem.

    I set the MHz for 800 and then clicked the "set on boot" box. I then restarted the phone. When I opened SetCPU, I unchecked the box and then adjusted the slider to 1.2 Ghz. I then rebooted the phone. Once it restarted, I checked SetCPU and it was set for 1.2GHz.

    So then I tried a different way and I repeated step 1 and set it to 800MHz and checked the "set on boot" box. I moved the slider to 1200 and then unchecked the box (reverse order)...but still when I rebooted...it was set to 1.2GHz

    Sorry if that was a bit of a teaser but I thought that could have been what was causing it...I couldn't reproduce it however. I did come to the conclusion that I don't know what "set on boot" actually does! :D
     
  16. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Joined:
    Jan 31, 2010
    Messages:
    4,335
    Likes Received:
    1,563
    Per my last post, I couldn't make SetCPU do what you say it will do. I thought this was the way it worked too but I couldn't make it happen.
     
  17. Fabolous

    Fabolous Superuser VIP Member

    Joined:
    Nov 7, 2009
    Messages:
    3,635
    Likes Received:
    2,126
    Yeah, if you don't have "set on boot" checked, the clock speed will default to the kernel's default speed.

    You guys must be running some older kernels though, since I believe all of the newer ones default to 550 or 600.
     

Share This Page

Loading...