paid apps don't update?Support


Last Updated:

  1. Jerry-rigged

    Jerry-rigged Well-Known Member This Topic's Starter

    Joined:
    Feb 15, 2010
    Messages:
    255
    Likes Received:
    25
    So I rooted and rommed (bb .4) about a month ago. No major issues, it all seems good, except for one thing-

    When ever I update notice for one of my paid apps, it won't update - it goes to the google checkout and wants me to pay again. Should I e-mail the app developer? Or is this a known issue with root & roms, with a work around?

    Help?

    Jerry
     

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    Not a known issue - your paid apps are connected to your Google account that you first registered your phone with.

    If you performed a factory reset, and then use a different Google account when setting up the phone, your paid apps will not show as having been paid anymore.

    You have to set up the same account as the primary account in order for that to work the way it is supposed to.
     
  3. hobie5

    hobie5 Member

    Joined:
    Nov 13, 2009
    Messages:
    11
    Likes Received:
    0
    Ok, so I installed a Froyo Rom and restored a paid app from Titanium backup. I have two google accounts on the phone, one that I use for email and the other that I used to purchase this paid app. No matter what i've tried it always asks me to repurchase for an install or update.

    I've tried to remove my other google (non paid app) account. - no luck
    I've tried to uninstall and reinstall - no luck
    (When I uninstall it even says I can reinstall again for free) Ha!
    I've reinstalled from backup and tried to clear data - no luck
    Ive sent an email to the developer and he just said to use the same account. - no luck.

    I realize that the app is supposed to be tied to the google account I used for purchase but, why won't it let me update when the account is clearly connected and syncing? I did connect my (other) gmail account first and the paid app account second however that's why i tried to remove the mail account and that didn't seem to matter.

    Is there a place to specify which google account is being used for authentication or something like that?

    The app in question is Remote Wave by Walter Yongtao Wang.

    Thanks for any help!

    Droid Incredible
    Rooted base froyo rom
     
  4. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    Hmmm, perhaps it is the fact that it is being restored from TiBu? Normally that does not matter, but since it let's you reinstall it after uninstalling it, just uninstall it and then let the market allow you to reinstall it.
     
  5. hobie5

    hobie5 Member

    Joined:
    Nov 13, 2009
    Messages:
    11
    Likes Received:
    0
    Sorry for not being clear on that. No matter if I try to install or update it asks for payment again. This is the only app I've purchased so far so I have nothing else to test with. The only way I've been able to "reinstall" is by restoring from backup.
     
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    That's weird. Check your Google account settings online and see if it lists the app as being paid or not.

    If not, then try to see if you perhaps purchased it at a third party site, rather than Android Market...
     
  7. hobie5

    hobie5 Member

    Joined:
    Nov 13, 2009
    Messages:
    11
    Likes Received:
    0
    Yeah it's the strangest thing. I didn't even know you could see your purchase history inside the google account until you mentioned it. I looked online and it does show up there. I just tried to change the password on my account and did a battery pull out of desperation. Do you think it could have something to do with the fact that I cancelled the credit card I used to originally purchase? Walter got his money so I can't imagine that would be the case. It has to be related to the rom I used or the way I backed up.
     
  8. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    Hmmm, you could make a full TiBu backup, then perform a factory reset, then log in to your account and see if the apps restore automatically. It might be that TiBu doesn't play nicely with that particular app....

    That is the only thing I can think of. Oh, since you canceled the credit card linked to the account, try just linking another card to it...

    Since the payment has already been processed it really shouldn't matter, but since you don't ahve a card attached to the account, that *may* be causing you and issue - and that means it is time to contact Google, b/c that should never be a factor.
     

Share This Page

Loading...