Pandigital Novel 7 useless...Support


  1. tazman137

    tazman137 New Member

    I cant get the Pandigital updater to run, it crashes, like it does for everyone... and you cant even install Amazon app store.. on top of that most apps wont even install cause you get "cannot parse the package" which is due to the OS being too old and not supported.

    Got 3 for my kids for xmas but there is nothing you can do with them but read books and surf. Wish I'd known this sooner...

    Advertisement
    :
  2. tazman137

    tazman137 New Member

    I called their support and was told to return them. they are no longer supported and nothing works for them anymore.

    Great.
  3. The_Chief

    The_Chief Accept no imitations! Moderator

    First of all Tazman, welcome to Android Forums!

    Second of all, I am so sorry to hear that your Novels do not meet your expectations. Trust me: I have a 10" gTablet that is in much the same situation. It still has Android 2.2 on it, and Google Play Market, on that particular Android version, isn't supported on tablets larger than 7 inches. So it's now more of an entertainment device that a tool like my Nexus phone is.

    While I'm not familiar with the Pandigital, I am familiar with what you're going through. Great to have you aboard, and we are here to help any way we can :)
Loading...

Share This Page