pandigital planetSupport

Last Updated:

  1. iwannabeam3

    iwannabeam3 New Member

    Hi all this is my first post and since I didn't see a section for the planet? I figured I should post here. Well I just got a pandigital planet today (on clearance at my work) I turned it on got it set up to my wifi and everything and it poped up for a firmware upgrade so I went ahead and started that and it said to plug in the tablet if below 30% power It had 20% left so i plugged it up, well thought i did but didnt have the cord all the way in. It never died and then i realized it wasnt in all the way so I plugged it the rest of the way in. And it finished downloading the update and then started rebooting. Now its just stuck at the start up screen,anyone have any ideas on how to fix it? please help asap

  2. nuismer

    nuismer Active Member

    If it has a reset hole - try it. If no reset hole, try holding down the power button for a long time (30 sec). If that shuts it down, then restart. Hopefully, one of these should get you back in business.
  3. iwannabeam3

    iwannabeam3 New Member

    It doesn't have a reset button. And I've tried shutting it down and back on to where it reloads the new firmware and it goes right back to the same screen :( and i cant figure out the buttons for recovery mode.
  4. The_Chief

    The_Chief Accept no imitations! Moderator

    Hi Iwannabeam3 and welcome to the forums :)

    If you want to access your tablet's Recovery console to try a factory reset, make sure the tablet is off. Hold the volume UP and then the power button, at the same time, for at least 3 seconds. It should boot into Recovery mode for you.

    In Recovery, navigate the menu with the Volume UP button and use the volume DOWN button to select.

    Try that. Hope this helps :)

    EDIT: By the way - if you want to start a forum for the Pandigital Planet, you can make a suggestion to the admins here:

    That way the Planet will have its own dedicated home here :D
    nuismer likes this.
  5. iwannabeam3

    iwannabeam3 New Member

    It wouldnt go into a recovery mode either, i just tried and it just sits at the boot screen. Unless im supposed to hold the volume button. Just tried that and didnt work either :( Just also called pandigitals support number and they cant even help. So I just bought the device and its bricked via their update?
  6. The_Chief

    The_Chief Accept no imitations! Moderator

    Do you have anything like a Squaretrade warranty? When our tablet failed, they (a) fixed the hardware and then (b) flashed the latest stock operating system and bootloader. It's something to consider if Pandigital refuses to let you ship the tablet to them so they can re-flash the operating system. Just a thought.
  7. nuismer

    nuismer Active Member

    In doing a lot of reading on this and other forums I ran across someone going through steps to recover a "bricked" tablet. One of the last steps was to run the tablet completely out of juice either by removing the battery or running it until it will no longer display and then overnight it. Then recharge it and see if it will boot properly.
  8. ecarman

    ecarman New Member

    tried to reflash but now can't even get a screen to come up. vol. key makes sound but no screen. Can't get it to power up. Please help
  9. nannycrick

    nannycrick Well-Known Member

    I picked up one of these at the local flea market for $20 bucks. I had to do quite a bit of research on this thing. I found for info on it. A good dev, Spz0 wrote a good GB rom, and the download links are still active. The battery calibration issue can be fixed with a downloaded zip file in the Hardware section of the forum. Although this version of the rom is a little outdated, if you have a phone that's rooted, you can use some apks to update it. I pulled the newest Google Pay from XDA Developers. Remember to change the permissions to rw-r-r in the system/app directory after you move the apk there. You may get a "false" error message- "application did not install". That's O.K. Go back into the system/app folder and find the app -Marketupdater.apk. hit it to "re-install". Eventually Google play market will update to the latest version. If you don't have that version, xda developers will. Just google search it up!
    Between & xda developers, you'll get this tablet updated. I recommend plugging the stock planet into you PC first and making a copy of EVERY file. Also, get a big sd card, about 16gb. you'll need it. And get rid of the stock all in one memory manager. It's old, and has NO white list, so the app killer will kill everything including Superuser! The new rom will come with superuser, but you want to download the latest zip version directly from Chainfire's website. It will help. Mine is now running OpenPDP 2.3.4 v2.1 w/Google play version 4.3.11. I have adobe flashplayer.apk v11.1 downloaded from Adobe's archived flash player website. (you have to delete the old apk, then paste the new apk in the system/app directory. Don't forget your permissions changes. Wifi works, no working GPS available, front & rear camera works, music works. (you can load DSP Manager into it the same way you loaded flash player) It made a nice little FULL Android tablet. Good Luck!

Share This Page