Pandora in the car with a MaxxTips

Last Updated:

  1. CKwik240

    CKwik240 Well-Known Member

    So I've had the Maxx for 6 days. And to preface this thread, I am going to first say that I am a huge nut about vehicle integration. That is, I want things to work as if it were designed that way.

    That said, my Pandora experience in my car has been rather horrid. The music plays fine and all, but its the start up and shut down processes that are just erratic. With the Bionic, I had used Smart Actions to trigger Pandora when it detected the phone was docked and connected to the car via bluetooth. It worked really well. Giving Assist a try, it did try to work. Generally, it was pretty responsive to getting started. But it didn't bring up the app on the screen. It only played the music. If I try to bring up the Pandora app either by pressing the icon on the homescreen or by using the notification, it would force close. Furthermore, it would also force close everytime I got out of the car. And 90% of the time, it would relaunch the app. This means I then have to wait for the app to open so I can pause it. If I forgot, it would just start blaring over the speaker, usually from my pocket.

    So I tried turning off Assist and using Bluetooth Connect and Play. It was still having the same issue. I decided to look into what the "Bluetooth for automotive setting in Pandora does last night to see if that might be a part of the problem. I could not find any credible source that said what it did. It was implied that this setting automatically starts and stops Pandora with the bluetooth connection. I tested today and anecdotally, that does appear to be the case. So I tried unchecking that feature and letting Assist handle it. Still produced a force close in the scenarios I listed above. I checked it again and turned of assist and same thing. Then I unchecked it and used Bluetooth Connect and Play again and sure enough, it worked. I'll have to see if its consistent over the next few days, but I'm hoping it sticks.

    Now, I have to wonder what the hell is going on. My impression is that there is a conflict with more than one app trying to start Pandora for me. What I don't get is why it still had the error with the box unchecked and allowing assist to launch it. I can't make any sense of it. I hope we see a fix in the future, but if my workaround works, I'm good for now.

    Next on my list is figuring out how to get text messages to be read by Uconnect. It has worked once and only once.

    I'd also love to get the MetaData working, but that may be more of an issue with UConnect (Chrysler). A few people have claimed their metadata has worked in the same car with certain phones, but mine does not. My Bionic did not either. Both work fine with the Pandora App in MyLink (Chevy).

  2. mistermojorizi

    mistermojorizi Well-Known Member

    i have it starting and shutting down automatically through tasker. even turns up my bluetooth volume so i don't have to look down at the nag screen. then my buttons on the steering wheel control skipping tracks and stereo volume.
  3. CKwik240

    CKwik240 Well-Known Member

    I spoke too soon. Happened again yesterday. Last night though, I left my phone off the dock. It started playing Pandora without a hitch and paused it just fine when I shut off the car. Basically, it sounds like a conflict with whatever app controls the dock.

    Mr Mo, do you have yours in the Griffin Dock?
  4. CKwik240

    CKwik240 Well-Known Member

    New solution. I found that since the Maxx does't have a dedicated dock screen with icons like past moto droid phones and being in portrait makes me not care as much, I really don't need any kind of a dock trigger. The stock launcher has been working fine for my needs. So to keep from running into conflicts with whatever app controls the dock, I just made it so it won' trigger. I partially opened up the dock and removed the magnet. I haven't tried it yet, but there really shouldn't be any issues with it.

    I attached some photos. The first shows the magnet. This is the left side of the dock if you're facing it (same side as the Micro-USB port). The second just tries to show some of the inside. The small green printed board is where the micro-USB port is. The third photo shows the magnet is no longer there. The last is the lower rubber section lifted. Mine happened to be not glued very well so it lifted easily and I used a small screwdriver to start separating the front panel there. The two pieces are ultrasonically welded so its not very strong and will start coming apart easily wherever you can get something in the seam. I used my boxcutter to open the side corner slightly once I had the corner separated and then held it open with the blade as I moved the screwdriver there. Once that is in, you can leverage it open along the edge. I used the same box cutter to dig the magnet out. It is slightly recessed on the outer edge so you need to get something down under it. The last photo also shows the two wires going down to the micro-USB port where the phone attaches.

    Not sure anyone else cares to do this, but at the very least, its always pretty cool to see the insides of stuff. Sorry I didn't take it apart fully. A partial opening allowed me to glue it back together really easily.

    Attached Files:

    Clementine_3 likes this.

Share This Page