Pantech Burst battery drains faaasssssttttSupport


Last Updated:

  1. lalabluee

    lalabluee New Member This Topic's Starter

    Joined:
    Oct 5, 2012
    Messages:
    2
    Likes Received:
    0
    What is wrong with my phone? In 45 mins the battery went from 50% to 11%? I was asleep and no apps or any thing on the phone was being used. I tried charging it but it took about 30 mins to charge from 4% to 6%. Also, my mom has the Pantech tablet that came in the phone deal (forgot the name -__-) and i tried using her chager that outputs 2A and it charged a lot quicker. My charger is a 1A. What's going on? Is it the phone or battery or charger? Help pleaasseee.
     

    Advertisement
  2. kartikoli

    kartikoli Well-Known Member

    Joined:
    Apr 18, 2012
    Messages:
    79
    Likes Received:
    10
    try charging through PC and see if it work properly

    if yes then your phone battery is good and the problem is with charger
     
  3. lalabluee

    lalabluee New Member This Topic's Starter

    Joined:
    Oct 5, 2012
    Messages:
    2
    Likes Received:
    0
    I tried charging it through my netbook and it still took long to charge :/
     
  4. kartikoli

    kartikoli Well-Known Member

    Joined:
    Apr 18, 2012
    Messages:
    79
    Likes Received:
    10
    now there are 2 possible senario
    1 - cable is faulty ... try charging with another cable [friend etc...]
    2 - battery fault
     
  5. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Joined:
    Feb 21, 2012
    Messages:
    6,420
    Likes Received:
    1,204
    Hello welcome to the forum I see you have a problem with your pantech. Well if the battery has a problem. Is your device rooted. Next thing try and and reset the device. This will erase the battery stats to a fresh start. Now after wiping the stats clean get the app juice defender from the market.
     
  6. clma55

    clma55 New Member

    Joined:
    Jul 29, 2013
    Messages:
    1
    Likes Received:
    0
    very av...but bateery life makes me mov with a charger in the pocket. The only advantae: 1Gb rom..
     
  7. ashok520

    ashok520 New Member

    Joined:
    Oct 17, 2012
    Messages:
    2
    Likes Received:
    0
    I also faced the same prob. I installed DU BATTERY SAVER from play store. My battery remains longer :)
     
  8. mrnyjet

    mrnyjet Well-Known Member

    Joined:
    Feb 22, 2013
    Messages:
    265
    Likes Received:
    34
    son had same problem but finally enabled power saver app on phone /settings and especially keep the wifi set to OFF. That was causing phone to constantly look for wifi connection while rapidly draining the battery as a result.
     
  9. ashok520

    ashok520 New Member

    Joined:
    Oct 17, 2012
    Messages:
    2
    Likes Received:
    0
  10. cocoatea

    cocoatea New Member

    Joined:
    May 6, 2014
    Messages:
    1
    Likes Received:
    0
    My phone is not rooted and I want to root it but when I connect my phone to my PC it'll show debig mode and USB connected select to copy file .And I can select USB storage and copy files but when I open kingo it'll show no device connected I've tried 100% but stil same thing and when I wnt root with poot app the fone will freeze and get heated
     

Share This Page

Loading...