Pantech flex bricked- software? Hardware? Fixable?Support


  1. Neofyte

    Neofyte Member

    First let me say hello, just joined the forum moments ago and glad you all are here. I'm new to Android, far from new to Linux, and brand new to this Pantech Flex sitting in front of me. Got it from a friend who figured it was just dead, but I can't let things sit and die, and I know it can be fixed, I just don't know yet how involved it might be. I presume it's software, but of course it might be hardware. I like the Flex's specs, which is why I'd like to keep it.

    The phone, as far as I know, is bone stock. Here's what it will do:

    -Plug it in to the charger, vibrates once, and you get Pantech logo screen, and it just hangs there, forever.

    -Fresh, fully charged battery, vaibrates once, same logo screen, same hang time.

    -Try factory hard reset (volume up, power on), vibrates, Pantech logo screen, just hangs out, and it does not matter if I release power at the logo screen or hang on to it, I never get anywhere else. No robot repair, nothing.

    -Hold volume down and power, same thing as above.

    -Hold volume button in the center and power, I get a diagnostic scree. Shows me it's stock ROM, not rooted, and factory locked. I get a menu below for PDL downloads/updates, Fastboot, Reboot, or power down. Pressing PDL takes me to generic update screen, but it just hangs there forever. Fastboot says Fastboot Mode, but nothing happens. Reboot just hangs there forever. Power Off will power off.

    -Finally, once the Pantech logo, or any of the other screens, is up, you cannot power down without removing the battery. Pwr button does nothing.

    If it helps, I have Back Track 5, rel. 3 running on one machine. I'm not familiar with SDK or APK at the moment, but they are there and if need be I will know them soon.

    That is it. It has a brand new battery in it, fully charged, but since I don't know if it's actually charging or not, I don't know how long it will last.

    ANY help, advice, suggestions, ideas, recommendations, etc, will be greatly appreciated. This is the project I chose to learn about Android. Seems I'll learn from the inside out, or maybe on another device.

    Advertisement
    :
  2. teddyearp

    teddyearp A guide with guides Guide

    I _think_ a factory data reset will fix it. This is not the same as the "Factory hard reset" you described, in fact, that exact term is not for phone running Android AFAIK. This is one of the first ways to solve problems on an Android phone. This can be done while booted into the recovery system.

    On your phone you were almost there. What you need to do is hold the volume up, volume down, and then power the phone up. Make sure it is volume up and volume down. Holding in the middle of the volume button, well you already know what that does.

    Once booted into recovery, there should be an option to do a factory data reset.

    good luck
    Neofyte likes this.
  3. Neofyte

    Neofyte Member

    Thanks for the advice Teddy.

    I talked first with Pantech and what they call the hard reset (not mentioned in the manual) is vol up and power on, release when you get the repair icon (they were not clear on whether to hold both or just vol up until the robot surgery icon, but neither works for me at the moment, so there you go). I found the procedure you mention by trial and error. Sadly, the options on the screen are all essentially non-functional. Power off works, but reboot does not. Fastboot shows fastboot mode but no other functionality, and PDL download shows the software update download icon, but it will just stay like that till the battery dies. Of course when I mention this screen and menu options to the "tech" guy at Pantech, we go from maybe kinda sorta getting some actual technical advice to silence followed by "send it in under warranty for a new phone/ send it in out of warranty for repair".

    I'd love to find a tool, or learn if tools in SDK will do same, that I can set up in Debian or in BackTrack. I am working on getting Go-mtpfs set up to mount the device. If it works without conflict in LMDE, then I'll see how it works with the phone. If anyone thinks I might be barking up the wrong tree, maybe should bark up a tree nearby, by all means let me know!

    **update**

    So, though I hate to do it, I pulled out the Win7 laptop, installed Pantech PC suite 1.1.1.3437, just to see what may happen. Of course PC Suite won't do much simply because with the phone a bit bricked, I can't get it into debug mode, so I tried a few things, and here is what I find:

    Phone on, Pantech logo screen only, the laptop doesn't see it plugged in.
    Phone on, above mentioned diag. screen up, same, until I select something. Then I hear the magical MS bonk of a device plugging in. I get a "generic android" description. I give updating drivers a shot, and viola!, now I see it's a Pantech android device, pantech android usb composite device, ver1 to be precise.
    Selecting PDL upload actually does a bit more to update drivers, but I still can't get anything to happen with the phone, and I can't actually get in to the phone at all.

    I don't have SDK installed on the Win laptop, but maybe I should....but can I even get in to the phone if I can't get debug on the phone itself? Is there a workaround or can ADB be forced, in the nicest way possible, from outside?

    Again, thanks. Progress is being made, bit by bit, I think. Perhaps I'm wrong, but I can hope. It's a challenge and a good learning experience.
  4. teddyearp

    teddyearp A guide with guides Guide

    So you cannot get it booted into recovery? I looked around the web and the instructions I gave should get you into standard Android Recovery which hasa factory data reset as one of the options. Hmmm. . .

    Try installing adb on your win7 box. You can use the 'mini' version instead of installing the whole SDK. The mini version has adb.exe and two .dll files. Search my samsung folder for "Win_Nexus_Root.zip" and you will find the three files in there. Then try:

    Code (Text):
    1. adb reboot recovery
    And see if that boots you into recovery. Otherwise, I am stumped if your recovery doesn't have factory datta reset.

    good luck
    Neofyte likes this.
  5. Neofyte

    Neofyte Member

    Thanks again, Teddy,

    I've got adb and fastboot tools on the Win7 machine, but either I just don't know how to use them yet (very likely) or I need to fiddle with the path. They execute from the icon in the folder- the terminal comes up, I see them running, and then they are done, apparently see nothing, terminal closes. I'm still scouring the forums and the web in general about correctly installing and using the tools, and I'm sure the issue is mine. Been so long since I used Windows; can't get the programs to run from command line but I know it's just my needing to tweak things a bit.

    I will take a look at your other posts, and start putting things to work. And by the time I get all this done, I'll have a much better understanding of Android, which is what I'm after anyway.

    Thanks again for all your help. I'll post more information as I get it.
  6. Neofyte

    Neofyte Member

    BTW, I'm clicking "thanks", not showing that I have, so I'll see if I have some add-on conflict here. But again, thanks!
  7. teddyearp

    teddyearp A guide with guides Guide

    Yes, trying to run adb or fastboot by just clicking the icon will do nothing as they are command line programs that require additional commands to 'do their thing'.

    So that said, you can either open a command prompt on your windows box and try the command I gave above, or if you are more familiar with Linux, I have the linux versions of adb and fastboot in the file named "Linux_Nexus_Root.zip" in my Samsung file collection. There's more stuff in that file, but it contains adb and fastboot, albiet they are named 'adb-linux' and 'fastboot-linux'. So just change the name(s), make sure they're in your path and terminal window there you go.

    good luck

    p.s. I can see you're hitting the thanks button, thanks.
    Neofyte likes this.
  8. Neofyte

    Neofyte Member

    Again, thanks so much. I'll grab those files and try them out on the desktop. It's Debian, so no worries there . I am rebuilding a 64-bit system, so the box I am using right now is 32-bit Debian Wheezy. Do you know offhand if this will be a conflict? I'd think it would only be an issue if I were building a kernel from scratch or building a mod from source, but again, just learning the tao of android.
  9. Neofyte

    Neofyte Member

    Just re-read your reply, and what I didn't mention is that I've got adb and fastboot working fine on the windows box, but adb isn't doing anything because the phone isn't in debug mode, and fastboot is working, but the documentation I've found on fastboot seems to be more a summary.

    I think I'm at the point where I need to find out if I can do anything with usb debugging turned off on the phone. If yes, how. I'm reading as much documentation as I can find on fastboot, and I have both the recovery and boot images for the flex in the tools folder. I'm looking to see if fastboot has a man page anywhere.

    I can look at fastboot commands and arguments and they all makes sense, but nothing tells me if this one will save the phone while that one will brick it forever.
  10. teddyearp

    teddyearp A guide with guides Guide

    Hmmm, yes. I don't think you can do much with adb with adb debugging mode turned off. Side note, that is why I always turn it on first on a new phone.

    I am not sure if the same command will work with fast boot, but you can tgry it:
    Code (Text):
    1.  fastboot reboot recovery
    good luck
    Neofyte likes this.
  11. Neofyte

    Neofyte Member

    Thanks, I'll give that a try.

    I think my two biggest problems at the moment are adb isn't turned on in the phone, and fastboot oem unlock has no effect, so no adb, still locked. That of course doesn't let me flash recovery, boot, anything to the phone. I'm sure I'm not the first person to go through this, so somewhere there's a solution (other than sending it to Pantech- I'd rather spend months looking for a solution or work around than do that). Being a fairly new phone, there's just not a lot of information about it. I have the recovery and boot images, be nice to find a factory system image. I'd eventually like to put a custom ROM and Debian side by side, but gotta fix it first.

    Just a bit more info from early this morning:

    Phone in fastboot, fastboot gives me the phone ID, no problem. Tried fastboot oem unlock again, no go. Tried flashing recovery and boot, both return a failure, not support(ed) error. I figure, based on reading I'm doing, that it's 'cause it's still locked. I keep hoping there's a post somewhere that has a work around for either turning adb on or unlocking the bootloader in a situation like this.
  12. My Pantech Flex is doing same thing boots up freezes at logo. I too can only get to the other mode not recovery. I know this is a year later but was there ever a fix for this??
Loading...

Share This Page