PC Companion wont detect my xperia playSupport


Last Updated:

  1. fryedace

    fryedace New Member

    when i try to update my Xperia Play, i follow the steps in PC Companion and when it tells me to connect my phone, it dings (whatever USB connection sound is) and starts detection mode, then after abut 30 seconds it goes to finish and says "PC Companion must be updated". i have the latest version. i downloaded and reinstalled minutes ago. i cannot seem to get PC Companion to detect my phone, please help.

    i have uninstalled/re-installed, unplugged/re-plugged, closed/re-opened and more and at my wits end. Oh yeah, my computer seems to recognize my phone just fine. if i hit "turn on USB storage" on the phone when plugged in, i have access to my files just fine. (by the way, i do not hit this button while trying to get it to connect with PC Companion, although i did after multiple failed attempts in a last ditch effort, . . . didn't help.

    Advertisement
  2. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    Sorry for the late response but one question. In what USB mode is your phone?
  3. paxchristos

    paxchristos Well-Known Member

    Better question, which version of the play do you have? If you have the Verizon version, PC companion is kinda pointless.
  4. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    xsylus and paxchristos like this.
  5. fryedace

    fryedace New Member

    i have tried it in both USB modes and i use C Spire not Verizon. as for the last recommendation, the Sony update service, that is exactly what i have been trying to get to work.
  6. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Are you sure, in the above posts you mentioned PC Companion which is a different program?

Share This Page