PC won't recognize phoneSupport


Last Updated:

  1. Brian706

    Brian706 Moderator Moderator

    So at home on my laptop, running Windows 7 64-bit, plugging in my n5 put the phone in usb storage mode and also I was able to install the adb driver.

    On my work pc (same os) the phone does not automatically install the drivers for usb storage and also will not let me install the adb driver. It does charge, however, and when usb debugging is enabled, it shows up in device manager (just like at home) but will not let me update the driver.

    Using the same OEM cable on both computers, nothing is blocked at work. I have rooted several devices here, and just tested my 3vo in case something changed, and it still works in mass storage mode.

    Any ideas on why, or how to get the pc to recognize it? Any other device I plug in is fine, but my n5 just won't install the drivers on this pc.

    Have restarted pc and phone and tried the rear usb ports as well. I need your braaaaains!!!!

    Advertisement
  2. jhawkkw

    jhawkkw Chinchillin' Moderator

    Ugh, sometimes the drivers are absolutely maddening. Is there any reaction in the device manager at work when you plug it in? Does your computer account at work have the necessary privlidges to manually install drivers?
  3. Brian706

    Brian706 Moderator Moderator

    Only if usb debugging is enabled. It shows up as Nexus 5 with a yellow question mark. Same thing as at home, but from there I installed the adb driver and here it will not work. If usb debugging is not enabled, nothing happens in device manager.

    Also windows doesn't make the little sound when you plug and unplug a device. It's not recognizing it at all.

    It's odd because when I try to install the driver it says "Windows could not find the driver software for your device". Even though I downloaded it and pointed right to it...

    Not doing anything different than I did with my laptop.
  4. jhawkkw

    jhawkkw Chinchillin' Moderator

    I don't know about the 3EVO, but wasn't that a device that still used USB host mode since it was pre ICS? With these newer devices, it needs/tries to install the MTP driver which I hate with a passion. So since that's not installing and the adb driver isn't installing either, it sounds like it's preventing you from installing a driver that isn't native to windows. Not sure why though.
  5. Brian706

    Brian706 Moderator Moderator

    Hmm. Weird. I have full admin rights on my work pc so I'm not sure what's up. :(
  6. jhawkkw

    jhawkkw Chinchillin' Moderator

    Only thing I can think of is that there's already some drivers conflicting with it. There's this program that lets you examine all the drivers you have ever installed on that computer, but I'm brain farting on the name. If you use that, or a similar tool, I would use it to uninstall any driver android related and try to start fresh with your driver installs.
    Brian706 likes this.
  7. Brian706

    Brian706 Moderator Moderator

    Okay, so I'm having the same problem at home on my laptop now too.

    The only conclusion I can come to is somehow rooting messed that up which really doesn't seem right...

    It connected at home before root, never tried after until now... But yeah, all I did was flash supersu. Not sure what to do now... Obviously (especially without removable storage) I need to be able to connect to the pc...

    Any ideas? Jhawk, ask your chinchilla for some advice. :)
  8. Brian706

    Brian706 Moderator Moderator

    Also, out of curiosity, what's the procedure when flashing rooms for a device with no removable storage? This is my first one.

    Do you have to backup the entire storage contents every time so you can wipe and flash? Then restore everything?

    Can't picture how this will work...
  9. jhawkkw

    jhawkkw Chinchillin' Moderator

    My best piece of advice is to use this program to uninstall every driver related android and then install the CM universal drivers again.

    The custom recovery is designed to skip over the internal sd card portion when you wipe, thus leaving it intact. Just don't use the format internal memory option and you should be fine. Nothing different than usual. Factory reset, wipe cache, wipe dalvik, flash rom, flash gapps, reboot.
    Brian706 likes this.
  10. Brian706

    Brian706 Moderator Moderator

    Still no go... I don't get it.. Drivers installed just fine, rooted, now can't connect to any pc...
  11. Hook

    Hook Ever since DU... ;-) VIP Member

    I went round and round with this on my Win 7 box and the Nexus 5, which was weird because I had no problems with my Nexus 4 (don't have anymore) or my Nexus 7 (still worked fine). I kept installing and uninstalling adb drivers and they seemed to work, but I couldn't get MTP. Then I noticed that Windows was offering me a "composite USB" driver. I said, what the hell. I installed the driver. It still didn't work, but it finally gave me a Nexus 5 device in Device Manager with a yellow triangle. I then did update driver and it *finally* offered an MTP driver. Now it all works fine. :rolleyes:
  12. Brian706

    Brian706 Moderator Moderator

    What's odd is it worked initially, then after rooting it stopped. What's more odd is that the drivers install while in recovery but same issues when I reboot the phone. I think I'm going to reset the phone, see if it works, then try rooting again.


    Edit:

    I did a factory reset in recovery, and then booted up. Sure enough the drivers installed correctly on their own upon plugging the phone in. Restoring my backup now, will see if the problem comes back or if it's resolved.


    Edit: So the problem returned after restoring my backup... I really don't want to start all over, not sure how I'm going to handle this yet.
  13. Brian706

    Brian706 Moderator Moderator

    Update:

    Just flashed Cataclysm rom (oddly not named kataclysm...?) and my USB storage is working.

    It's a good rom too. It's basically the same as stock but with extra settings/options and tweaks.

    To name a couple you can customize your quick settings panels and it has the expandable volume controls and reboot menu added into the long press of the power button.

    Check it out if you're looking for some extra functionality.
    Hook and jhawkkw like this.

Share This Page