Penn State Student EmailSupport


Last Updated:

  1. TMH478

    TMH478 Member This Topic's Starter

    Joined:
    Nov 16, 2009
    Messages:
    9
    Likes Received:
    0
    Hello fellow Nittany Lions! Have you gotten your psu.edu email to work on your device? If so, can you please be so kind to provide instruction? Thanks!!
     

    Advertisement
  2. Backnblack

    Backnblack Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    126
    Likes Received:
    0
    GO BLUE

    Sorry...Had to say it.

    Wish ya luck...
     
  3. TMH478

    TMH478 Member This Topic's Starter

    Joined:
    Nov 16, 2009
    Messages:
    9
    Likes Received:
    0
    Ha! As in GO BLUE AND WHITE???

    Thanks!
     
  4. ckc5022

    ckc5022 New Member

    Joined:
    Dec 17, 2009
    Messages:
    1
    Likes Received:
    0
    what are you using? I just set up my droid yesterday. The first step I think you have to do is change something over on your webmail account, I think it has to be set up for IMAP, search ITS for help.
     
  5. photoeditor

    photoeditor Well-Known Member

    Joined:
    Nov 18, 2009
    Messages:
    62
    Likes Received:
    2
    At my school, if you just use the automatic set-up on IMAP, it won't work. You actually have to go in and insert the name of the server in front of the school's name for the incoming settings and then also manually replicate the name of the SMTP server for outgoing. I'm still trying to reconcile the fact that the phone and the server are in disagreement over what Sent mail folder to use, with the result that messages sent off the phone don't show up on the server (although sent messages from the server do show up on the phone). So for example, the phone's auto set up just enters giantstateu.edu, whereas what you really want is mailservername.giantstateu.edu

    K-9 mail configures the mail properly and automatically without fuss, but seems to go heavy on the battery.

    Mobile me configured just fine automatically on the default mailer.
     
  6. veracious

    veracious New Member

    Joined:
    Jan 18, 2010
    Messages:
    2
    Likes Received:
    3
    Try this..


    Droid Mail Settings
    Incoming server settings:

    username: "abc1234" - Penn state userid without quotes
    password: "password - Penn state password without quotes
    POP3 Server: email.psu.edu
    Port: 995
    Security Type: SSL
    Delete email from server: Never

    Outgoing server settings:

    SMTP Server: authsmtp.psu.edu
    Port: 25
    Security Type: None
    UNCHECK Require sign-in.

    Let me know if this works for you.
     
  7. messenger13

    messenger13 Well-Known Member

    Joined:
    Dec 8, 2009
    Messages:
    3,133
    Likes Received:
    381
    Lessee . . .

    Penn State won the Capitol Bowl
    Ohio State won the Rose Bowl
    Wisconsin won the Champs Sports Bowl
    Iowa won the Orange Bowl

    Heck! ... even MSU won the Alamo Bowl. :D

    What in the world did the pathetic Wolverines do last year but lose, lose, and lose some more? :confused: (5 & 7 in case you forgot.) ;)

    "Blue" better stick to playing all the other crappy Michigan teams. But they best stay out of East Lansing. :D Central Michigan would probably hand it to em too. :D
     
  8. icstars989

    icstars989 Well-Known Member

    Joined:
    Nov 5, 2009
    Messages:
    300
    Likes Received:
    7
    Hawkeye here, and I never get tired of reading that!
     
  9. Heide264

    Heide264 Active Member

    Joined:
    Dec 10, 2009
    Messages:
    33
    Likes Received:
    1
    I got mine to work. Play with the password settings mostly. I found some help on ITS. If you still don't have it working let me know and I will mark down my exact settings for you =)
     
  10. TMH478

    TMH478 Member This Topic's Starter

    Joined:
    Nov 16, 2009
    Messages:
    9
    Likes Received:
    0
    It worked! Thank you so much!!

     
  11. TMH478

    TMH478 Member This Topic's Starter

    Joined:
    Nov 16, 2009
    Messages:
    9
    Likes Received:
    0
    This thread has proven to be quite entertaining! Thank you all!
     
  12. bexy11

    bexy11 New Member

    Joined:
    Jul 25, 2010
    Messages:
    1
    Likes Received:
    0

    Thanks a lot, this worked for me on my captivate.
     
  13. Jtyoung

    Jtyoung Active Member

    Joined:
    Apr 29, 2010
    Messages:
    42
    Likes Received:
    6
    This is NOT working for me...what am I doing wrong?
     
  14. droiddoesPSU

    droiddoesPSU Member

    Joined:
    Aug 25, 2010
    Messages:
    5
    Likes Received:
    0
    That worked for me but FYI- it is a "POP3" account type when it asks.

    Works perfectly for me, thank you so much!



    We are...!

    ("`-''-/").___..--''"`-._

    `(6_ 6 ) `-. ( ).`-.__.`)

    (_Y_.)' ._ ) `._ `. ``-..-'

    _..`--'_..-_/ /--'_.' ,'

    (il),-'' (li),' ((!.-'
     
  15. blankppr

    blankppr New Member

    Joined:
    Aug 26, 2010
    Messages:
    1
    Likes Received:
    0
    Yeah I actually was doing this just now and was able to use POP settings. It said that it didn't work when I tried to press next but I just ended up pressing continue and then finish. Went to open my mail to try to change it to IMAP but the emails were there.

    This is the information I used:

    [Incoming]
    Email address: abc123@psu.edu
    Username: abc123
    Password: xxxxx
    Pop Server: email.psu.edu
    Security type: SSL
    Server Port: 995

    [Outgoing]
    Username: abc123
    Password: xxxx
    SMTP server: authsmtp.psu.edu
    Security type: none
    Server Port: 25

    It didn't load all my emails - just the 10 most recent ones. I'm not sure if that's related or just happens. But POP did work for me. Though I already sent an IMAP request just a few minutes before I realized it worked.
     
  16. droiddoesPSU

    droiddoesPSU Member

    Joined:
    Aug 25, 2010
    Messages:
    5
    Likes Received:
    0
    Stopped working for me (worked for about a day then I got kicked off or something)

    I think Penn State doesn't want our emails being forwarded is all...
     
  17. AutoShadow

    AutoShadow Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    68
    Likes Received:
    0
    I got tired of dealing with the email settings, so I just made a new gmail account "abc123@gmail.com" and have that account grab the emails from my psu account, which seems to work more seamlessly than having my phone grab the emails directly from the psu mail server. After I set up the gmail account, I added that gmail account to my Droid and, booooom, I get all my psu email now.

    WE ARE...
     
  18. that guy

    that guy Active Member

    Joined:
    Aug 29, 2010
    Messages:
    43
    Likes Received:
    1
    you mean blue and gold right? haha WVU
     
  19. Soultics

    Soultics Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    164
    Likes Received:
    12
    My school email uses the GoogleApps stuff, so I can just add it through the Gmail app, works nicely.
     
  20. veracious

    veracious New Member

    Joined:
    Jan 18, 2010
    Messages:
    2
    Likes Received:
    3
    Look at my post above, I changed the outgoing server on it to authsmtp.psu.edu instead of smtp.psu.edu. try that out
     
  21. jdailey1981

    jdailey1981 Well-Known Member

    Joined:
    Feb 5, 2010
    Messages:
    386
    Likes Received:
    12
    Go Buckeyes! :D Tressell owns that state up north. At least Buckeyes are BCS bound. You can't spell Buckeyes without BCS! I did enjoy watching PSU and Alabama. Bama fans love JoePa.
     
  22. droiddoesPSU

    droiddoesPSU Member

    Joined:
    Aug 25, 2010
    Messages:
    5
    Likes Received:
    0

    Well I've tried once again.

    My outgoing settings are
    Server: authsmtp.psu.edu
    Port: 25
    Security type: none
    CHECKED require signin

    and it is currently working.

    I also applied for the IMAP thing.

    It is getting my emails but while I've been playing with settings alerts saying there were connect errors (mainly when I UNCHECKED require signin) and username/password incorrect messages but nothing seemed to be wrong.

    I will try out the IMAP thing and see if it works more regularly and whatnot.


    PS- my dad's Blackberry works amazingly with the psu.edu mail except (and I've noticed this so far as well) that the junk mail flows right into the inbox on the phone but not on a computer. Any thoughts on how to fix it or should we just deal?




    I have anothing question however: someone mentioned that their school used GoogleApps and so does mine. However I never could get the mail on in through an app (I'd use the web browser). It gave us emails @scasd.org and the website we go to is google.scasd.org/mail so it isn't directly Google.
    I adore using Gmail on the Droid and was wondering if that person had any idea how to get it working.
     
  23. droiddoesPSU

    droiddoesPSU Member

    Joined:
    Aug 25, 2010
    Messages:
    5
    Likes Received:
    0
    Well I did the IMAP method and its working :)


    As for the school one- I've been suggested just to forward the emails to my Gmail account but the school blocks other websites. I log onto it all the time at school for the GoogleDocs and don't want to deal with the weirdness that happens when you forward mail and check through both accounts.
     
  24. mla5117

    mla5117 New Member

    Joined:
    Dec 6, 2011
    Messages:
    3
    Likes Received:
    0
    This should work for android systems and DROID 3:

    First go through IMAP Service Overview | ITS Knowledge Base and sign up for IMAP this will take about 24 hours to actually start working.

    The next day you will do the following with your email account settings:
    General:
    Account name: Psu
    Real name: doesnt matter
    Email address: abc123

    Incoming:
    Change from POP to IMAP mail server
    Server: mail.psu.edu
    username: abc123
    Password: xxxx
    --->Advanced settings
    Port: 993
    Check use secure connection
    use secure password(TLS): ALWAYS
    check verify certificate

    outgoing:
    SMPT server: authsmtp.psu.edu
    username: anc123
    password:xxxx
    ---->advanced settings
    port: 465
    check use secure connection
    use secure passwrd(TLS): ALWAYS
    Authentication: NONE
    check verify certificate


    hope this helps!
     
  25. randylauj

    randylauj New Member

    Joined:
    Sep 22, 2011
    Messages:
    3
    Likes Received:
    0

    It works :DDDD
     

Share This Page

Loading...