1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

phantom key presses


  1. dhabell

    dhabell Well-Known Member

    I have noticed that while entering the text in a text message my phone often bugs out. It acts like someone is pressing the menu hard key very rapidly. At first I thought maybe my case was causing some kind of false positive or maybe my palms were inadvertently pressing the button. I have since ruled both out but the problem still remains. The problem is persistent across several different rom flashings.

    any ideas?

    Advertisement
  2. Rally 517

    Rally 517 Well-Known Member

    factoryreset
  3. Rally 517

    Rally 517 Well-Known Member

    or Odin back fto stock. thenflash
  4. dhabell

    dhabell Well-Known Member

    im on stock now. and I also factory reset before every flash.

    any other ideas?
  5. Codegerm

    Codegerm Well-Known Member

    I haven't run across that happening. Which keyboard are you using?

    Codegerm
  6. SelfElevated2

    SelfElevated2 Well-Known Member

    Happens on mine too.. It was doing it straight out of the box.. But i figured I'd just deal with it.. I'm using the Swype on stock. Happens a few times a day
  7. Codegerm

    Codegerm Well-Known Member


    Okay something to work with. I am not using the swipe keyboard. I am using the Samsung keypad. will have to try that out and see if I run across it. I am on stock with AGAT 054 kernel.

    Codegerm
  8. dhabell

    dhabell Well-Known Member

    It also happens while not entering text at all. Im using SwiftKey, but the keyboard is not the problem. The problem is the info hard key. It is the physical button on the far left next to the home button.
  9. Codegerm

    Codegerm Well-Known Member


    okay you mean the menu key. hmm I haven't had any problems from that. The only issue I have run into was doing an app search in the play store. If I entered the text via voice recognition, every once in a while it would freak out. I noticed that it was also the only thing I do that i have to hit the mic by the search box and not the one on the keyboard. so as a result i just type for that search box.

    Codegerm
  10. LEVERage

    LEVERage Well-Known Member

    My phone started doing the samething a few days after I got it. I turned off haptic feedback and haven't done it since. Try that and see what happens, might fix your problem as well.
    dhabell likes this.
  11. dhabell

    dhabell Well-Known Member

    I will test turning Haptic off and report back in 24 hours.

    btw - I found the option to turn it off in the Swiftkey settings in case anyone is wondering where it is...

    update... it didnt work
  12. SelfElevated2

    SelfElevated2 Well-Known Member

    Same here... Stock with agat 054...
  13. Codegerm

    Codegerm Well-Known Member

    When you rooted your phone, were you on FG31 (as it cam out of the box) or did you root after the FH29 update?

    I did both rooted as soon as i got it, then unrooted, got the OTA update then rooted again.

    Codegerm
  14. Wintafr3sh

    Wintafr3sh New Member

    this happens to me aswell its been this way ever since i bought the phone fresh out the box stock & even after rooting my phone it still happens not more or less just a few times here & there but what i have noticed is that it happens to me only when my phone loses or is searching for a 4g/3g signal after acquiring a steady 4g/3g signal it stops weird huh anyone else notice this??...anyways hopefully this is fixed on a future update
  15. dhabell

    dhabell Well-Known Member

    turning Haptic feedback off in Swiftkey fixed the problem for me!

    even if you dont use Swiftkey (you should, best kb in my opinion) try turning Haptic off on whatever keyboard youre using.

    UPDATE... it didnt work for me after all
  16. Codegerm

    Codegerm Well-Known Member

    Cool, I'm glad it worked. That is one odd bug.
  17. SelfElevated2

    SelfElevated2 Well-Known Member

    Rooted after the update..
  18. kevindroid

    kevindroid Well-Known Member

    im using the jellybean keyboard with no problems
  19. TechBravo

    TechBravo New Member

    Seems that when the signal strength is low the menu button falses. The radio commands more power when signal is low and this causes an undervoltage condition which causes this anomaly. 50/50 whether its hardware or software. I work on equipment with similar technology and it is truly amazing how a software engineer can "fix" hardware issues by tweaking the firmware. If the power supply and distribution systems in the samsung device is not capable of providing the current demanded then you either beef up the power supply systems or require less power for other systems.

    I am in the process of working with a sprint tech and developer to find solutions to this issue. If we come up with anything I will be glad to share.
  20. TechBravo

    TechBravo New Member

    BTW: I am trying the idea of disabling haptic feedback. That is a great and logical idea!
  21. SelfElevated2

    SelfElevated2 Well-Known Member

    It has nothing to do with signal strength. That is pretty crazy to even think that. In no way is the phantom key presses related to signal.

    However I have had them since I've had the phone. Before root and after. And on all custom roms. I'm thinking it's a bug in our phones bc so many of us are having the problem.

    It's not haptic feed back either bc it will still do it with it turned off, you just can't feel it. But you'll still see keyboard settings pop up like you pressed menu.maybe something we just have to deal with
  22. Codegerm

    Codegerm Well-Known Member


    I don't have the problem at all. I do see things like poor signal strength being able to cause problems because when in a poor signal area your phone will increase its transmitter output power (and when it is in a good area your phone will turn output power down). I will say my house is a poor signal area, and other than not being able to make a phone call etc from inside, I have no problems (to use my phone inside I connect to WiFi). I do turn on airplane mode to keep from wasting battery while inside now, but sometime have left the cellular transmitters on too.


    Codegerm
  23. SelfElevated2

    SelfElevated2 Well-Known Member

    Yeah I feel you...

    But you do understand what the issue is right? Let's say for instance your looking at the home screens. And out of nowhere it looks like you just pushed the menu button 6 times because the settings menu pops up then down up then down ect.. But you didn't do it.

    Or maybe you doing something with the keyboard open, texting,posting something ect... And your keyboard menu pops up then down a few times as if you hit the menu button multiple times..

    That problem has nothing to do with signal strength. It's ridiculous to think it does. I mean really think about it. Even thinking about what you just said . But how could that even represent the that. Takes more power to keep pressing home buttons by itself. And that's without even demonstrating that a simple voltage fluctuation could make the phone actuate the menu button several times.

    I don't know what the issue is but I know many of us are having it.(not really a big issue though, just annoying).. But I can guarantee you that it is not related to our signal strength!
  24. Codegerm

    Codegerm Well-Known Member

    Well one easy way to test is to operate the phone in airplane mode and turn WiFi on to connect to the internet, and play with it some putting it through it paces. I also know some phones have different chips in them (supply at manufacturing etc) which could cause problems (EMMC brick bug for instance, which I am glad to say I don't have that chip). I do know that if I had that as an issue right from stock, I would take it back.

    Codegerm
  25. systemofadown

    systemofadown Well-Known Member

    My S2 just started this strange behavior.. Thought I had saw a post about it on here so I came to share also. Stock phone - never rooted, FI22 updated, purchased new at local boost store. while using yahoo messenger the menu button ghost presses around 2 - 6 times. As stated above Annoying.... Powered off, then restarted going to keep an eye on it..

Share This Page