Phone Call earbud issueSupport


  1. daveradiofm

    daveradiofm Member

    Okay my issue is a semblance of several different posts on the internet. I'm trying to figure out a solution that doesn't require me to buy a BT headset or a microphone headset since I've already a bunch of earbuds around the house. What I'm trying to do is figure out a way to make a phone call using either the stock headphones or my sony earbuds.

    I can't seem to hear anybody or speak to anybody with my headphones plugged in. Can't even hear the phone ring out. It's as if the heaphones cut off during a call. Is there a configuration setting that I need to change, or can I download an app that will enable me to use the internal mic with my headphones plugged in.

    I'm running the CM7 Gingerbread rom.

    Advertisement
    :
  2. kevinrubio

    kevinrubio Well-Known Member

    Hmm are the headphones that came with the phone new or old? and the sony earphones will work if it fits in, i am currently using something i brought for one of my gaming systems, and i didnt have to enable anything so not sure
  3. daveradiofm

    daveradiofm Member

    Phone is new and the stock headphones are new. The Sony headphones fit via 2.5mm adaptor. Same results with both. Do you think the CM7 Mod is a factor?
  4. kevinrubio

    kevinrubio Well-Known Member

    no CM7 has nothing to do with the problem your having.
    so your saying the sony's does not fit since the ascends is 3.5mm. I need more information from you
  5. daveradiofm

    daveradiofm Member

    The sony headphones are standard audio type headphones with a 3.5mm tip. I bought a 2.5mm adaptor for it. This rig works perfectly for listening to music on the go as well as hearing alerts. Just a no go with phone calls. I can't speak to anyone while the buds are plugged in nor can I hear from them.

    The same goes with stock headphones that I got when I bought the Ascend. (These do have a 3 ring 2.5mm tip) I can hear music and alerts and even the customized ringtone when I get a call in...just nothing when I'm actual in the call.
  6. kevinrubio

    kevinrubio Well-Known Member

    wow i have never had this problem before, and i'm running CM7 too. I have the stock ascend headset and can talk to people with them easily, try rebooting with them plugged in, and then boot up with them again plugged in too. It will kinda trick the system into doing something. If that doesnt work then maybe it is CM7, may i ask what build do you have. Also did this ever happen before?
  7. daveradiofm

    daveradiofm Member

    Never tried it on my stock MetroPCS froyo. So, I couldn't tell. I could boot with just the headphones plugged in, but I am having sticky issues with booting the CM7 rom. It seems to hang from time to time on the issue Android boot screen. When I do get it booted, it works amazingly well.

    Except for the headphone and calls issue....

    I've never been able to get it to work with CM7. It's weird. I think it's a software issue sending the signal to cut the headphones in call. Music and everything else works well on the headphones. I have no problems running napster or Google stock media player app.

    The build I'm using is PlayfulGod's 06242011 build.
  8. kevinrubio

    kevinrubio Well-Known Member

    Okay here is my experience! I just flashed the same exact ROM as you, PG 06242011 build CM7.
    And called my brother with my headphones plugged in, i heard the ringing of the call, and when he picked up, i could hear him perfectly, and talk to him with the mic in the headphones.
    So lets just hope its not a hardware issue, on your part.
    So lets try this, maybe it is the ROM.
    backup everything on your SD to the PC.
    Then backup your ROM either in CWM or ROM manager.
    After all that is done, factory reset..
    reboot and test it. If it doesnt work, maybe flash a ROM i had before i flashed the ROM, it was BobZhome 07082011, i loved it. and im going to flash back once i am done with you
  9. daveradiofm

    daveradiofm Member

    Unfortunately, I'm at work and I can't duck out to test since my headphones are in my car.

    I have a theory. I was checking my call settings based on the info you gave me, and I noticed 3rd from bottom that there is a setting for voice privacy. It was checked on my phone, and I unchecked it. Do you think that might possibly be the culprit.

    Did you have voice privacy checked on your phone?
  10. kevinrubio

    kevinrubio Well-Known Member

    Mine is unchecked, thats it!
    voice privacy should be always unchecked, i tryed to check it and call my bro again and i did not hear no rings and no voice although he picked up and said something. Well looks like we found the solution. tell me if it works for you
  11. daveradiofm

    daveradiofm Member

    Okay...so I unchecked it and went to my car and tested it on the car stereo via the line input. (Left my headphones at home) I could only hear the phone alerts from when I disconnected my phone only from the car speakers. I may need to give the car stereo more juice though now that I think of it. A combination of the Texas heat and the a quick lunch has a tendency to rush things.

    I'm still not going to give up as I have a couple of other aces up my sleeve that I'm going to try. First, when I do get home...I will do a test with my headphones as well as the stock headphones. If that doesn't work, I will flash to my MetroPCS stock rom and go from there. If the issue persists, it's probably a hardware issue.

    I'll still keep at it tonight, and I will give you an update.
  12. kevinrubio

    kevinrubio Well-Known Member

    alright, try the stock headset first with your phone unchecked voice privacy.
    And feel free to email me @ krubio98@hotmail.com i'll reply soon as possible
  13. nuttmeg

    nuttmeg Well-Known Member

    there has been a problem with headphone and cm7, you could try sound route switcher or get a good pair of BT headphonesthe lets you listen to music and speak out of them also for voice calls...:)
  14. kevinrubio

    kevinrubio Well-Known Member

    not for BobZhome CM7!
  15. nuttmeg

    nuttmeg Well-Known Member

  16. kevinrubio

    kevinrubio Well-Known Member

  17. tronics2011

    tronics2011 New Member

    Hi all
    I am using the cm 7 build & I have the same issue ..... any cm7 I use I get that same problem .... cm6 seems to work ok with my stock headphones
  18. kevinrubio

    kevinrubio Well-Known Member

    go to call settings, in meu-> settings-> call settings-> (3rd from the bottom) uncheck that box
  19. tronics2011

    tronics2011 New Member

    Will Try It & Let U know what Happens
  20. kevinrubio

    kevinrubio Well-Known Member

  21. tronics2011

    tronics2011 New Member

    No it did not ... I found out that if u turn off the phone & plug in the headset ... turn on the phone .... it will work ... as long as u don't plug it out.If u do It stops work just with phone calls.
    KOLIO likes this.
  22. daveradiofm

    daveradiofm Member

    See...I tried that, and it didn't work for me, but one of the things I tried was calling someone with the headset plugged in. No sound through the headphones, but when I would mute and unmute, I would hear the caller through the headphones, but they wouldn't be able to hear me.

    I'm going to try your method and actually shut down my phone and restart it. I will try it with my voicemail and see what the results are.

    EDIT: Tried it, and all it did was go into speaker mode with the headphones plugged in. I was able to mute and unmute leaving myself 4 google voice messages. The only successful test was the speakerphone method.
  23. daveradiofm

    daveradiofm Member

    I'm rehashing this a little from here (http://androidforums.com/huawei-ascend/374637-phone-call-earbud-issue.html), but I seem to find both of these resulting from issues with the default phone.apk used on the CM7 Gingerbread mod.

    I'm currently using the latest mod from BobZ for 070811 which is amazing. It's fast...usb, GPS, SMS, MMS, camera, video, and Market all work quiet well. :D

    The only 2 issues I have seemed to both be related with the actual "phone" side of the phone.

    Issue #1
    Headphones: The standard headphone with 2.5 jack and even the 3.5 jack using the 2.5 adaptor works quite well when I'm listening to the media player, napster, youtube, etc. They don't seem to work when placing calls. I've had to do the mute/unmute just to hear the caller, but they can't hear me at all. Voice Dialer won't even respond when my headphones plug in. It's as is the mic gets muted once standard headphones are plugged in. This happens when hot plugging, rebooting, and just plain power off and booting with headphones plugged in. (This feature did work with the MetroPCS stock rom, so I know it's not a hardware issue.)

    Issue #2
    Custom Ringtones: Regardless of what custom ringtone is set per contact, the default ringtone always rings. I did a Fix Permission and the Default Profile's ringtone started to ring. Removed the Dialer from the Profiles manage apps, and it went back to the default ringtone. (This had also worked with MetroPCS stock rom as well.)


    I was wanting to try an idea out. I think both issues are related to the CM7 Phone.apk. Would it be possible to use another phone.apk from a generic Gingerbread rom to replace it.

    I had attempted, just for grins, to use Titanium to back up the Dialer and the Dialer Storage and then restore the apps+data from my MetroPCS rom. The install failed, and I think it's largely due to the fact that force stopping is hard to do. Would I need to boot CWM to restore the stock phone.apk for the CM phone.apk? I did uninstall the dialer and dialer storage app, and I attempted a backup restore, but it took several minutes and still hadn't completed as if it had gotten frozen during the process. I stopped it, but I'm wondering if I should have waited longer.

    Am I barking up the wrong tree, or would this seem like a probable idea? The MetroPCS stock image is for Froyo.
  24. intrdrgn

    intrdrgn Well-Known Member

    this did the job for me as well, both builds 0624 & 0708 i have this issue. but for me i have Bluetooth sunglasses (paid $20.00 on Ebay) works like a charm on both builds...
  25. Taterhater88er

    Taterhater88er Well-Known Member

    Interesting! I was having the exact same problem.

    To add to it, I also had a strange occurrence in that sometimes if I hit the "speaker" button while in call, I could hear what was coming through. I think that ultimately, this was just a strange bug in CM7's default settings. Glad to see you guys worked it out though. Now I can fix mine too. :D
Loading...

Share This Page