Phone cannot add events to Exchange calendarSupport


Last Updated:

  1. sweetthunder

    sweetthunder New Member This Topic's Starter

    Joined:
    Aug 28, 2010
    Messages:
    2
    Likes Received:
    0
    I'm having an issue with my Exchange calendar. I currently sync my calendar and email through Exchange. Events added to my outlook calendar via computer show up on my phone and work perfectly. But, when I add events to my phone calendar, my only available calendars are my google calendars and my PC Sync. I never use PC sync. It does not give me the option of adding events to my Exchange calendar.

    I had to reset my Exchange account after the Froyo update, and I thought that I had everything working properly. I don't add events to my outlook calendar through my phone very often, so it's likely that this has been an issue since Froyo. Has anyone else run into this problem or have any ideas how to fix it?
     

    Advertisement
  2. Tv77

    Tv77 New Member

    Joined:
    Jul 7, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same problem. It used to work until I started getting the client/server error. I cleared my calendar data, which resolved the client/server error, but now I can't add events on my EVO and have them show up in Outlook/Exchange.

    Did you end up finding a fix?

    Thanks.
     
  3. josephlucas

    josephlucas New Member

    Joined:
    Jul 13, 2010
    Messages:
    3
    Likes Received:
    0
    I too am having the exact same problem with a client's EVO running 2.2. Worked fine until it started getting the client/server error, cleared the calendar data as was suggested on a forum to resolve that issue. Now the only calendar that shows up to add entries to is the PC Sync calendar. Exchange is still syncing just fine and events that are added to exchange through Outlook on the PC propogate to the phone properly, but I can't add any on the phone to the Exchange calendar. I'll let you know if I can find a fix for this. May end up having to do a factory reset...
     
  4. Wadester

    Wadester Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    249
    Likes Received:
    21
    In the Calendar app, click Menu, More, then Calendars. Which ones do you have selected? I have all but Exchange unchecked.

    I, too, started receiving a sync error on the Calendar before. Deleting and re-adding the account seemed to fix that (took a couple of times).
     
  5. EvoDavid

    EvoDavid New Member

    Joined:
    Nov 4, 2010
    Messages:
    1
    Likes Received:
    0
    Curioser and curioser:
    - When I do this in the calendar app, my Exchange calendar is not even listed. I can't check or uncheck it, because it's not there ... all the others are, but not Exchange.
    - Exchange events do show up in the calendar, and when I tap on one to see the details, at the bottom it does show that it is from the Exchange calendar.
    - I use the Android Agenda widget on my home page. When I click Settings, Calendars, Choose Calendars there, it shows the Exchange calendar just fine (and the widget shows Exchange events with all the others). But if I click '+' to add an event, it doesn't have Exchange as an option under 'Calendar'
    - Settings, Accounts & Sync shows the Exchange ActiveSync account, but the sync indicator is greyed out, even though it's set to sync every 15 minutes.

    Any ideas? I *hate* creating events in my Gmail account, because of the way it sends out invites. Anything personal during the day, I have to have also on my work account to block out the time. But instead of just sending the invite with the title like Exchange does, Gmail adds the whole "Invitation: (subject) @ date time (from)" which really clutters up my work calendar and makes it painful. Instead of being able to look at the calendar and see what the events are, all I see are a bunch of truncated "Invitation: ..." etc. Useless.
     
  6. Wadester

    Wadester Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    249
    Likes Received:
    21
    If Exchange isn't showing up in the Calendar app's Calendars list, then it sounds like there was a partial account creation or deletion. I would delete the Exchange account on the phone, then re-create it -- making sure you have Mail, Calendar and Contacts selected to sync. I'd also set the Schedule to "As items arrive" i.e. using the Push technology.
     
  7. jrhodes

    jrhodes New Member

    Joined:
    Oct 27, 2010
    Messages:
    2
    Likes Received:
    0
    Hi. Look at this post. True, it requires some work to get things back to the way they were, but I have offered it up to many of my customers and it seems to work very well.
     
  8. Wadester

    Wadester Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    249
    Likes Received:
    21
    "To make ActiveSync (the service that connects the device to Hosted Exchange) happy, it needed to be the first account set up on the phone. The VERY FIRST. Which means, if you just took the phone out of the box, you would cancel the Google account setup prompt you get when activating the device, set up Exchange, and then go back and set up Google and all of your other accounts."

    Hmm... never heard of that one before, but I could see how that might help.
     
  9. JBO-FR

    JBO-FR New Member

    Joined:
    May 30, 2011
    Messages:
    1
    Likes Received:
    2
    Hi,
    This has worked for me on an HTC Legend (Froyo):
    -Delete Exchange account
    -Delete all agenda data
    -Re-add Exchange account
    If you use agenda widget, uninstall first and re install after creating exchange account.
    I am now able to add Exchange events from HTC agenda or from agenda widget.
     
    ballibeg and ocnbrze like this.
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    Joined:
    May 13, 2010
    Messages:
    23,596
    Likes Received:
    14,435
    Welcome to the forums!
    great bit of info. hopefully this will help others.
     
  11. ballibeg

    ballibeg New Member

    Joined:
    Jan 31, 2012
    Messages:
    1
    Likes Received:
    0
    Many thanks. Worked on my Desire and solveda problem that's been really annoying.

    Dave
     

Share This Page

Loading...