Phone contacts wont sync to gmail contactsSupport


  1. dudeman1996

    dudeman1996 Well-Known Member

    I have contacts in my phone that I want to sync to my GMail account, but when I try to sync them, they don't go from the phone to the GMail account, they go from the GMail account to the phone. I create a new contact on the phone called test (just an example) then sync and it gets deleted because that contact is not in the GMail contacts. I want to sync the contacts from my phone onto the GMail account but it doesn't seem to want to do this and it's really frustrating because I want them synced so I can have them backed up just in case. I'm a first time Android user, just got the phone about a week ago.

    Additional information:
    Phone model: LG GT540 Optimus
    Android 1.6
    LG Software Version: GT540-V10a-JUN-24-2010

    Advertisement
  2. Kostas

    Kostas Well-Known Member

    Be sure to set contact type to google and not phone or sim.That should work.Its the first option after entering the phone number.Post back to tell me what happened.Mine works just fine
  3. kingroach

    kingroach New Member

    I am having the same problem but with and HTC Hero running Froyo (FroydVillain 1.4.4). I know that if I set the option to 'Save to Gmail' not to Phone or SIM it would work (as it did in Eclair), however that option seems to have been omitted from this version.

    I've been searching the net now for ages looking for a solution and I'm positive it's a Froyo problem (other people using official Froyo installs are having the same problem).

    Anyone have any suggestions?
  4. dudeman1996

    dudeman1996 Well-Known Member

    Nope didn't work, when I sync the contacts it just deletes the contact I just made because it doesn't exist in the online contacts. :confused:

  5. Kostas

    Kostas Well-Known Member

    Are you sure you were creating a new contact and not trying to update an old one? I suppose it does sync from the net to the phone, right?
  6. qwerta369

    qwerta369 New Member

    Exact same problem here with my GT540. Did anyone find a solution? :confused:
  7. HonestGuvnor

    HonestGuvnor Active Member

    I am also having the same problem. Syncing with gmail deleted all the new contacts instead of syncing. That is about as serious as a bug can get!

    Does anyone know if gmail keeps a copy of what was deleted somewhere?
  8. eppo

    eppo Member

    Just found out that it does sync , but you have to change the view from in the contact settings to google sync.

    contacts/options/more/view from/googlesync.

    and any new contacts added on the phone must be of type googlesync and not phone or sim .

    works perfectly
  9. HonestGuvnor

    HonestGuvnor Active Member

    > contacts/options/...

    What do you mean by contact/options? In the contacts application I do not seem to have an options menu, in settings I do not seem to have either a contacts or options menu, in gmail I also have nothing that looks like contact or options,...? No criticism intended, I want to fix this!
  10. eppo

    eppo Member

    press the contacts icon . then the button above the green telephone answer button (menu key)[​IMG] . this will bring up the options menu , bottom right press on more, then view from, googlesync.

    just looked in the manual they call it the menu key

    Attached Files:

  11. HonestGuvnor

    HonestGuvnor Active Member

    Thanks for the input which has moved my understanding on a bit but the problem still remains. The current situation:

    If I add a contact and label it a "phone" type then when I sync with google it is not deleted. It is also not added to my contacts at google. This is the expected and reasonable behaviour (although I have no interest in maintaining mutliple different sets of contacts).

    However, if I add a contact and label it "google" then when I sync with google it is deleted from my phone and not added to google contacts. This is not the expected behaviour because it is not syncing and, far far worse, it is deleting user created data. The expected behaviour is that it would add the new contact (new because the creation time is after the last sync) to the set of google contacts on the phone and on google's computers. Does this happen for anybody?

    PS Syncing will transfer contacts from google to the phone. The behaviour is the same whether the syncing is automatically or manually triggered.
  12. HonestGuvnor

    HonestGuvnor Active Member

    There seem to be a zillion people reporting this issue but few posting solutions that work. In my case it was to do with the recent name change from googlemail to gmail for those in the UK (and perhaps elsewhere?). Unlike everything else, it appears that the contacts system is not picking up the name change somewhere along the line. The solution is to go to the settings in your email account at google (i.e. the one on the web not on the phone) and change the name of the account back from gmail to googlemail.
  13. HcMAX

    HcMAX New Member

    Hi,

    did anyone found out a solution to this problem?

    My brother bought a gt540 and the guy at the store transfred the contacts from the previous phone to the phone memory of LG, Now the contacts doesnt appear on the gmail.....

    Any suggestions?

    Appreciated

    Thanks
  14. HonestGuvnor

    HonestGuvnor Active Member

    You have to set up a gmail account and point the phone at it. In addition, each contact has a type (google, SIM or phone) and only the google contacts are synced with google. There is a fair chance you need to change the setting from SIM to google for your current contacts.
  15. HcMAX

    HcMAX New Member

    Ok thanks ....regarding the current contacts how do I change their profile to Google contact s so that they can be sync? Is there an automatically way? Its almost 1000 contacts ...

    Thanks for your help
  16. cca

    cca Member

    Unfortunately, no. Phone contacts can't become google contacts with the press of a button.
  17. Douzeper

    Douzeper Member

    Ok I just fixed mine I hope this helps others...

    !!!!!BACK UP Contacts to SD Card!!!!! then.........

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    "Manage Applications" - "ALL" - "Contacts Storage" - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc"

    Then reload contacts from backup and select Google.

    (this was on HTC desire)
    Daisydoo and Insomniac3 like this.
  18. elkay

    elkay Member

    !!!!!BACK UP Contacts to SD Card!!!!! then.........

    Ok, first question....how do you backup your Contacts to SD card :confused:

    Elkay
  19. cca

    cca Member

    No such option on the LG GT540 as far as I know.
  20. HonestGuvnor

    HonestGuvnor Active Member

    > Ok, first question....how do you backup your Contacts to SD card

    You can backup your contacts using a third party application like mybackup.
  21. elkay

    elkay Member

    So, used Mybackup to back up my contacts.

    Went through the motions, and restored my contacts.

    Unfortunately, Mybackup put them back the way it got them - no option to make them all Google contacts!

    So it looks like I need backup software that works like the Desire's !

    Les
  22. HonestGuvnor

    HonestGuvnor Active Member

    What type of file is the backup file?

    On my previous phone the contacts were stored in vcard format which is a plain text file. In order to make anything other than trivial modifications to the contacts I would copy the contacts from the phones memory to the PC, modified the files using scripts and/or text editor and then copy them back to the phone. If they are stored in an sqlite3 database file (which seems to be used a fair bit on Android) then you could make the modifications using SQL commands.
    elkay likes this.
  23. eppo

    eppo Member

    I synced all my contacts to the pcsiute , then exported them to a csv file and saved it on my hard drive....

    went to googlemail , and contacts and imported the saved file there , then synced from the phone, the contacts are automatically a google contact...

    long winded but a bit easier than editing 1000 odd contacts..

    hope it helps
    elkay likes this.
  24. qwerta369

    qwerta369 New Member

    I did the same. Worked fine.
  25. elkay

    elkay Member

    Thanks folks.

    - Mybackup produces an mbp file, I haven't investigated it.
    - I haven't bothered with LGSuite so far as some people have encountered problems, and I haven't found a need for it.
    - I'm not as popular as you guys...and my contacts need tidied anyway!

    I'll just sort them out manually as I review them :)

    regards
    Les

Share This Page