Phone continually asking to connect to wifiGeneral

Last Updated:

  1. squeemu

    squeemu New Member

    I have my phone set to not auto connect to wifi in the settings, and have checked several times to make sure. However, whenever I open the internet or any other app that uses the internet a list of wifi connects pops up asking me to connect, and my only other option is to select "not now, remind me later". Why does this keep popping up if I have "do not auto connect" selected? These same apps never asked to auto connect to wifi on my old droid phone.

  2. chrlswltrs

    chrlswltrs Well-Known Member

    Go to Settings -> WiFi -> press menu, and select advanced -> uncheck "network notification"
    Shadowydreamer and noseph like this.
  3. meggaplex

    meggaplex Member

    I have a similar but slightly different problem. I keep on getting this pop-up (randomly, sporadically; I haven't been able to detect a pattern):

    but these are my settings:

    I'd like to disable that first popup, since it makes my data glitch out. If I select the "Turn off wifi" option then the wifi does indeed turn off, but it also turns off my data. I have to toggle my data a couple times for me to get connectivity back.
  4. bbriggs169

    bbriggs169 New Member

    to quote the above user, I am having a similar problem with my wifi connection. My phone automatically switches to wifi when I launch certain applications. I have my wifi cut off completely, yet upon launch (of song pop, draw free, Facebook for Android, , Web browser.. Only to name a few), my phone seemingly takes it upon itself to attempt to connect to a wireless network, even though I have none listed as access points. In doing so, the app will show a "no connection" message and tender itself unable to be used. I have checked the settings in said applications, as well as the settings on my phone... and do so continuously. this problem happens frequently when my phone's battery is lower than 70 percent, and it never happens when my phone is plugged up. Can anyone help me solve this problem? It's getting to be ridiculous
  5. cheliiii

    cheliiii New Member

    So after a bit of trial and error with my husband we've concluded a solution to the issue with the Wifi turning on whenever any data session is initiated. So I had no wifi networks saved so I could verify the fix while at home. You must open settings>wifi turn on to view Optimize WIFI settings and Select the option to connect to Wifi when a known network is available finally set the device to notify you. What I deduced is, then when You launch data session the device will do a quick search verifying one of your connections isn't available and remain off. Silly really should be clear if no wifi info is configured there'd be no need to have antenna on in the 1st place. Glad that's over and now i can verify if it helps to improve my battery life! Enjoy!:)
    sfronde3 likes this.
  6. sfronde3

    sfronde3 New Member

    Perfect solution! Or close enough anyway! The version of the software that I have doesn't have a Wi-Fi optimizer, or an option to not search for networks. I had to take all the saved networks off and now the phone will search and then turn Wi-Fi back off. Still uses some battery, but much better than always having Wi-Fi on!

Share This Page