Phone is not detecting sim cardSupport

Last Updated:

  1. DIsLike

    DIsLike New Member

    Hey guys,

    I've had this problem for about a week now and I've subsequently lurked forums and tried to find solutions, however, there was none.

    I got my Samsung Galaxy S2 via Three (yes I know) and it was working beautifully for a good two months. All of a sudden, however, my phone simply wouldn't detect my sim card. Whenever I pull down the options menu ( or whatever you call it), it says No Service, and my tab at the top of the screen has a circle with a line crossing through it, meaning I haven't inserted a sim card.

    I've tried a factory reset, cold battery switch, etc. I've even put my phone in rice in case it may have been water damage.

    However, all of the above have worked to no avail. I've called Three multiple times, and they say it may be my Sim card, and the fact that it's old (wtf?), even though newer sim cards still don't work on it.

    Any help would really be appreciated guys, thanks alot.

  2. aceominous

    aceominous Well-Known Member

    Can you not take it back to Three and ask them to arrange a repair or replacement?

    why did you assume it had been water damaged?
  3. DIsLike

    DIsLike New Member

    Hi, thanks for the reply.
    Well what happened initially was that my phone was stuck in airplane mode, and I told Three about the problem, and they booked it in for repair. The airplane mode problem was fixed with a factory reset though, and I still had no signal.
    I still sent my phone to Three and it came back, with them saying the 'screen hanging issues have been resolved.' I think there was a miscommunication as to what the actual problem was.
    I didnt assume my phone was water damaged, I just wanted to be sure it wasnt.
  4. Zeeshi

    Zeeshi New Member

    Same problem happened to my phone there is no solution but to claim the warranty on the phone. Don't try Samsung support they are pathetic.
  5. sknight

    sknight Member

    Hi Guys,

    Similar problem. Brand new SGS2 (mine is International version, Unlocked). Froze last week and wouldn't recognise SIM card after restart.

    I upgraded the firmware a few weeks before, through Kies, to v2.3.5 (XWKI4). I'm pretty sure I was asked/forced to restart right after, though so the problem should have shown up right then, right?

    Anyway, I'm still trying to figure out how all this stuff works (kernel vs. firmware, CSC, rooting, etc.) but I THINK the XWKI4 version actually LOCKED my phone to a provider (not sure which one) and that may be why my SIM is not being recognised.

    My solution is to upgrade to a firmware version that will keep my phone UNLOCKED. I just don't know which firmware version and whhere to find it. So far, all I can find is the provider-specific ones like XWnnn, XXnnn, UGnnn, etc.

    Any suggestions or pointers would be appreciated.

Share This Page