Phone is stuck on 4G splash screen...Support


Last Updated:

  1. Vincredible

    Vincredible New Member This Topic's Starter

    Joined:
    Nov 9, 2011
    Messages:
    3
    Likes Received:
    0
    So I'm having the same issues that a lot of other users have been having. Phone shutting off at 70% batt or so, battery super swollen. On top of that, my widgets disappear every time the phone is rebooted, forcibly or just shutting off. Now, it doesn't turn on at all. Just gets to the 4G page and stays there, then it gets super hot before I have to take the battery out. Any ideas? I was rooted. I think I've unrooted and am on stock kernel, but I can't say for sure.
     

    Advertisement
  2. KitsapAndroid

    KitsapAndroid Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    743
    Likes Received:
    118
    You need a new battery. Plain and simple. This should fix the majority of the issues. The fact that your current battery is swollen is enough to replace it. It's also enough to point to it as the cause of your problems.
     
  3. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,760
    Likes Received:
    3,717
    Did this start to occur as soon as you unrooted?

    DS
     
  4. Vincredible

    Vincredible New Member This Topic's Starter

    Joined:
    Nov 9, 2011
    Messages:
    3
    Likes Received:
    0
    I ran into problems before I unrooted. It all stemmed from the battery swell. I think I messed up when I tried unrooting it. While restarting, I held down the UP Vol and did a full wipe from there. It cleared up the widget disappearing problem. Got a new battery today for free from a cool Sprint Store rep who was lazy to find one in the back to sell me. Apparently they have tons of spare parts lying around. Everything seems to run better now that I have a new battery. Hopefully this one doesn't start to swell like the first one. I've been trying to read into it, but has anyone pinpointed a reason as to why batteries have been swelling? I feel rooting plays a part or something.
     

Share This Page

Loading...