Support phone keeps deleting area code


  1. I've had a Samsung Mesmerize on US Cellular for around three weeks now and I love it so far but I just recently started having this problem. I added someone to my contacts, just her phone number no picture or anything and she's not linked to Facebook or Gmail. sometimes when I text her it will work fine. when it's working fine, her whole number will show up at the top of the conversation like this <xxx-xxx-xxxx> as it does with my conversations with anyone else. but just for this one contact and nobody else yet, it will randomly decide to delete the area code from the conversation even though it still shows up in her contact profile. so now in the conversation it's only showing <xxx-xxxx> and it will not let me reply to her when it is like this. the only fix is to delete the conversation, then delete the contact and re-create it. just deleting one or the other will not work.

    has anyone else had this problem? she's someone I talk to the most frequently so this is a gigantic pain in the ass. any and all help is greatly appreciated. thanks!

    Advertisement
  2. USCellularAndroid

    USCellularAndroid Well-Known Member

    I have not heard of this issue before. did you save the contact on your phone or on your gmail account?
  3. I just saved it to my phone.
  4. USCellularAndroid

    USCellularAndroid Well-Known Member

    Yeah I tried to ask around at work on this one, and I cant find the answer.

    Good luck on this one!
  5. abbnew

    abbnew New Member

    Hi. I just got this phone on Saturday and I have had the same issue just when I have tried texting my husband. Yes, what a pain. I have deleted him in contacts, put him in under abbreviated name, etc. and it still goes back to deleting the area code. So each time I need to text him I have to enter his number as a new text number and go from there. I am going to my USC store tomorrow to hopefully get some help from salesperson who sold it to me...he seems to know the ins and outs. I can let you know what I find out?!?:)
  6. USCellularAndroid

    USCellularAndroid Well-Known Member

    I was thinking about this one at work today, again, ha...

    Are you saving the contact as a "mobile" number? I had a friend who accidentally started to save all her contacts as "home" numbers. Then when she tried to text them, it wouldn't show the number since the phone "knows" you can't text a home phone.

    Just a thought, who knows if it will work. Good luck once again
  7. yes, I was saving it as mobile. yesterday while I was in Madison I decided to stop in and see if they would replace it and they gave me a new one, no questions asked. the new one isn't doing it and works perfectly.
  8. USCellularAndroid

    USCellularAndroid Well-Known Member

    Glad to hear everything worked out
  9. superman80

    superman80 New Member

    I am having this same problem..... i know one other person.. I have tried everything. I can text everyone but the one person im usually texting. Any answers?
  10. JimmyJams86

    JimmyJams86 New Member

    I am having the same issue - dropping area code for a specific contact on the Samsung Mesmerize from US Cellular (other contacts work fine). I have found discussion of this issue on the internet, but really not a solution yet.

    I wonder how you upgrade the operating system to see if this solves the issue.

    The person I am having problems with dropping the area code is the first person I texted on my phone. The second person I texted and others are just fine. I wonder if this has anything to do with it?
  11. Alethia

    Alethia New Member

    I love my phone, but I'm having the same issue. It's also on one of my most texted people, my sister. Mine is a bit different. I had my sister's cell phone number saved in my gmail contacts like this " (xxx) xxx-xxxx (sister's) " So when it transferred over to my phone it came over that way. I did delete it out of my phone w/the () and the (sister's) and saved it in the correct format...xxx-xxx-xxxx. I then selected the information I wanted for her defaults. So what happens that's so weird is this...when I text her (I'm in the texting screen, I select her correct number- xxx-xxx-xxxx- send the text) when I go back to the main lists of all my texts, the text that I just sent her is there and the phone number attachd to it is now with the "(xxx)xxx-xxxx (sister's)" So if it has the () and the word (sister's) in the phone number info so you can't reply to her in this message. To reply, I have to go back to the message screen and select her all over again each time-select the correct number xxx-xxx-xxxx or type it in manually. But it will then link it on to the same "(xxx)xxx-xxxx (sister's)" formated text again. I may not be explaining myself very well on this, as it is so weird.

    I went to the US Cellular store yesterday to fix this issue. We deleted all of her information out of everywhere...gmail, the phone, every text, every phone call...EVERYTHING. She was completely out of my phone. Then we had her text me. When it came in the phone it came in with the parenthesis on it and her (sister's) again!!!! OMG this is driving me CRAZY!! We can't figure out where that is stored at w/that information. I even took out the SD card and tried it...NOPE still in there w/that wrong format!!!

    Any suggestions?
  12. LaTuFu

    LaTuFu Well-Known Member

    Have you completely deleted your sister's contact info from your Google account?

    You can delete all of the info from your phone, but if its still in your google/gmail account it will link to it when you get an email or a text from her.
  13. RobsLost

    RobsLost New Member

    Having the same issue on 3 units, keeps dropping area code. I have tried unlinking contacts, deleting contact in gmail and the problem persists. I think I will be restoring them tonight, but might try deleting contact storage first. Has anyone had that solve it? Extremely frustrating because I can't figure out how it keeps dropping it.
  14. Woody1957

    Woody1957 New Member

    Same problem here... I see lots of posts with same issue but no solutions other than changing phone. I wonder if there is an update somewhere?
  15. Ronkat81

    Ronkat81 New Member

    I Think Jimmy Jam might be onto something.. everyone says that it is happening to the person that they text the most. If that is the case then it is very possible that was the first person that we all text initially. That would explain why it is just that one person. I spoke to a few people on my new Mezmerize that i just got yesterday, but when I sent a text message it was from my other US Cellular phone to this one and that is the number that I am having the deletion on.

    Has anyone Checked the Samsung Website? I am and if i find anything i will post it....

    Hopefully we can find something out. . . It is Aggervating and I can't take mine back yet because in my area all the stores are sold out of the Mesmerize :-(
  16. LaTuFu

    LaTuFu Well-Known Member

    I text all the time, to virtually the same 4 or 5 people. Have not had this issue happen at all. But I am in a calling area that still allows 7 digit local dialing. Are the rest of you in a 10 digit dial area?
  17. Ronkat81

    Ronkat81 New Member

    Yeah I am in the 10digit area... I can dial local calls minus the area code, but not for texts... all texts have to have the whole thing. I had another one do it yesterday finally... and this was the first time I had ever text this person from this phone!! GRRRR
  18. LaTuFu

    LaTuFu Well-Known Member

    I think thats where the bug may have an issue. Its total speculation on my part, but I would be interested to know if that is what is causing it. We have 5 Galaxy Mesmerize phones in our office now, none of them have duplicated this problem.

    Can you check the phone settings to see if there is an option for 10 digit/7digit dialing preference? If not on the phone, maybe customer care can do that?
  19. kcracolici

    kcracolici New Member

    My suggestion to help resolve this issue - deleete the contact completely from you phone, then have that person send you a text message (should come in as from unknown person, number only - assuming that you have deleted every aspect of that contact from your phone - reply to that sms, if it goes successfully, then save that number from the original sms creating it as a new contact for that person.
  20. JBER

    JBER New Member

    I tried this today and was successful:

    1. Settings> Accounts & Sync> select Google > turn off autosync for contacts.

    2. Pull up contacts, menu>display options> make sure each 'line' is checked for both phone and google, in others words all groups are checked; I did this because after deleting the contact in question, I found another entry after checking all these boxes.

    3. Delete all entries of contact in question.

    4. Send a text message manually entering the ten digit CTN.

    5. Once that person replies, add to contacts.

    That seemed to work, hope this helps. I did go ahead and turn google sync back on.
  21. Sunshyn

    Sunshyn New Member

    I am really trying to avoid a factory reset, which seems to be the only solution I
  22. I never found one. I went into the USCC store and complained and ended up getting a new replacement phone free of charge. I'm on my 3rd Mesmerize now and I haven't had this issue at all since my first one.
  23. Martyntroy

    Martyntroy New Member

    Hi. I to had this problem from day one. I'm thinking it may have something to do with the way the replying phone is calling/identifying its self self. I see a lot of users are having this problem w/people they may have got the phones with or on the same account. This is the problem for me its only my three family members are the only problem texts I have.
  24. georgiaruth

    georgiaruth New Member

    I have had this problem of phone dropping area code for text. It was driving me crazy. The two people my phone did it for were my boyfriend and best friend. I erased all of the msgs sent to those numbers and still it won't work. I think the problem is if you ever entered this number without the area code it remembers it that way. I called SPRINT and they said the only thing I could do was a factory reset and then MAYBE it would be better. I decided to do a work-around and installed a new messaging ap on my phone. I installed Handcent SMS for free and so far it seems to have killed the problem.
  25. luvcoffee

    luvcoffee New Member

    I too am having this problem. It only does it to one number and it's the person i text most too. I have sprint's epic (galaxy S) phone. I tried the different suggestions but it still does it :/

Share This Page