"Phone" key on HTC Incredible 2 not working, help!!!Support

Last Updated:

  1. TMac7254

    TMac7254 Member

    For some reason, when I go to press the "phone" key on my DInc. 2, it doesn't bring up my contact list, but shows the word "Phone" on a small grey bubble right above the phone key. I don't know why it's randomly stopped working, but the sooner the feedback the better. Any ideas at all are welcome! :confused:

  2. Martimus

    Martimus One bite at a time... Moderator

  3. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    I use this answer a lot, but factory reset is the only thing I can think of.
    That is unless you want to try installing dialer one from the market.
    TMac7254 likes this.
  4. missdcteacher

    missdcteacher New Member

    Mine is also doing the same thing, as of yesterday.... sooo maybe this could have something to do with an update that somehow got automatically installed? I just upgraded to a Droid from a feature phone about a month ago so honestly I have no idea, but I have had to pull my battery a few times already and that is aggravating. :mad: Tried that w/ this issue and it didn't fix anything.

    I wish there was a solution other than factory reset. I feel like I finally got my phone set up the way I wanted it.
  5. danbeltran

    danbeltran New Member

    Hi I recently started having the same problem on my incredible 2. Did you ever find a solution?
  6. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    Have you tried dialer one?
  7. janetfax

    janetfax New Member

    I just had the exact same thing happen. It had happened a month or so back and somehow I got the button to work again and I have no clue how I did it. I just pulled the battery a couple times and pushed all kinds of things, made calls that were in my address book, etc. Finally I took the suggestion of installing Dialer one that works! I am now able to dial people that aren't in my address book. Thanks for that wonderful suggestion. True, most people are in my address book, but it would suck to not be able to dial a number that wasn't....like 911? I hate technology sometimes...
  8. coachwalt

    coachwalt New Member

    This situation just happened this morning to my phone. Phone "button" does not work, and I can't seem to get this to work. I haven't tried to install the dialer one app. Not crazy about having to install a 3rd party app to make the phone work!

    Has their been any fixes to this problem since the last post?

  9. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    Pretty sure that unless you're rooted, dialer one is a band-aid and factory reset is the "fix". The files that are wonked are in the system and not accessible unless you have super user access.

    You could spend some time doing battery pulls, rebooting and using cache cleaners, but I doubt you'll get anywhere with those.
    coachwalt likes this.

Share This Page