Phone lags on 4gSupport


Last Updated:

  1. makisupa79

    makisupa79 Well-Known Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    64
    Likes Received:
    9
    My evo lags horribly on 4G. Scrolling, switching screens, apps, texting, basically every aspect of the phone. It's to the point where the phone is almost unusable on 4G unless I am tethering. I am not rooted and running launcher pro. Anyone else experiencing this or know of a fix?
     

    Advertisement
  2. vicshalls

    vicshalls Well-Known Member

    Joined:
    May 30, 2010
    Messages:
    390
    Likes Received:
    25
    Ya I have the same problem. Then when I switch back to 3g I have to turn my phone off then back on to get it to run properly.
     
  3. Palmetto Fellow

    Palmetto Fellow Well-Known Member

    Joined:
    Sep 24, 2010
    Messages:
    2,022
    Likes Received:
    323
    Welcome to the club. There are lots of people with this problem, but we aren't making enough noise. Check out my thread, and please install a CPU monitor of some sort and let me know what your EVO does during the lag.

    http://androidforums.com/evo-4g-support-troubleshooting/203542-100-cpu-usage-but-doesnt-add-up.html
     
  4. rkkeller

    rkkeller Well-Known Member

    Joined:
    Oct 25, 2010
    Messages:
    588
    Likes Received:
    105
    Try turning on 4G, then turning your phone off and then back on.
     
  5. marctronixx

    marctronixx Moderator Moderator

    Joined:
    Oct 12, 2009
    Messages:
    5,699
    Likes Received:
    3,503
    people have stated switching scenes and updating your PRL helps. i have personally done the PRL update and the 4g lag went away... this is indeed a widespread issue.
     
  6. Barats

    Barats Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    470
    Likes Received:
    37
    Yes it's BAD for me. The phone becomes unusable when I turn 4G on. I mean the phone is called Evo 4G, we pay $10 premium every month for this feature and the big feature of the phone makes it lag to the point where you can't use it? Someone dropped the ball on that. Don't know if it's combination of Sprint and HTC or who is to blame.

    I will try the PRL update and see what that does.
     
  7. makisupa79

    makisupa79 Well-Known Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    64
    Likes Received:
    9
    OK...now yesterday I noticed if I turned my phone off and back on, it starts with 4G on, how can I control/stop the phone from starting the 4G radio on start up? This happened all day yesterday, regardless of whether 4G was on or off when I turned off the phone. It also happened whether I did a battery pull or not.
     
  8. Barats

    Barats Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    470
    Likes Received:
    37
    I have noticed this, too and it only started recently. Even when I'm at home, which is not a 4G area, even for 4G to be on and scanning for a signal slows my phone down really bad. It used to never start until I turn it on. Now on a restart, it will start on it's own. I don't know if it's an app I downloaded that would want this to be on or what. I know there is a way to fix this. :mad:
     
  9. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    mine started doing this this week.

    no lag...but occasionally when I reboot via power on off or quickboot 4g comes on automatically at start up....not always and I can't seem to find the trigger
     
  10. shadowarz

    shadowarz Member

    Joined:
    May 25, 2010
    Messages:
    7
    Likes Received:
    0
    I and seven of my friends with EVO's have the same problem, i have called sprint and htc and they do not help, they seem to think that if i turn my phone in to the warranty department for fixing that it will help, even though i am telling them that a brand new evo in the sprint store also does the same thing. HTC claims that they havent heard of the problem before.

    I have done a factory reset and other things and nothing helps but restarting the phone every time i turn off 4g.

    I think sprint and htc have turned a blind eye on this issue since it looks like a good number of people are having this issue.
     
  11. Monticolo

    Monticolo New Member

    Joined:
    Oct 28, 2011
    Messages:
    1
    Likes Received:
    0
    Try to simply toggle airplane mode on and off. It seems to work for me.
     

Share This Page

Loading...