Phone not connecting via USB><>Support


  1. Kcsuper

    Kcsuper Well-Known Member

    Hello there! My phone is all of a sudden not connecting to my computer, or even recognizing it. I have bought a couple different wires (yes, I've also used the one that came with the phone) but my pc won't recognize it. I've also used the same wire on other phones and it works fine (on my pc). I'm pretty sure I have the right driver since it works on other phones (trans. ultra*). It's in debugging mode (CTmod apparently doesn't offer mass storage mode). It just seems like my phone is unrecognizable by the pc completely. Anyone that can help would be appreciated. Thanks

    Advertisement
  2. kolosus

    kolosus Well-Known Member

    Uninstall and reinstall the drivers? Try a different computer
  3. Caeadas

    Caeadas Well-Known Member

    CTmod does have mass storage mode, when you plug in your cable, it should have "usb debugging" and "usb connected", in your notifications. If it doesn't, something is broken.

    If you go to CWM recovery/ mounts and storage/ mount USB storage, its exactly the same thing as usb storage in the normal interface. If that doesn't work, try using the drivers from the Odin packages.
    mookdm likes this.
  4. Kcsuper

    Kcsuper Well-Known Member

    Ya...no notification or anything (on phone or the <beep> from pc). Something must be broken I just don't know what. It's not the rom cause I've used cm7, CTmod 2.4,5,6 with no avail. I'm downloading Odin FA19 now but it won't be done for an hour because I'm only using 3g.
  5. jrsummersill1

    jrsummersill1 Well-Known Member

    I was having the same exact problem a few weeks back and it was my usb cable. Got a completely new cable and it worked right away.
  6. Heloguy

    Heloguy Well-Known Member

    i had the same problem a while back. this worked for me:


    "Run "regedit" and select the "HKEY_LOCAL_MACHINE/SYSTEM/MountedDevices" folder. See all the "Dos Devices" listed? You'll have one entry for each physically mounted drive (HDD or Disc) plus you'll have one show up for each USB drive you attempt to insert. Double click each device listed and see if you see text saying something like "U.S.B.S.T.O.R...". Once you find that device, right click it and select "Rename". Now change the drive letter to something unused... like Q: or something. Close regedit, disconnect the USB device and reconnect again.
    Mic Dem and manocskaa like this.
  7. plcahill

    plcahill New Member

    I'm not sure you'll see this, but I just wanted to thank you. This worked for me. Do you have any idea why? Just really, really curious.

    FWIW I'm on a Virgin Mobile LG phone, and was having the exact situation described in this thread -- cable is charging the phone, but computer would not recognize the phone when plugged into any of my 4 usb ports, or maybe more accurately, the phone would not present the usb notification, and therefore I was unable to synch, or otherwise transfer stuff from my phone to my computer, etc. I changed the drive letter of the usb port I normally plug my phone into as per your instructions, and voila, it's working. (It remains to be tested whether it will continue working day after day, hence the reason I'd love to hear WHY this works.)

  8. momokit

    momokit New Member

    I've noticed in CTmod that the notification curtain that you can pull down from the top of the screen has options for me that made the files on my SD card viewable as a drive on my computer. I have a mac, and have yet to try it on my pc. But here's what I found:

    1- Pull down the notification curtain.
    2- Look under the 'Ongoing' section.
    3- See if you have an entry that says 'USB connected', and click on it.
    4- That should bring you to a screen that has a button named 'Turn on USB storage'.
    5- Now your device should show up as a drive on your computer.

    You should be able to go home on your Android device and leave it in USB storage mode, then just choose the eject option on the computer to disconnect the device (and theoretically you should go back the to screen in step 4 and choose 'Turn off USB storage'...but I don't think that's as important as telling the computer to eject/disconnect the drive).
  9. vce2005

    vce2005 Well-Known Member

    Hmmmmmm, I only turn on and turn off the USB on the phone..... I never ever "eject" or "disconnected" the drive on the comp..... Never had a problem
  10. EarlyMon

    EarlyMon The PearlyMon Moderator

    Trust me, I promise that is rolling the dice and coming up lucky.

    It's really best to eject from the pc side first. ;) :)
  11. cwhatever

    cwhatever Life Goes On Guide

    The same for me, I always just turn off on the phone side and then disconnect. Been doing it that way for thousands of times. Now for my camera and other devices that I have the PC says disconnected device, for the phone it never gives that up so I never did it. If its luck ,I'm super lucky because I've never had a problem yet. But thanks for that info maybe I'll start doing that.
  12. vce2005

    vce2005 Well-Known Member

    It really never, ever affected anything if I just disconnect on the phone and than unplug..... without the "eject"...... and it just depends how you have set up how all your drives are handled in your device mgr........ The only real problem you can run in by just "unplugging" a USB device is, that the "read/write delay" comes in place when you toooooooooo quickly unplug and the comp or device is still writing a file..... Than the copy process could fail, the file could be corrupt, etc......
    So if I need to copy files freom and to the phone, I just give it an extra 10 or 15 seconds after the copy window disappears, than I turn OFF USB on the phone and unplug...... Never had a problem with any USB device doing it like that......

    Just my thoughts.
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    Ok, it's your phone.

    You may right.
  14. vce2005

    vce2005 Well-Known Member

    Nope, don't know...... Maybe it has something to do with the USB unpligging and people wrecking theior phones....... MAybe MTP is safer for "mass-use" !!

    I just know from my own experiences, that since true "Plug-n-play" came into the picture, I never had any troubles with just unplugging a USB device...... But hey, it all depends on your setup.... If you go to your device manager and then to "Disk Drives, under "POLICY" these options also ( usually ) apply to external drives once connected..... And yes, I totally agree, that something could happen by JUST unplugging a USB device, just said, I never ever did it and never had trouble. Well, maybe MTP will change all that and be safer !!! ;)
  15. wyelkins

    wyelkins Well-Known Member

    I am not sure about the proper ejecr process either, but I have always made sure that both the PC and phone are finished with I/O.

    I tend to attempt to eject the device First from the tray icon and then stop USB mass storage on the phone. This works and I have never had a corruption.

    If the PC says that it is not safe to Eject, I wait a minute and try again. If it still says this, I close phone USB and try it again. If the PC is still busy, I do an orderly shutdown of Windows. I wait how ever long that takes. After the PC is off, I unplug the phone.

    Probably a little too cautious, but I don't want problems with the phone. I can't remember ever having this problem with the phone but it has happened with other Mass Storage USB devices. If it did happen with the phone, that is the procedure that I would recommend.

    I must admit that many times in the past with thumb drives at work I haven't been that meticulous and just snatched the USB. But that was in cases that were not mission critical where a corrupted Spreadsheet would be obvious. So instead of shutting off the PC, I would just plug the thumb drive back in and try to load the file to check for corruption. Even then the copied file was almost always fine.
  16. vce2005

    vce2005 Well-Known Member

    In XP, I had some I/O error experiences with mass storage.......... but never in Vista or Win7 ! I mean, Heck, it's called "plug'n'play", not "eject'n'play"........ Grinzzzzz Doesn't make a difference if it is a phone or a thumb drive as mass-storage.... As long as you're not unplugging during copy or installing or Odin, etc..... there should nothing happen......

    But I don't try to convince all you guys who are cautious and using the "eject"..... I am probably just "to-more-click-to-lazy" and have to learn the hard way if I "just" unplug.... ;)
  17. wyelkins

    wyelkins Well-Known Member

    In my case, it probably is a hold over from XP and prior days. I know Vista and Win7 are more forgiving, but I still don't trust 'Em. Lol.
  18. wetbiker7

    wetbiker7 Well-Known Member Contributor

    I've always done the same thing VCE. Guess I'll change my MO. :D

    :thumbup:
  19. EarlyMon

    EarlyMon The PearlyMon Moderator

    I'm not a Windows expert by any stretch of the imagination, just tossed that out based on problems I've seen posted on the forums in general. :eek: :)
  20. wetbiker7

    wetbiker7 Well-Known Member Contributor

    You're correct. That is the proper procedure for disconnecting a device. It is supposed to be ejected from Windows.

    I've never heard of it causing any problems with Windows 8 but I have heard of it causing problems with older versions of Windows.

    When you look at the big picture, I guess it's best to do it the way that's recommended. That eliminates the chance of anything getting damaged or data loss.

    Edit : all other devices I use are ejected properly. I just figured that the Android was safe since sd access was a cut via the phone when selecting to switch from mass storage. Better to be safe though. :D
    EarlyMon likes this.
  21. Michael Keyes

    Michael Keyes New Member

    Simple solution: Disconnect your USB. Shut-off your phone. Remove the battery and re-install it. Turn your phone back on and connect the USB. Walla! Instant fix!
  22. ForenN

    ForenN New Member

    I have tried to do this, but it doesnt work for me, have any suggestions how to fix it? i can connect my phone to other computers using the same cable
  23. Vorda Warlord

    Vorda Warlord New Member

    Belive me...I tried all types of drivers and nothing seems to help,not even cord switch,but i found a solution to this problem,and its way too simple and easy.When someone says "All you have to do..." he knows nothing about it and he missed the thread.
    I belive i have found a solution because after my Firmware Update of Jelly Bean 4.2.2 my Telefunken tablet couldn't connect MASS Storage to PC...so i tried to reinstall my firmware so I turned it off and pressed "-"and "Switch button" and it switched on over safe mode...after i connected my USB cord it prompted me to turn on the Mass Storage...after i did it showed up on my PC!!!

    !!!!Just switch on using "Safe mode" it works!!! [​IMG] Happy New Year!
Loading...

Share This Page