Phone not functioning properly (AT&T)Support


Last Updated:

  1. KazmanN

    KazmanN New Member

    I'm trying to replace my dying Samsung Captivate s1. I had an issue with my s2 that I couldn't fix about 8 months ago which is why I'm still using my s1. I think now is the time to get it working how it should. I bought the s2 when I was in Bahrain for work, back then it was working with the Batelco network which is one of the service providers out there. I had the phone rooted at one time and was running a beta version of ICS before there was an update available for the s2. Basically what I'm saying is the phone was working perfectly fine then. As soon as I got back to the states I decided to flash it back to factory settings, which is...

    Model: GT-9100
    Version: 2.3.5
    Baseband: I9100XXKI4
    Kernel: 2.6.35.7-I9100JPKJ2-CL655700
    root@DELL143 #2
    Build: GINGERBREAD.JPKJ2

    The above is the current flash. The phone drops calls constantly, signal is very inconsistent, 3g doesn't work, my blue tooth ear peace won't connect, and samsung KIES can't find firmware updates. So basically anything useful about this phone doesn't work.

    I've tried to find the factory kernel because I don't think the current one is right. It seems not many people have the "JPKJ2" version because I've looked concerning the issues.

    If anyone has info that would resolve my issue or point me in the right direction that would be awesome. And of course thanks for your time.

    Advertisement
  2. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums KazmanN! :)

    This is the OJP, Gingerbread, Samsung firmware for the Middle East which contains the European modem, (baseband), XX, which is not particularly compatible with North American networks.

    For reasons that the phone will not update via Kies, see under the heading, "ICS is available for my code but I cannot update", in post #1, here.

    My suggestion would be to flash the only North American firmware for the Galaxy S2, which is for the M variant. M stands for the modem software which is more compatible with N. American, (Canadian), networks.

    The unbranded, Gingerbread, firmware for this is, I9100MBMCLD3.
  3. KazmanN

    KazmanN New Member

    Sorry for the late reply. I've tried the firmware you recommended, and so far so good. The only issue I'm having now is the bluetooth isn't working still. I've read up on it, and it seems to be a kernel issue :dontknow: The good thing is the phone is actually functional now.

    I'll keep reading up on it. Thanks again
  4. ironass

    ironass Well-Known Member

    Try, "Clear data", in Settings > Applications > All > Bluetooth Share and then reboot.

Share This Page