Phone not registering my SD Card


Last Updated:

  1. basscommander

    basscommander Well-Known Member This Topic's Starter

    Joined:
    Apr 5, 2010
    Messages:
    45
    Likes Received:
    1
    So, I was having problems with my Hero not playing videos that were on the sd card, also having problems playing videos on the youtube app. So, I did a nand restore. I also did the restore because my phone was being laggy after installing the DB-OC kernel to speed up the phone. So, I nand restored back to before I flashed the kernel. So it is now running Aloysius 2.1 LWP non-OC. But, now all of a sudden my phone wont register my SD Card...at all. I run Dark Tremor app2sd, and can use some of my apps, while others just force close, or hang. I shut my phone off, and put in a different SD Card, to see if the phone was not registering it, instead of it being the card itself. The phone didn't register the other card. So, I put in my original sd card after turning the phone off again, and it still isn't registering, and is force closing many apps.

    Does anyone know what to do in order to fix this? I have no idea why it even started having this problem registering the sd card, as it was reading it just fine earlier. I would do a complete wipe of the phone, and sd card, but am not sure if that will make the phone register the sd card again. When I put my sd card into my laptop, the laptop read it just fine. Please, someone, help me fix this problem! :( Should I wipe the phone, and sd card, and repartition the card? Or should I boot into recovery and select "wipe data/factory reset"+"wipe dalvik-cache"+"wipe SD:ext partition"? Or will that not solve the problem?

    Thanks for any help you guys give on this issue!
     

    Advertisement
  2. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,820
    Likes Received:
    4,750
    Try rebooting the phone.

    If that doesn't do anything, backup your SD card onto the computer. Put SD card back into the phone and reformat it. .::OR::. Try another SD card.


    It may be a problem with the SD card OR with the phone.
     
  3. basscommander

    basscommander Well-Known Member This Topic's Starter

    Joined:
    Apr 5, 2010
    Messages:
    45
    Likes Received:
    1
    How do i reformat my sd card, then repartition it? My laptop took a dump today and wont work. Plus my phones bein buggy so i gotta check the forum from the phone, which is a crapshoot. So any and all info is appreciated
     
  4. basscommander

    basscommander Well-Known Member This Topic's Starter

    Joined:
    Apr 5, 2010
    Messages:
    45
    Likes Received:
    1
    Well i fixed the problem, not sure how tho, lol. I did another nand restore, didnt fix it, i then got mad and threw the phone to the floor. Its now registering the sd card, and is now working great, go figure lol!
     
  5. JB in AZ

    JB in AZ VIP Member VIP Member

    Joined:
    Oct 27, 2009
    Messages:
    1,869
    Likes Received:
    267
    Disclaimer: Don't try this at home. :D
     
  6. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,820
    Likes Received:
    4,750
    Lol, but if that's what it takes to get it working ;)

    Glad it's working OP. :)
     

Share This Page

Loading...