Phone not working !Support


  1. amir88

    amir88 Active Member

    Hi people,

    I have Telus Samsung Galaxy S2 X, I never rooted my phone. Suddenly today afternoon, I wasn't able to send text messages nor make calls. Receiving texts and calls is just fine. Also, my keyboards pops up but I can't type. No matter which keyboard I choose, I can't type. I reset the phone many times, took out the sim card and SD card and tried different things, but nothing happened.

    Also when I connect the phone to my computer, my PC recognize the phone, but Samsung Kies doesn't. And I can't mount my phone on USB Storage mode as well.

    I tried to root the phone, but my phone gets stuck at the "downloading" part when it wants to install the superuser file.

    Everything else on my phone works. What should I do? My friend told me that I should factory reset my phone but that's the last option for me!

    Please help me as I need my phone so bad!

    Thank you in advance.

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    Hello amir :ciao:

    With so many different problems I think your friend is right. I would also suggest a factory reset. Then you will at least know its not some app causing the problem.
  3. Captain Mal 78

    Captain Mal 78 Well-Known Member

    I'm having a similar issue and I'm running stock ICS and not currently rooted. Keyboard will pop up, but nothing happens when I type on it and when I click on someone's phone number, nothing happens. I can still receive texts and other apps work just fine. I cleared the cache, but that only made everything work for a short period of time. Did you factory reset the phone and if so, did it work?

    I suspect it might be the smooth calendar app since it's been running sluggishly since the last update. I uninstalled it and reinstalled. Nothing changed.

    At one point it said, "Activity Phone is not working Would you like to close it?" What the heck is "Activity Phone"? I got this message when it locked up in my contacts.
  4. Atma

    Atma Well-Known Member

    Hi capt. Try going to recovery and wiping the cache partition. If you don't know how to do that, look at the last step in the sticky how to Odin any stock ROM. Don't do the wipe data part, just the format cache partition. See if that helps.
    Captain Mal 78 likes this.
  5. Captain Mal 78

    Captain Mal 78 Well-Known Member


    I tried that last night and it only helped for a few minutes. I finally uninstalled smooth calendar and then cleared the cache. No problems since I did that. I checked the google store this morning and the dev rolled back smooth calendar to the previous version since a lot of people were having problems with the latest update.
    Atma likes this.
  6. Atma

    Atma Well-Known Member


    Good, hopefully that will fix it for good. Thanks for the info about the app. It may help someone else. :)
Loading...

Share This Page