phone questions :)


Last Updated:

  1. owned66

    owned66 Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    0
    hi all
    read this if you want to know my history first

    http://androidforums.com/introductions/91553-hi-all-my-phone-history.html#post865574

    anyway i want a new phone but i was confused about the news i heard
    some phones arnt able to upgrade to the newest android OS (ie 2.2)
    like the HTC
    what i want to know does it have to be a google phone like Nexus One to be fully supported (future proof) (ie apps)
    and another thing is there any rumors in the web about the next google phone ? i was waiting for a tegra phone since 2008 and the only device that exists that has one is the Zune HD .....

    thanks
     

    Advertisement
  2. owned66

    owned66 Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    0
    and is it possible for any version of android to be installed on the Omnia HD i8910
     
  3. owned66

    owned66 Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    0
    bump
     
  4. owned66

    owned66 Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    0
    bump
     
  5. takeshi

    takeshi Well-Known Member

    Joined:
    Dec 6, 2009
    Messages:
    3,354
    Likes Received:
    281
    No. You're just likely to get faster OS updates with a Google experience phone.
     
    owned66 likes this.
  6. owned66

    owned66 Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    0
    is it true some apps cant run on certain android phones ?
     
  7. owned66

    owned66 Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    0
    bump
     
  8. Ngo93

    Ngo93 Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    586
    Likes Received:
    39
    Yes, some apps require a higher version of android to run
     
    owned66 likes this.
  9. Thefoodman52

    Thefoodman52 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,314
    Likes Received:
    329
    If you're looking at getting an older Android device (G1, Mytouch 3g, and so on) you're probably not getting 2.1. If you get a new one, you're more than likely to have 2.1 already running, then an update here in the near future to 2.1.
     
    owned66 likes this.

Share This Page

Loading...