Phone randomly selecting items...General


Last Updated:

  1. BATZ

    BATZ New Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    4
    Likes Received:
    0
    So the past month or two, my Eris has been randomly highlighting/selecting icons, shifting from the home screen all the way to the screen on the left, and moving the cursor around as I type, making it difficult to text or search.

    I did some reading from other people that had the same issue and others replied saying it had to do with the trackball. I have had my phone replaced three times and all have the same issue.

    Has anyone else had or know of anyone having this issue and might have another theory of what's causing it?

    Thanks
     

    Advertisement
  2. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    The scrolling of the screen in one direction (to the left, esp) sounds a lot like trackball issues.

    Sometimes this can be identified as the problem by making it appear/disappear when the USB cable is plugged in (and you shift the cable around a little).

    OTOH, the selection of on-screen items sounds more like a problem with the (capacitive-sensing) touchscreen. That's a much more rarely-occurring problem though, and when it happens, it usually is localized to one region of the screen.

    Perchance, do you use a screen protector, and have you used the same brand on all three phones?

    Seems more likely that it's a trackball problem, since a lot of people have reported problems with them.

    eu1
     
  3. BATZ

    BATZ New Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    4
    Likes Received:
    0
    Thank you for the quick response.

    There is actually no screen protector on the phone. Only the first phone I had that originally had the issues had a screen protector.

    You're right, it does seem to happen more frequently when the USB cable is plugged in, but still occurs otherwise.
     
  4. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    There are a bunch of threads over in the XDA Eris General forum relating to trackball problems, including a tutorial on manually replacing them

    IIRC, other users have speculated that the mechanical strain of plugging/unplugging the USB connector has something to do with the development of trackball problems.

    I'm not sure that I would recommend replacing the trackball yourself unless you are handy, and it's the last resort (no warranty) - get yet another replacement if you can.

    Something to consider is that if one out of ten or one out of 100 Eris develop a problem with their trackball, for you to experience it 3 times on 3 different units suggests that there is some way that you are using the phone that tends to make the design problem with the trackball show up more quickly. (Do you use a cradle or charging station? Do any of your USB cables fit a little too snugly in the connector? Do you use the trackball frequently? Does the phone ever "dangle" from the charger on the cable? et cetera)

    I'm not trying to place blame on you, I'm just suggesting that if you get another Eris as a replacement, the design problem will still be there, and it is likely that the problem will recur. There might be something you can discover about the way you use the phone that will give you some ideas about being a little more "tender" when inserting a charging/USB cable into the phone.

    good luck

    eu1
     
  5. BATZ

    BATZ New Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks again for the response again.

    Actually, I haven't thought about how I'm handling the phone. Normally, I'm very careful with things but it's possible I might cause damage from the USB cable. Never used a dock or any other type of charge other than the USB charger it came with.

    Thank you for your help!
     
  6. jumperwire

    jumperwire Active Member

    Joined:
    Nov 24, 2009
    Messages:
    36
    Likes Received:
    0
    I called Verizon today about that issue, especially when plugged in. We did the Factory Reset. I was skeptical, but it worked. I don't know if the problem will return, but for now I am happy. Just my .02
     
  7. thrawn86

    thrawn86 Well-Known Member

    Joined:
    Aug 3, 2010
    Messages:
    512
    Likes Received:
    33
    I started having this issue a few days ago, no notable changes. both a factory reset and switching to xtr sense did nothing, in fact it was so bad during the xtr google quick setup I was almost unable to type in my google password.
     
  8. rvpartsguy

    rvpartsguy Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    308
    Likes Received:
    25
    I am on my 4th Eris, one of them replaced for this exact reason, and my current refurb with the same issue ....just dealing with it now .....probably get it swapped again once I get settled in GA

    you will probably notice it will do it more when the phone is plugged in
     
  9. DaveDragon

    DaveDragon Active Member

    Joined:
    Apr 22, 2010
    Messages:
    26
    Likes Received:
    4
    Got my Eris replaced 2 days ago because of the same problems. It had been growing for 2 months and finally the phone was unusable. I hadn't had any other problems so I lived with it. I'm hoping the replacement doesn't bring any problems with it since it's a refurb.

    There seems to be plenty of Eris's around here for replacement. They had 11 in stock. The first store went to wasn't authorized to swap out phones, but they were still selling them! $80 for an obsolete phone!!
     

Share This Page

Loading...