1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Phone Ringtone won't change

Last Updated:

  1. vet3shaws

    vet3shaws Active Member

    I've set my phone ringtone, but a podcast plays instead. I've been trying to fix this for 10 days, so I'd appreciate some help. The following steps have all failed. I list them so we can consider what else to do.

    I. I've checked the basics:
    I've changed the Settings / Sounds / Incoming calls / Phone ringtone (for the default ringtone)
    Under the individual contacts, the custom ringtone would not ring, still the podcast.
    I've created a ringtone in Ringtone Maker and Ringdroid, both didn't set either.

    II. Continuing the failing streak, I've also tried different programs, uninstalls and reinstalls, clearing data:
    I've uninstalled Zedge, and Handcent. Setting the ringtone in Android System.
    I've reinstalled Zedge and Handcent, selected in them, no change.
    I've reset the storage : Settings / Applications / Manage Applications / Media Storage, "Clear data"

    III. So I tried to narrow down what exactly is happening:
    After renaming my podcast folder, from Music to Musics, it still rang the podcast. So it's not using a podcast ringtone in that folder.
    After unmounting the micro-SD card, nothing rings. Next I set the default ringer as one in the ROM. After re-mounting it, the podcast rings, argh! So it's referring to it somewhere on the SD card, not the ROM.

    So I'm left trying to delete the unbreakable podcast ringtone, but I don't know where it is. It plays too short for me to tell which one it may be. But it's definitely somewhere else than in the Music podcast folder.

    That makes me think another program, maybe a music program I once used, may have set it as that. I've done so much customizing in the recent weeks, I don't know which or what app could have done that.

    I renamed the BeyondPod folder on the SD card, so now I know where the podcast ringtone is. It's not in the music folder. Why there's 2 folders for podcasts, who knows! But moving in the right direction.

    Next I set another custom ringtone again. No fix. I tried to fix the CM7 ringer profiles, no good. I tried a ringtone that came with TickerGuy's Rom, which I'm using. No fix. It vibrates, but doesn't ring!? Restoring the original name to BeyondPod, now all I get is the vibrate, but no ring. Under Sound Settings / Volume / it does test preview correctly. But under an actual test call, it just buzzes! Good bye podcast, hello just vibrate... great.

    Just for giggles, I unchecked vibrate; but now when I call, it vibrates!? Ringer is up, vibrate is off, does at it pleases, now with no sound. So as strange as it sounds, something is not allowing me to change the ringtone or the vibration settings, but it is seemingly enforcing it's settings that it was told.

    Unaware of registry tweaks, programming, etc., I thought I'd retry some basic steps again. I launched Music set a ringer there. Just vibrate. I set my testing number I'm dailing from, my home line, as default ringer. It vibrates. It all tests well, under the audio settings, it takes, remembers, but doesn't act on it. Something is intercepting it. I did try some 2 Full-screen Caller-ID apps. Which was probably the start of it. What to do!

  2. vet3shaws

    vet3shaws Active Member

    I reinstalled FullScreen Caller LITE. I let it ring, it played enough of the podcast ringer, that I now can find the podcast in BeyondPod, and delete it. (Good thing I didn't have to delete my whole podcast folder, it's huge.) Yet after deleting it, it rings and vibrates, which is better than not ringing, but it rings the podcast still, even after deleting it from the Podcast folder!

    Incidentally, changing the notifications sounds for my SMS does work. So I am able to change sounds, but not ring tones.

    Since it's still vibrating, even though I've turned it off, maybe that's a clue, of what I can do next?
  3. agentc13

    agentc13 Daleks Über Alles VIP Member

    Looks like you did a lot of troubleshooting, that's nice to see.

    Have you tried deleting the BeyondPod app and seeing if it is that apps fault? I am not sure that renaming the folder will make make it not recognize your podcast.

    Do you have a Nandroid backup? Try restoring that.

    You could also move your important files from your sd card onto your computer (so you don't have to re-download them) and do a fresh install of your ROM (wiping /system /data /cache and dalvik cache).

    p.s. Since I see you are running CM7 I will move this to the ATR section.
  4. also try re-assigning or deleting the podcast?
  5. vet3shaws

    vet3shaws Active Member

    Hey Guys, I appreciate hearing from you. Good news, it's working, but not sure how long it will.

    For those who may deal with the same problem, I'll record the "solution" here. First of all, it may have taken some resets for any of the multiple fixes I've tried to eventually work. But the most certain fix went along the following direction:

    1. First delete the podcast after it was found.
    2. Then to re-install the trouble apps in question, namely the Full screen caller ID apps.
    3. After each re-install, I stopped the service and app, disabled in the app first if I can, but also anywhere else.
    4. Then cleared the cache, any storage and settings. Then I uninstalled again.
    5. Just in case, I re-flashed the ROM, twice for good measure.

    Eventually, the test went good. Yay!
    iSnow likes this.
  6. congrats!!!!!!!!
    vet3shaws likes this.

Share This Page